Performance Mode

My laptop running Zorin OS 16 has Ryzen 7 5800H processor. I use an gnome extension called Vitals and at no time it shows the CPU freq greater than 3.6 GHz (my CPU has support for turbo boost so it can go 4GHz+).

How can I be sure that turbo boost is working? Or could the extension be showing inaccurate values?

Try this in your terminal after enabling turbo/performance mode
watch "(lscpu | grep MHz)"
and see if your cpu is running 4GHz

Thanks for that thing. I didn't know the freq would be updated in lscpu output.

Anyways, it's not going beyond 3.6GHz even if I stress the CPU. I have 16 threads so I stressed all of them using stress command.

Is there an extension or something to enable performance mode? I've seen something like that when I used Pop!_OS.

This might help

Yes run
sudo apt install indicator-cpufreq
and it should appear in your taskbar and then choose performance

1 Like

I could see the indicator, set it to performance, but no - the CPU doesn't go beyond the base clock.


I don't see 4Ghz+ freq option....

Mine is an Asus Vivobook 16X with a Ryzen 7 5800H CPU. And according to the CPU specs, Turbo boost is indeed support but in the BIOS I do not see the turbo boost option. Does this mean Turbo boost is not going to work?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.