Performance tanks on Battery mode

I want to switch from Windows to Zorin on my Surface Book 2. I installed Zorin 16 core and am booting from the Linux for surface kernel (https://github.com/linux-surface/linux-surface). Everything works just fine as long as the laptop is connected to power, but when it runs on battery the performance drops dramatically to a point where it is unusable. I cannot even move the mouse properly. I tried to remove any power-saving tool on ubuntu that I could find but was not successful.

If anyone knows what else I could try it would be greatly appreciated.

I would recommend installing the Surface Kernel and testing it on performance:

1 Like

As mentioned in the question, I already did that. And I can see both batteries and their status.

Can you review this:

I understand you can see your battery. That links title relates to that particular users problem - My interest was in the guide that was the reply... Since tracing your steps and ensuring everything was done correctly often works wonders.
However, the guide linked above in this post may have some more pointers. It is a little old...

It may also be that the Surface Kernel is not the way to go and should be replaced with the 5.8 kernel.

sudo apt install linux-headers-5.8.0-63-generic linux-modules-5.8.0-63-generic linux-modules-extra-5.8.0-63-generic linux-image-5.8.0-63-generic

1 Like

Thanks for the answer. The answer in the first post references the github page of linux-surface, which I used. I checked the steps again and it appears to be exactly what I did.

I booted the system with the 5.13.0-28-generic kernel and the problems persist. Is there something special about the 5.8.0-63-generic Kernel?

There seem to be a lot of regressions in these later kernels. The 5.8 is the last most stable kernel I have found.

2 Likes

This solved the problem, thanks!
Although not being able to use the touchscreen and pen is kind of a deal-breaker for me :frowning:

Looking round... Some say that the 5.15.13 kernel works and the touchscreen and pen work on it. But not on the 5.16 kernel...
From this source, it states that this is due to an Ubuntu introduce APT bug, not due to the Mainline Kernel or to Debian. Way to go Ubuntu.
The workaround to install the 5.16 kernel is to install the individual packages by downloading them, then running the sudo dpkg -i ... command, instead of installing through APT.

Source:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.