Permanently disable CapsLock-Key

I want to turn off the CapsLock key when starting Zorin Pro. The command
setxkbmap -option caps: none
basically works. However, it - entered as the start app - is not taken into account. I have to turn it off manually every time I start it.

Switching off the touchpad as a starter works perfect:

xinput set-prop "10" "Device Enabled" 0

Thanks for any help.

Have you tried using a different command like xmodmap -e 'keycode 66 = ' . If 66 isn't the keycode for caps-lock in your device, run xmodmap -pke in terminal and find the keycode for it. Then try setting it as a startup application and be sure to enable it.

This could solve the setxkbmap issue:


Thanks for ideas, your solution worked!


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.