Persistence support not working with uefi mode

Hello guys i was searching for an os which supports usb persistence for my office work so that i can be able to carry my os with me where i go and heard of zorin . I made zorin os 15 education bootable pendrive with persistence support with rufus,unetbootin and others again and again but it persistence didn't seems to work with both the uefi and legacy boot in my hp pro book x360 .
I checked for my bios setting it was all fine but persistence was not there , the persistence partition was shown on the desktop but i think zorin was not using it.

Atlast i tried the usb to my friend's 10th century lapy it worked with legacy and old bios.

Please help me about persistence zorin is cool and pretty much better suited to me .Also ubuntu persistence didn't work.

1 Like

casper-rw maybe the issue> ?

1 Like

Have you tried using Ventoy?

2 Likes

Yes sir i had tried using ventoy with the casper rw file but persistence again didn't work i can just see that partition on my desktop.

Member @zabadabadoo has also experienced this issue. Aside from what you have tried already, I do not know of a way to help on this one.
Usually, adding the casper-rw and editing syslinux.cfg to add --- persistent" after splash should work. However, there is a Casper Bug:

This may be affecting you.
Using a Debian Distro should work, since it does not use Casper (That is an Ubuntu thing).
Lastly, some have said that using Linux Live USB Creator was able to create a persistence build, where other etchers failed.

Yup. I tried Z16 Core and Z16 Lite with 2048M persistence set in Unetbootin, but did not work. Search suggests problem with all Ubuntu based distros >18.04, assume related to Casper. Boot USB persistence with Z15 is OK.

yeah, only kali linux did a work for me but i am thinking why zorin persist in a 10 year old laptop? with legacy support instead persisting on my uefi based new laptop:|( .
But thank you guys i hope this problem will be resolved in future but i personally say that i love zorin os a most awaited linux for every kind of user.
(above optimus prime, its me i forgot my user id now i realized and logged in)

ok i did a try with ventoy again: MBR on secure boot mode enabled.

but this time with 1.0.64 ventoy and ventoy plugson and keeping the casper persistence file in the main D:/ventoy folder and keeping the iso separate in D:/ISO and then using ventoy plugson i updated json file . And after that it worked on uefi . Both zorin 16 and 15 worked.
Thanks for support @Aravisian


I think mounting persistence first with ventoy working well than other creators like Rufus,etcher etc... . Give it a try it worked for me.

1 Like