Zorin Forum

Phantom Mouse Cursor In Pages

I have a phantom mouse cursor showing up in most page. It does not move and there is no wireless mouse attached. Both mouse and keyboard are wired.
Mose cursor

Hi and welcome to the zorin forum,

All i see in your image is white only, does it looks like this ?

From what i could find fast is to turn off the second screen in system settings > displays

Or this one

system settings -> screen display and checked the "Mirror Displays" box

Maybe i am blind but i don't see a black arrow in the bottom line.

NO, I'm the stupid one. It is not showing in the screenshot. But it is in the screenshot if I open it. I am having trouble attaching the image. I will try another screenshot. I guess it something in my computer as the arrow stays fixed when I scroll a page and does not show in any screenshot. It seems to be on top of the page as even my real mouse cursor goes underneath it.

Upload the image at imgur.com :grinning:

Take a photo with your phone and post that.

2 Likes

If you are using Fractional Scaling, this can cause duplicate or ghost cursors.

Ensure Sticky Keys are not enabled.

Is GDM3 utilizing Wayland?

sudo nano /etc/gdm3/custom.conf

Comment out the line WaylandEnable=false to #WaylandEnable=false
Then restart the service;

sudo service gdm restart

This may correct the Fractional scaling.

Turning Wayland on did the did the trick. No more phantom mouse cursor. Thank you for the help in resolving this aggravating problem!

Actually... I recommend Wayland off.
And ensure Wayland is off for GDM, as well.
We may have established a connection of cause... But using Wayland will mean that other applications may break.
Wayland is just not Yet Ready and is incomplete.

Are you using Fractional Scaling?

Marked solution. 91

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.