Pipewire (Or pulse audio?) virtual sink dead from shell

First, I'm sorry that I have not been able to tell the difference between pipewire and pulse audio in this regard.. lol. Second, it works great!... When it works.. However, I'm leaning towards this being a bug now? But I wanted to ask first in case.

So, I've done a bunch of testing and from my observation it seems that if I load a virtual audio sink (VS) via a shell script, the VS will refuse to output any audio, yet if I type the exact same command in a terminal, it'll work no problem? So I'm thinking this is a bug, but before making a bug report, I just want to ask if anyone else knows what's up, if I'm missing something that changed or.. I don't know. (I'm still considering myself new to Linux, but I'm starting to learn a few things.)
This being said, I'm using Helvum and Easy Effects (in a nutshell) for GUI references. What I'm trying to do is create four audio sinks so I can split the audio for something like OBS, but then route it back into my speakers Easy Effects -> speakers. The fourth sink is a dummy for OBS output reasons if Discord ever catches audio again.. lol. (Apparently a Discord thing.) My pactl (Pulse Audio? Pipewire?) is the current version:

pactl 15.99.1
Compiled with libpulse 15.99.0
Linked with libpulse 15.99.0

Here's an example with just one virtual audio setup:


This is how the audio routs if I were to use a shell script:

And if I were to just manually write the command in terminal, exact same command both work:

ok i don't have the faintest clue what u are talking about lol , but from the header i'm kinda assuming ur asking which one to use ?
i don't know that either .
but my standard install of Lite somehow have both running ,not sure if this is suppose to be?
output for inxi -F

audio

No, sorry, I meant I don't know if this is pipewire or pulse audio when I use pactl * commands. I do know absolutely which devices to use when I do pactl list short sinks and pactl list short sources. The commands to hook up loopback devices though don't work via numerical ID, only by the name itself. So for context, I have this shell script that I run:

#!/bin/bash

Main=VS_Main
pactl load-module module-null-sink media.class=Audio/Sink sink_name=$Main
pactl load-module module-loopback sink=easyeffects_sink source=$Main.monitor sink_properties=device.description="$Main sink"

Aux=VS_Aux
pactl load-module module-null-sink media.class=Audio/Sink sink_name=$Aux
pactl load-module module-loopback sink=easyeffects_sink source=$Aux.monitor sink_properties=device.description="$Aux sink"

Voice=VS_Voice
pactl load-module module-null-sink media.class=Audio/Sink sink_name=$Voice
pactl load-module module-loopback sink=easyeffects_sink source=$Voice.monitor sink_properties=device.description="$Voice sink"

Dummy=VS_Dummy
pactl load-module module-null-sink media.class=Audio/Sink sink_name=$Dummy sink_properties=device.description="$Dummy sink"

The thing is that if I run this from a shell script, the sinks (VS_Main, VS_Voice, and VS_Aux) don't actually output any audio.
With the aid of Helvum (the GUI and screenshots I posted) it shows how the sinks are properly hooked up, but no audio comes out of the audio sinks. If I directly, again using Helvum, just rout audio even just to the loopback inputs, the audio works again.
There was a little bit of time I had where I could type it in manually and it would work, too, but that seems to not want to work anymore either, now. (The same problem.) So I was wondering if this was a bug and actually, this would have been the wrong place to post if it even is a bug... lol Sorry.