Please help me to solve big performance issue on games

Hi team,

I am getting huge performance issue running games on Wine and Proton, freezing almost every time, being unable to even navigate on first start menu on games, could someone please help me?

My setup is a Dell XPS 8930 with NVIDIA GeForce RTX 2060, 32 GB of RAM and Intel i5-8400.

I tried to install and run games on Heroic and Steam, I am only able to play veeery old games, even GRID (the first one from 2008) game freezes on first screen after game logo, on resolution inferior to 1080p.

Maybe it's a GPU rendering issue, but I tried several proprietary driver version and it did not work, for driver inferior of v500 the games just does not open. Sometimes, when I try to activate a driver, it fails and says that a dependency is unavailable and not installable, but if I try again, it works.

I am newbie on Linux desktop for games, please, how can I troubleshoot and solve this performance madness?

Ah, I am running the new Zorin OS 17 :slight_smile:

Thanks a lot and regards

Are you on Wayland or Xorg?
Try to switch to Xorg (Switch from wayland to x11)
Probably this is an Nvidia <-> Wayland Problem - give it a try.

You probably have a dual GPU setup and i suspect the machine is running on the igpu now. Nvidia drivers should be installed automatically, to switch to dgpu run the app Nvidia settings and set it to use the NVIDIA allways.

Very first thing I'd try is to check the drive(s) for errors... it may be that weak sectors are making reading and writing slow... I've seen hard drives that took as long as 5 seconds per sector... the data was still read, it just took a long time. Those sectors failed completely shortly afterward.

I used to have a LiveCD that would worry over every single sector on a drive, repeatedly writing certain patterns of data to each sector to attempt to rejuvenate the sector, then marking the sector as bad if it failed... it'd take days and days and days to run, but it worked. Not sure why, but it actually increased the read speed for healthy sectors.

Now, I do this:

Next thing I'd check is that your memory is properly seated, and its clock speed matches what the motherboard is clocking it at. I'd also ensure the memory was matched sticks (both the same amount of memory, and both the same clock speed) so memory interleaving could take place to speed up data transfer. Then I'd test the memory to be sure it's not faulty.

Next thing I'd check is the CPU, GPU and power supply cooling... it may be that one of them is throttling back or malfunctioning because it's getting too hot... check that your fans spin easily by finger without any bearing noise (put your ear right next to the fan as you spin it with your finger... a noisy bearing will sound like "crunkle, crunkle, crunkle" and the fan may shift back and forth on its axis when you push sideways on it.). Check that the fans spin up when the machine is on, and if you've got variable-speed fans, that they ramp up as load increases.

Clean all the heatsinks on the CPU and GPU and power supply... I've found the best way of doing this is with a vacuum cleaner with a brush attachment to suck the dust out, and a pipe cleaner to scrub between the fins. So you'd scrub the dust out of the heat sink with the pipe cleaner, then suck it away with the vacuum. Clean the fan blades, too.

Then, and only then, would I consider addressing potential driver issues.

As to whether you've got multiple GPUs:
xapp-gpu-offload -l
... that'll list your GPUs.

Now let's say you have two GPUs...
0 default [ Integrated GPU ]
1 [ Nvidia GeForce RTX 2060 ]

You can switch from the integrated to the Nvidia GPU via:
xapp-gpu-offload -i 1

Wayland cannot play games on Linux - it needs a plugin, ironically, X on Wayland! (Learnt this from Nick of 'TheLinuxExperiment' channel)

I am using X :confused:

Please, where I can find this option? I do not found it :confused:

My hardware is OK, I am trying to run xapp-gpu-offload but it says command not found
Please, how can I run it?

I ran a command found in How To Switch Between Intel and Nvidia Graphics Card on Ubuntu and it only shows that I have my dgpu nvidia, maybe it's not the problem :confused:

I had similar issues with nvidia, installing the latest stable kernel and the 545 proprietary drivers fixed it for me, I made a post earlier with the solutions called something like "How do I install the 545 proprietary Nvidia drivers?"

I found the topic and doing the update, maybe it works if I have dependency issue, it's not a minor performance problem, maybe it breaks my system but no problem :sweat_smile:

I broke my system lol, it holds on a black screen after UEFI boot

If using Nvidia as Dedicated Graphics, you might first try using the nomodeset grub parameter prior to reverting to a different Nvidia driver than 545.

As you can see from this picture, here is where you change which gpu who runs, but the app is called NVIDIA X sever settings:

Does not exist this PRIME option in my NVidia settings, and considering that the system only sees the dgpu, I dont think that I am running anything on igpu at all :confused:

Out of interest do you have a swap set up? For me just going through zorin installation did not set up a swap, and this caused huge issues when trying to play games, freezing and stuttering like you described. Maybe not a problem for you since you have 32GB ram, but I thought I would just note it as adding a swap is what fixed my issues.