Portable SSD

I don't know how this happened but is it recoverable. Nothing has been written to the drive. Any ideas what I can do?

Is there data on this drive that you need to recover?

The first step would be to reformat that USB drive but you may need data recovery, first.

1 Like

Thanks for your reply.
There is no data to recover. I would just like to use the drive. It wont let me format it. The only things that aren't greyed out are 'Edit mount options' in the additional mount options and 'Power off' in the drive options.

1 Like

Does it work on other PC's?

Thanks for your reply 337harvey
All my options are greyed out except what I previously mentioned. I can't unmount the drive. I'm not a technical person so I don't know what 'fstab' is (sorry).

Thanks, Ponce-De-Leon.
I haven't tried yet but I will this morning and get back to you.

1 Like

Hi 337harvey.
Thanks again.
If I click the cog, I get the following:

This probably has more info about the drive, but I don't really understand any of it.
I don't know if this helps, but I also got some info using the the Terminal with the command 'sudo lshw -class disk' (I got this command from another website). The output was as follows:
description: SCSI Disk
product: USB2DISK
vendor: NAND
physical id: 0.0.0
bus info: scsi@4:0.0.0
logical name: /dev/sdc
version: 0.00
capabilities: removable
configuration: ansiversion=4 logicalsectorsize=512 sectorsize=512
physical id: 0
logical name: /dev/sdc

I've tried the drive on my laptop and I got an identical result.

Does this Laptop have Zorin too or Windows? What Manufacturer/Model is it? What Size has it? How is it formated? I find it weird that there stands ... nothing.

The laptop has Zorin 16.3 Pro Lite. It's a 9 year-old (very slow)'Toshiba Satellite'.

Sorry, that was not good asked from me. The Questions with Manufacturer/Model, Size and Format were for You not working SSD.

Sorry. I think you meant the drive. I can't remember the size. It isn't formatted and I can't format it, I am hoping there is a way to do it. However, the computer recognizes it. Here is a picture:

There is no more information printed on it, other than what you can see.

1 Like

Both, really. It has worked before. I've had it for a couple of years. It stopped working not long after I got it. I've got a feeling my son tried to format it, but I've got no admission or proof. It's been in a drawer since then.

You can mount or unmount using terminal.
Mounting with read andf write permissions:

sudo mount -o rw /dev/sdc /mnt

To unmount it, this is not a typo - The command is umount:

sudo umount /dev/sdc

If the manufacturer failed to include SMART controls, the Gnome Disks app will be limited in its ability to communicate with the device - but the terminal can do it just fine.
With the drive unmounted, run FileSystem Check on the drive:

sudo fsck /dev/sdc

Does the Manufacturer Name stand on the Back Site? Please don't understand me wrong. I don't want to offend You. The Device looks a little suspect to me. The Design reminds me to the Samsung Drives. But maybe I'm only too paranoid.

That could mean that they simply broke. Do you have the Posibility to use a Windows-PC? Maybe by a Friend or a Neighbor? You could test it there if it works. And You could format it on Windows.

Thanks Aravision
This was the result:

sudo mount -o rw /dev/sdc /mnt

mount: /mnt: no medium found on /dev/sdc.

Interesting. It reads so as if there wouldn't be a SSD in the Case. Maybe the Cable is broke. Did You try another one?

1 Like

In the first post, the screenshot show this drive is placed at /dev/sdg, not /dev/sdc. Make sure that is the right location for this drive, and try again.

Do you see an option inside of the Disks software to format the drive? If you don't have any information in this drive that is important to you (it will be lost) this may work.

Another option, try to open the drive physically and clean all the connectors with isopropyl alcohol, remove excess dust inside of it, etc. I once managed to get a 20+ years old drive to work by extracting it from it's case in this way.

I tried 'sudo umount /mnt/usb-NAND_USB2DISK-0:0'

the result: umount: /mnt/usb-NAND_USB2DISK-0:0: not mounted.

I'm starting to wonder whether Ponce-De-Leon's suggestion that the products quality is suspect and maybe I was sold a dud. I seem to remember it was a 'bargain'. I've got no access to WINDOWS so I can't try it there (if I do get a chance, I will). There is no way to access the inside. There are no manufacturer's names or serial numbers on it. Should I give up?

Try running on a terminal:


And from the output, check to see which letter is associated to the drive. It should be something like /dev/sda, /dev/sdb or similar but it's important to confirm it as this may change without you noticing. Then use that to run the commands as Aravisian suggested above. Try to mount and unmount it, as well as running the filesystem check.

If nothing works, it seems likely there's some sort of hardware failure. Consider opening it and clean it from the inside with isopropyl alcohol and cotton swabs. Otherwise, it may very well be that the quality is junk not there for this particular brand. Personally never heard of it before and can't find any results online about it, given how generic the name is.