Possible to easily swap sound devices?

I picked up Zorin Ultimate, so I could have access to the Mac-like themes, and I really enjoy it! However, I constantly swap from my desktop speakers to my headphones, and so far I haven’t found an easier way to do that then to go through Settings → Sound and select the device from that list.

On macOS, this is changeable from the dropdown in the top right corner that shows your volume. Zorin has a similar dropdown, from which I can adjust the volume of the current device, but I cannot change devices from this menu.

I did install a Bluetooth Manager, and it added a new Bluetooth dropdown to that top menu bar, with additional shortcuts. Is there something like that I can install to manage active input/output devices?

Hi @ReynoldsCahoon!

Yes, you can install this desktop extension to add a sound device selection to the indicator menu in the panel: Sound Input & Output Device Chooser - GNOME Shell Extensions

2 Likes

How do I know which Shell version I’m running?

Should be 3.30

You can open Activities Overview and click the About button.
Or in terminal, run

gnome-shell --version

1 Like

That is correct. When visiting the link provided to install the GNOME Shell Extensions, I’m met with the message

Although GNOME Shell integration extension is running, native host connector is not detected. Refer documentation for instructions about installing connector.

I have the chrome-gnome-shell installed, as per the documentation on that site, and the GNOME Shell Integration extension installed. I’m using the Brave browser.

I can download the zip file for my version, but I’m not sure what to do with that.

Ok, the documentation you helpfully linked to says this:
sudo apt-get install chrome-gnome-shell

Let’s see if what you have installed is correct or if installing the dependencies help:

sudo apt-get install gir1.2-gtop-2.0 gir1.2-nm-1.0 gir1.2-clutter-1.0

Then run the above offering from the documentation:

sudo apt-get install chrome-gnome-shell

Then restart your shell: Hit alt+F2 and type in the pop up window

r

Or if you prefer terminal:

killall -3 gnome-shell

Once this is done, return to your extensions and try enabling the above extension again. At this point, I become less helpful- Since I lack experience and knowledge in using Gnome as a Desktop Environment.
I absolutely cannot stand Gnome. On my copy of Zorin Lite, I can plug in, unplug speakers and headphones, swapping them all over the place at will, no extensions needed.
I find Gnome to be very unfriendly for the user. Just bein’ honest.

1 Like

Unfortunately that doesn’t appear to have solved my problem. Curiously, possibly related but probably not, every time I load my browser, it tells me it’s not my default browser despite it being listed as the default application for the web in my Settings → Details → Default Applications.

Is your default browser Chrome or Chromium or is it some other browser?
EDIT: Sidenote, setting your default browser in the manner you say above is the correct way to do it, so it is not an error on your part.

I’m using the Brave Web Browser, which is based on Chromium.

I use that browser sometimes, as well. I just tried setting it as default and then opened it and had no issues.
I appreciate your calm, since I have failed on each issue you have posted so far. Usually, I get one knocked out at least. It goes to show how much I have yet to learn.
Off the top of my head, I cannot see how this could relate to the other two items you have asked about.

There is one thing that if this was me, on my machine, I would try in this situation, just for kicks. You mentioned recently installing Zorin, then in this thread, recently installing Ultimate. Zorin OS Ultimate also comes with Ultimate Lite.
I wonder if you might be willing to install Ultimate Lite and test each of these issues on that running as its own system:
1.) Flickering display
2.) Browser not setting as default
3.) swapping headphones and speakers

and relay the results?
If not, we can continue trying troubleshooting, but the above test will allow a much more solid starting point on the thing I suspect.

I’ll see if I can find some time to give the Ultimate Lite version a test run, but unfortunately the work week starts up again tomorrow, and I need my current install running for that. Maybe an evening this week, but more likely this next weekend.