Potential bug in password creation during install

During the installation of Zorin OS, I attempted to set a password that was rejected by the system for being too insecure. However, it appears that this password was accepted by the GNOME Keyring before the system rejected it. When I chose a more secure password for my user account, the keyring password remained the insecure one I initially tried to use. This caused confusion as I was unable to unlock the keyring with my user account password but it worked when I tried the insecure one I attempted first.

I've moved this topic to the #feedback category as I feel it fits that better.

1 Like

Can you please go into further detail?
The Ubiquity installer does not reject passwords due to perceived security. In fact, you can set it as blank or as a multi-digit PIN (I have mine set to a PIN).
Were you using LUKS encryption?

I'm sorry, I was helped with ChatGPT (I know, I know...) to solve the problem of the Default Keyring pop up at start not working with the password I gave during install. I know very little about computers so I can't tell you much more than what ChatGPT accurately put together in the OP.

It suggested it was an important thing to give feedback on, and here I am.

So, I will summarize:

I installed Zorin, during which it asked me to create a password. I put in a 6 number password which was rejected due to being "weak" (my wording - maybe it was "insecure" or "low" or similar word) with red. I put in a new password and then I could continue.

However, later when I got the Default Keyring popup (for some reason, I think some program asked for it?) at start my password of choice, that was approved by the install ("strong") and works for logins, did not work. So I tried the weak one, which I thought had not gone through in any way, and it worked. ChatGPT told me that it is most likely because GNOME accepted the first password I put in for that area of security, ignoring what Zorin said... or something.

But, the conclusion might be incorrect.

I did use Ubuntu before Zorin and had this weaker password without issue. Therefore it sounded correct that the "base" of the OS would approve the weak password. If that makes sense.

Sorry again if I have wasted time.

ChatGPT will provide answers with such confidence that it may seem easy to believe. However, it is... often inaccurate and will give the Wrong Answer. Please see ChatGPT in its current state as a form of entertainment and never trust your system to its advice.

You are never wasting time by asking questions or problem solving.

However, the Ubiquity installer should not reject your password entry - As I said, it will accept no password at all. I have often made one digit, two digit or four digit passwords, too.
The Try Zorin option uses a -blank- password as an example.
This makes me wonder if we are talking about the Same Passwords...
And Gnome Keyring may be a different issue altogether.

There is also the Full Drive Encryption option (LUKS) available at point of install that does reject a password if it is deemed too weak. This is a LUKS password and is unrelated to the sudo or the Keyring password.

I think it might be because I clicked the enter keyboard button because I didn't see "continue" was grayed out.

I think I picked an option to create a password and therefore it insisted I indeed do so before I continue.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.