Printer drivers, lock screen after sleep, etc

Hi: I quite liked Zorin OS until I found that it only sees one wifi printer, a Canon Pro 100. It thinks this is a low end printer and not a photo printer. Also Zorin fails to see my Brother MFC-J680DW printer even after putting in its network address. Neither printer appears on the list in Zorin. I went to the Canon and Brother sites and downloaded drivers but they come as .gz - whatever that is.
So, question what to I do with one of these files to install it, I'm sure there are instructions somewhere. I thought that Zorin was supposed to be easy for idiots coming from Windows!
Second problem. Wifi keeps quitting, it worked OK on Windows. Have to use a different router in the house, further away, but it works reliably. Odd.
Third problem. Can I stop Zorin asking for a password when waking from sleep?
One good point is that the fingerprint reader works better on Zorin than it ever did on Windows!
Maybe three things is too much?

Well, it is. But that doesn't mean that everything always will be.:wink:

Let's see if we can make things easier.

Tar.gz files are very much the same as you used on Windows: .zip

They are just compressed. Often times, decompressing and opening the file, you can find a README file or Installation Instructions.
There was a time when you did not know what a .zip file was. Until you learned it. There was a time when you did not know .tar.gz and now you have learned that too. It is not that it isn't easy... It is that it is unfamiliar.

Now, let's forget all that.
Brother also supplies a .deb package - which is a Self Installer, much like the self-installers you used on Windows.
You can get the driver installer tool here;

That one above is the all in one.
IF you want only specific drivers... You can download just those as a .deb. You probably are fine with just the one above so if any doubt, you can stop at this point and hopefully that will be One Problem down.

Otherwise, Printer Only:

CUPS printer driver:



The source:

If you could please start a New Help thread on this issue so that we can keep things organized?

Yes, you can try autologin, but I do not recommend it. AutoLogin comes with its own troubles and can be more harm than good.
When I first moved from Windows to Linux, I was caught off guard by having to enter my password, so often, too.
I changed it to a Four Digit PIN and that made things much easier.

And later, using Win11, it seems to want me to authenticate Admin actions far more often than Linux does...

Thank you for your excellent response. Above and beyond! I've learned about the Terminal! Eventually got past su and sudo su and URI and got a bunch of .deb files in the Download directory. Clicked on one of them and got a screen saying "Brother inkjet lpr printer driver Installing 0%" It has been at 0% for 15 minutes! Tried a different .deb file and it doesn't do anything either.
Now I look they seem to have installed themselves - is that possible?
Tried to print an Only Office doc and the MFC-J680DW printer showed up. But no print
Any ideas please?

Printers are admittedly, my weakest subject. There are some others on the forum that are much better with the peripherals.
I know that @swarfendor437 would recommend using Gdebi to install .deb packages as it is verbose, comprehensive and works well.
I know I would second that recommendation:

sudo apt install gdebi

Perhaps using gdebi on your existing printer driver .deb packages may shed some light on what happened with those installations.

I would remove printer and drivers and use gdebi as Aravisian has recommended. Using gdebi installs the drivers into Printers but you need to reboot first after installing .deb packages then once rebooted go to Settings | Printers, add printer, select brother then scroll down the list to find your model and install. The Linux kernel can identify new printers but labels them driverless which is why you may not be printing. I have tried to remove driverless printers after installing drivers but they just keep coming back. One of the downsides to autodiscover that needs to be disabled. Would have been better if never implemented, IMHO.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.