Printer only prints one copy (Canon MB2720 ) even for a multiple copy

I also sell on eBay and print labels and have had no troubles across a variety of printers in this regard on Zorin OS. I cannot say for sure per model but... Can always start a thread if you run into trouble.

Cross linking this - just in case it provides helpful clues:

I have the MB2720 network printer installed on wife computer with Z16 Pro. I have tried everything in this Post and nothing works on this office computer. How can I delete all the MB2720 out of this office computer so I can start over. I go to Settings>Printers and it shows 2 MB2720 printers when I right click on options and delete they keep popping back up. How do I get rid and start over?

Is there anyway to copy the printer drivers from wife computer and install them on the office computer?

Depends on the mode of connection, it is normal to have multiple entries for a single printer.

For example, my Brother printer is listed twice with a different mode of connection:
Brother MFC-J870DW, driverless, cups-filters 1.27.4
Brother MFC-J870DW CUPS
(both work)

That is normal.
Some printers are auto installed (but not necessary work).

It might help to change the mode of connection.
We recently see some printers only work with WiFi connection.

You installed the Linux driver for this printer?

1 Like

I am back on this project now had other fires to put out first.
My Canon MB2720 is installed on my network. Have wife computer that I got it working on and I was trying several things and don't exactly what I did to get it to work. I tried Cups and that didn't seem to work. Next I installed drivers from Canon. The next thing I know it was working.

I click on settings>printers and it shows 1st Canon_MB2700_series & Ready, Model Canon MB2700 series,,,,,,,, 2nd MB2700_series & Ready, Model Canon Canon MB2700 series. There is a ADD button at top of page and when I click on (at bottom of page) "Additional Printer Settings" it opens another small printers-localhost which shows on left Canon_MB2700_series with a green check-mark and a orange triangle with white exclamation mark. On the right shows the Zebra thermal printer which works.
When I try printing out more than 1 page (the name of Printer showing is the 1st one), it will only print one page.
What should I do next, install drivers and how?

Could you tell me which operating system has been installed on your wife's computer? You might have mentioned it somewhere in this thread but I failed to find it.

Zorin 16 Pro

That sounds familiar to me - been there done that myself.

I've now made it a habit to create a text file for any tricky operation I do in Linux and save it on the USB key dedicated just for that purpose. This USB key makes my Linux life easy :slight_smile:

Which driver you have installed?
Could you give me a link for the driver page?

Its the link at #17 and I selected the 1st on canon page.
Is there any way to copy the drivers from wife computer and paste in my where the printer is that only prints one page?

You mean this?


It may be possible but probably not easy. The printer driver installer will install more than one files in the system directory which is better not to touch especially for beginners.

That looks familiar but I don't know what to do with it now. I know I click on the Install and Save at least 2 times. I print a test page. then I try to print something that is 2 pages and it will only print 1. I will try this with all MB2720 printers that are listed. Since there are more than one Canon MB2720 printer I don't have a clue which one the drivers are installed on.

  1. Save file in your Downloads directory.

  2. Double click on it in File manager to uncompress it.

  3. You have to do the procedures bellow in the Terminal at this point.

  4. Open Terminal (ctrl+alt+T)

  5. Change the current working directory to the folder which contains uncompressed files.

cd Downloads/cnijfilter2-5.40-1-deb

  1. Type ls to display the content of this folder. There should be the following 3 files. packages resources

  2. Run installation shell script.
    sudo bash ./

  3. Follow the direction shown in the Terminal.

How to find out what drivers is being used?

Hello and welcome to the forum :slight_smile:

Linux (and Ubuntu as well) doesn't have separate entity as "device drivers", Linux has kernel modules which could be called "drivers" for real or virtual hardware depending on their functionality.


You may try looking in the downloads folder of you're wife's computer. The installer or archive of the drivers you installed on her machine will still be there, unless you delete things as you perform them.

If you installed using the terminal you can type history and it will show you a list of commands you performed. This might help narrow down what you did on her machine to get that printer working.

Here is the history. Can you tell what I did so I can do it again?
lkp@lkp-MS-7577:~$ history
1 wget -q -O - | sudo apt-key add
2 echo 'deb [arch=amd64] stable main' | sudo tee /etc/apt/sources.list.d/google-chrome.list
3 wget -q -O - | sudo apt-key add
4 sudo apt install cnijfilter2
5 sudo dpkg -iG cnijfilter2_5.40-x_amd64.deb
6 sudo /usr/lib/cups/backend/cnijbe2
7 sudo systemctl enable cups
8 sudo systemctl start cups
9 CUPS Setup-localhost:631
10 CUPS Setup - localhost:631
11 wget -q -O - | sudo apt-key add -
12 sudo sh -c 'echo "deb stable main" >> /etc/apt/sources.list.d/google.list'
13 sudo apt-get update
14 sudo apt-get install google-chrome-stable
15 disk
16 history

You added the public key for Google and the repository.

Downloaded the cnijfilter2_5.40 deb. Installed cnijfilter2_5.40 and cnijfilter2, from two different sources (one deb, one apt respectively).

Then you enabled cups, started the service and configured it twice (localhost:631).

Reinstalled the Google public key and repository, then installed Google Chrome.

And you initiated disks from the terminal.

Why did you install two different versions of the cnijfilter2 driver? Did you need both?

Maybe configuring cups twice because it didn't take the first time?

As I said I was trying any and everything. I was trying to install MB2720 and it was in system as MB2700 series.

Looking in wife computer solved the problem:
Device URI: cnijbe2//?port=net&serial=74-38-B7-08-FD-18
Make & Model: Canon MB2700 series Ver5.40

Deleted several Canon MB2720 printers and added the above.


I'm glad we could help get you straightened out. Just goes to show that sometimes, after trying everything, backtracking a bit and going over what you have done might provide the solution.

1 Like

This topic was automatically closed after 5 days. New replies are no longer allowed.