Printer only prints one copy (Canon MB2720 ) even for a multiple copy

Canon MB2720 network printer installed wireless. Works just fine on the Main Windows 10 computer. I am printing out multiple sale invoices from XPS shipping using MS Edge. I have not tried using Firefox, really don't think the browser is the problem.
Just installed Z16 Pro as a stand-alone OS I am very impressed with this OS. This is the only problem I have found other than don't know how to do things in Linux due to terms and lingo.

I had a similar issue and went through a lot of hoops trying to resolve, including downloading the correct and proper drivers from the Canon website- installing and enabling them and multiple tests. Nothing worked.
Then, on a whim, I dropped everything to just the CUPS drivers that comes with the distro and... It has worked perfectly ever since.
Which drivers are you currently using?

1 Like

What ever was in Z16 Pro standard download the first choice. What is CUPD and where/how do I check drivers? Installed yesterday 08/22/21

I was starting to type out a guide when it occurred to me that I bet someone else would do a much better job. So:

Thanks Aravisian will check it out. I feel it is some simple. I was really amazed after the install Zorin recognized my wireless printer and Navida card.

1 Like

That how we are using our old HP printer.
It is amazing to see how CUPS could overcome this pesky driver issue.

1 Like

I have read the documents tried everything I know of I have tried. Tried printing using a different browser no change. I don't know how to use only the CUPS drivers so did not try that. I Removed the printer and reinstalled the printer over 4 times & no change in the printer. When I reinstalled the printer is the software using the CUPS drivers or others.
I am at a dead stop need help, please.

Here are the drivers for Linux from Canon:
https://uptodrivers.com/download/canon-maxify-mb2120-ij-printer-driver-for-linux-debian-packagearchive-tar/#general-help

And Scangear (If you need it)
https://uptodrivers.com/download/canon-maxify-mb2120-scangear-mp-for-linux-debian-packagearchive-tar/#

Extract the file. You will see a cnijfilter folder. Open that and there will be an install script. Double click it and it should ask if you would like to Run the Script to Install the drivers. Run it and - let's see if it works.

Now, on the Zorin computer I am logged out of the forum. I entered my UserID and PW it say that is not correct and I had saved it in Bitwarden it is correct.
I am still log into forum on this computer.
I followed your instruction the best I could. I got all the way to a page where I had 2 folders and 1 txt file named Install.sh..... the only thing I was able to do was open the file. It looks like it should be copied and pasted into a driver file.
Anyway it still will print one page, meaning I have not made things worse but I can't drop Windows 10 with printer working this way.
I am tired, going to bed. Continue this another day.

Right click and select Permissions- Set to "Run as executable". Then double click to run.
Sleep well in the meantime.

I right click on "Install.sh" was no Permissions to set to Run as executable"
Iam going to call Canon tomorrow see what they say. How to find out what drivers is being used? Do I have CUPS installed how to find out? How can find out if Canon MB2720 works correctly on any Linux OS?

It should look like this:
perms

From the app menu, type printers and click open the app that appears.
Click on your printer to select it. Then click the printer option on the menubar.
From the menu, select Properties.
In the entry field for Make and Model: will be the Drivers being used.

sudo apt install cups

If not installed, it will install. If it is installed, it will display cups is already the newest version

It does. I had a very similar model about a year and a half ago.
That being said, while doing a quick search to see if I could find any confirmation on that, I stumbled on this:

I do not want to test the procedure in that link because I do not have that Make and Model printer now... but it will not harm you any to try out those steps.

Here is the results: lkp@lkp-MS-7577:~$ sudo apt install cnijfilter2
[sudo] password for lkp:
Reading package lists... Done
Building dependency tree
Reading state information... Done
cnijfilter2 is already the newest version (5.40-1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
lkp@lkp-MS-7577:~$ ^C
lkp@lkp-MS-7577:~$

Now we know that is the drivers that are installed installed.
This is making me think the problem is in Zorin 16 Pro somewhere.

Could be.
Remember getting to Printer Properties from up above:
Printers >select the printer > Printer (menubar) > Properties > Make and Model:
Hit the button "Change"
A pop up window will appear saying "Searching : searching for drivers." On some models, this can take a little while...

Otherwise, if you want to try using CUPS, open a terminal and enter in:

sudo systemctl enable cups

sudo systemctl start cups

Authenticate, then:

CUPS Setup - localhost:631

Add your printer (follow the prompts).

I have already tried "select the printer drivers" MB2700 series is listed but won't work. You can remove the printer and reinstall it by selecting the one listed. Same-O results only one page will print. Did I tell you that it will only print 1 page no matter how many documents or how many pages just one document has or if multi doc you can select any one of the documents and it will print the one selected and only the first page?
Will try using CUPS to see what that does. I Will call canon to see if they have any ideas.

1 Like

Here is results on Cups:
lkp@lkp-MS-7577:~$ sudo systemctl enable cups
[sudo] password for lkp:
Synchronizing state of cups.service with SysV service script with /lib/systemd/systemd-sysv-install.
Executing: /lib/systemd/systemd-sysv-install enable cups
lkp@lkp-MS-7577:~$ sudo systemctl start cups
lkp@lkp-MS-7577:~$ CUPS Setup-localhost:631
CUPS: command not found
lkp@lkp-MS-7577:~$ CUPS Setup - localhost:631
CUPS: command not found
lkp@lkp-MS-7577:~$

Canon could not offer help over the phone. My last resort is for Lorin 16 developers look into make sure it is not being caused by their software other wise I dead in the water. This is really disappointing.

I was talking with the moderators of the forum about where our strengths and weaknesses are. Mine are

  • printers
  • sound issues

These are likely to easily stump me. I am sorry, that as a persistent and stubborn member, this is a weak Topic for me.
But... I cannot count how many times on all fingers and toes how often someone with a printer related issue thought they were dead in the water - then some Simple Fix was all that was needed and they were cheering.

I may not be smart.

But I am stubborn. And persistent.

We're gonna get you working.

EDIT: Is this your device?
https://www.usa.canon.com/internet/portal/us/home/support/details/printers/small-office-home-office-printers/mb2720?tab=drivers_downloads

I am also stubborn, persistent, and just turned 83. You are correct I also feel it is something simple. Over the last 30+ years, I can't remember the number of times I have attempted this, at least 15-20.
Yes, that is my printer. I bought two at the time of purchase in case one broke I had a backup. Well, it has never broken and the other still in the box has never been opened.
I am keeping my fingers crossed that the person will show up with the answer.

1 Like

I am reading this guide:
https://pdisp01.c-wss.com/gdl/WWUFORedirectTarget.do?id=MDMwMDAyNjA4NzAx&cmp=ABR&lang=EN

One thing it says that I did not consider:
Register the printer to the spooler

/usr/sbin/lpadmin -p [printer_name] -P /usr/share/cups/model/[PPD_filename] -v [device-uri] -E

To read the guide - download by clicking link above. Extract the tar.
Open the extracted Guide Folder. Double click guide_index.htm to open the guide in your browser.

I opened the guide and Registered the printer as shown no errors. Results still 1 page.
I started doing other things shown in the guide still same results. Not knowing what else to do I deleted printers and reinstalled making different selections of copy & paste. The second printer I installed it printed all three copies.
Have no idea what I actually did but it works. Is there anyway to save what is installed so it can be installed on main office computer and the notebook?
I will install Z16Pro on notebook next due to this. Can't take a chance ending up with office computer shut down.
Well your memory was correct the Maxifly printers do work on Ubuntu. One thing for sure Aravisian without your help it would still be not printing correctly!!!! Thank you so very much.
Question do you know if Zebra GX420d shipping label printer will work on Ubuntu? I am now very very impressed with Z16Pro these guys are geniuses.

1 Like