Bought a Canon PIXMA TS3522 Printer, need help installing, have been trying for hours

I really need help, my HP photosmart stopped working so I had to buy a new printer. My business & survival relies on having a printer.

I've tried various solutions/attempts,
I tried an old @Aravisian recommendation here:

Here are some helpful links:

I managed to get the printer to work & print via the USB. I can either connect to my printer via USB cord, or wirelessly, I managed to get the Canon PIXMA set up using USB cord & the .tar driver files installed, and I am able to print. However I get no option to choose whether I want to print "draft/fast" version quality, normal, and also "Best" print quality which is what my HP used to give me as an option, see pic link for HP screenshot:

But here is what the Canon Pixma shows me:

Thanks again!

Hi, The IJ driver is for printing and the Scangear is for (clue in the name), the Scanner Driver. Download both of these Debian packages to your Downloads folder. These are tar balls (zip type archives that need extracting. Let's start with the Printer driver extraction first. Before we go any further after extraction, open Software and install Synaptic Package Manager. Once installed, launch Synaptic (you will be asked for your login password to elevate you to root) and using the search function enter 'gdebi' without the single quotes. Once this is installed, launch it and then select File and Open. Browse to the selected extracted IJ folder and inside of it are three more folders. Choose the resources/packages folder and choose the Debian or .deb folder. Inside of that is an x64.deb file. Select that. This will install the printer driver. Next open a Terminal and enter:

sudo system-config-printer

When the interface for printers opens,
Select Add Printer. Let it search for your printer then select Add driver. A list of manufacturers opens, Scroll down to Canon, then in the models pane Scroll down to TS-3000 series (Canon does not provide specific printer models in its Linux drivers, I have a TS-8151 and it comes up as a TS-8000 series.

1 Like

Thanks! You might've just missed my edit of my post, i did get the printer to print via the USB. Not sure about the scanner, that will get 2nd priority/back burner for now.

I got the printer working by downloading the tar driver files and then doing this: "go into the extracted tar driver folder and open a terminal from the folder and type: sudo ./"

And that is awesome to hear you have a canon too! Were you able to read my recent edit of my post? you might've just missed it, please take another look. Now the issue is that I cant choose printer quality, no options. No "draft" quality option, no "high resolution" photo option. Like I could with my HP photosmart.

1 Like

I will be back laters.

1 Like

With Linux drivers you don't get words but dpi. Draft is 600 and high quality 1200 dpi. You do have a choice of media. When I am at my machine I will post screenshots.

1 Like

When I print anything it only gives me the 600 dpi option, despite me specifically buying the printer because it prints "4800 x 1200 dpi" resolution. And i even tried to select glossy photo as the media, to see if the dpi option would change, it didnt.

I think it would be advisable to delete the printer and start again. Is it connected via USB or network?

Just looked at your image - you have pdf selected and not your printer, hence the 600 dpi being shown - use the drop-down arrow to change to PostScript. :wink:

I find that using gdebi is a better way of installing the drivers as I have outlined in the Unofficial Manual for Zorin 17 that I authored.

Just looked at my settings and 600 dpi is the highest setting.

Just found a review of the TS-3520 and I think the issue you will have is the fact it only has two ink cartridges.
If you can trade it in for one that has more cartridges like mine, you won't get higher res, but printing would be better. I always buy the XL cartridges which last longer and I usually buy a full replacement set about twice a year as not doing a lot of printing. Based on what I have found about the built in scanner its maximum resolution is 1200 dpi at 24 bit.

1 Like

I assume OP has downloaded the IJ Printer Driver and Scangear driver direct from Canon here:

1 Like

@zabadabadoo , yes i have and i installed them

@swarfendor437 , i got everything to work now. I dont think linux canon drivers were even necessary. I called their tech support. This is what solved it and gave me "Highest quality resolution option".

I installed "canon print" app on my android. Then using that app, I connected the canon printer to my router.

Then all devices can connect to my printer now wirelessly.
Then when I connect to the printer now using Zorin, i get "Draft mode", "Normal" print mode, or "high quality".

Now the only problem is, is that i cant get the scanner to work. I've used the program "Document Scanner" and also "gscan2pdf", and both get an error. But both, when i tell them to scan, they do communicate with printer, printer DOES scan whats inside it, But after that is where the error occurs with both programs, and the scanned file doesnt reach the computer.

I even made sure to install the scanner driver "scangear" via terminal, by using sudo ./ in the terminal.

I know you can install via ./, but I always swear by gdebi. Zorin 17 is the first iteration where I had to install scangear. I think you had to do your printer install the way you did because you don't have an LCD screen to make network connection which I have on the TS-8151.


Just had another thought. When you launch Document Scanner, do you see a drop-down arrow? Click on it to see the other options - to scan you need the one starting with eSCL:

@swarfendor437. Thanks for telling me about gdebi, i never even heard of it. I dont know the benefits of it. So the scangear driver is in a tar.gz file. Do i have to extract the tar.gz in order to install it with gdebi? or does it bypass that? whats the benefit(s) of gdebi? i have no idea.

I do know that it "identifies all the required dependencies and automatically downloads and installs them using the apt package manager." So thats cool :slight_smile:

2.) Here's a photo of the two options i get when I use "document scanner":

3.) Also, here's the error message i get once the canon printer scans & finishes:


I would go for the top option. Never seen an eSCL option with SSL after it!
If you want to learn about Gdebi I covered why you need it in addition to Software and Synaptic Package Manager in the Unofficial Manual for 15, and also covered its usage in the Unofficial Manual for Zorin 17. Basically it comes into its own when installing 3rd party packages as it checks that all dependencies are met and advises if additional packages will be installed for it to run. You extract the Scangear package the same way as you do for the printer driver. You need to open the extracted folder and then in one of the three sub-folders is an x64.deb package and install that using gdebi (Gnome .deb package installer.

1 Like

@swarfendor437 , I just did all that, it didnt solve anything unfortunately. I get the same error message thats in my last imgur link screenshot.
But it was cool to try out Gdebi though for the 1st time :slight_smile:

Can't find that printer on UK Site or SouthEast Asia site. I notice the scangear is a newer version to mine. I will upload my Canon Scangear 3.50 driver package to see if that works. Have you checked the manual that it allows scan to computer or only offers scan to print? If you can I would remove your scangear drivers and might mean contacting Canon Support. Another thought came to mind. Zorin 17 defaults to Wayland instead of graphical drivers. Can you please logout and when you select your user at login a cog appears bottom right of the screen, click on that and select the Zorin desktop, not Zorin Wayland, and see if that is the culprit. Wayland appears to create more problems than it solves.

1 Like

@swarfendor437 , Looks like i'm already using X11. When I just did:
"echo $XDG_SESSION_TYPE" in my terminal, I got: x11 .

And yes, could you please upload your driver?

Lastly, I can use the scan option on my "Canon Print" app on my android, i just tried it for the 1st time and it scanned straight to my android, no problem, worked perfect. So that answers your question whether it allows scan to computer/device. Only problem is, why I havent tried it until now is because it doesnt let me choose the DPI resolution for the scan when using the android app for some reason, there is literally no setting for it.

My bad. Seeing you joined last year you will be using Zorin 16 and not 17!

Link to Scangear 3.50.tar.gz here:

Just be mindful that I have extracted various archives to establish that the nearest model to yours packaged in the .deb file is TS3100 so may not work.

If still having issues with Scanner, the best proprietary software is VueScan - you can trial it to see if it is what you need (it leaves a watermark). There are two versions, standard and pro, if memory serves me correctly.

1 Like