"Printing service not available"

I have Zorin OS Lite 15.3. When I first installed the OS, my printer-scanner worked immediately after install. Now, months later, something happened and I cannot print. Under Printers, it says "Printing service not available. Start the service on this computer or connect to another server." I found some instructions online to restart the CUPS printing service, but it hasn't fixed the problem. (FYI, the scanner still works fine.)

Any tips on how to get the printing service working again?

It sounds like you have lost the configuration file. See below:

Ubuntu 18.04 LTS — Printing Service Not Available

. Config file is incorrectly located. Follow directions as per this link. Cups service stopped - UM 18.04 - Support & Help Requests - Ubuntu MATE Community
There is a default configuration file which should be installed in /usr/share/cups/cupsd.conf.default so I ran:

sudo cp /usr/share/cups/cupsd.conf.default /etc/cups/cupsd.conf
sudo service cups restart
1 Like

Awesome, that worked perfectly! Thank you!

1 Like

I am glad to hear that my advice has worked :smiley:
As I said somewhere in this forum, it is a great pleasure to return the favour :heart: Linux community has given me all those years.