Problem 16.1 after having to reinstall everything

Last week zorin 16.1 made my laptop unbootable. Did all the help-topics, but in the end had to reinstall. Now zorin 16.1 seems incomplete, can't pin favorite apps to taskbar, refuses all kind of apps of incomplete packages etc... Tried every trick in the book, but it doesn't work.
HELP

Good first step to ask for help @Tolstoi ! We'll need a bit more info, like:

  • What computer is this on?
  • What is the CPU/GPU?
  • What are the specs?
  • Are there any specific errors you're seeing while booting?
  • Have you tried booting in recovery mode, a.k.a. nomodeset?

That should be a good starting point. Here are a few commands that should help you answer a lot of those questions:

  • sudo lshw (for hardware info)
  • lscpu (for CPU info)
  • inxi -F (for a lot of the above too, simplified, and with driver info, but you might need to install it via apt)
  • cat /etc/default/grub (will tell us if you've got nomodeset or something else for the boot options)

Let us know!

I did all this. I forgot to tell that everything started with Firefox freezing and blocking my whole system who worked uptil that moment flawelessly.
inxi -F gives
inxi -F
System:
Host: nadine01 Kernel: 5.13.0-52-generic x86_64 bits: 64
Desktop: Gnome 3.38.4 Distro: Zorin OS 16.1
Machine:
Type: Laptop System: ASUSTeK product: X751MA v: 1.0
serial: <superuser/root required>
Mobo: ASUSTeK model: X751MA v: 1.0 serial: <superuser/root required>
UEFI: American Megatrends v: X751MA.206 date: 09/04/2014
Battery:
ID-1: BAT0 charge: 34.7 Wh condition: 34.9/37.4 Wh (93%)
CPU:
Topology: Dual Core model: Intel Celeron N2840 bits: 64 type: MCP
L2 cache: 1024 KiB
Speed: 556 MHz min/max: 500/2582 MHz Core speeds (MHz): 1: 556 2: 570
Graphics:
Device-1: Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display
driver: i915 v: kernel
Display: x11 server: X.Org 1.20.13 driver: i915 resolution: 1600x900~60Hz
OpenGL: renderer: Mesa DRI Intel HD Graphics (BYT) v: 4.2 Mesa 21.2.6
Audio:
Device-1: Intel Atom Processor Z36xxx/Z37xxx Series High Definition Audio
driver: snd_hda_intel
Sound Server: ALSA v: k5.13.0-52-generic
Network:
Device-1: Qualcomm Atheros AR9485 Wireless Network Adapter driver: ath9k
IF: wlp2s0 state: up mac: ac:b5:7d:c1:00:c1
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
driver: r8169
IF: enp3s0f1 state: down mac: 08:62:66:ce:29:cf
Drives:
Local Storage: total: 931.51 GiB used: 22.27 GiB (2.4%)
ID-1: /dev/sda vendor: Toshiba model: MQ01ABD100 size: 931.51 GiB
Partition:
ID-1: / size: 915.40 GiB used: 22.26 GiB (2.4%) fs: ext4 dev: /dev/sda2
Sensors:
System Temperatures: cpu: 6280.4 C mobo: N/A
Fan Speeds (RPM): cpu: 2000
Info:
Processes: 253 Uptime: 46m Memory: 7.66 GiB used: 2.92 GiB (38.2%)
Shell: bash inxi: 3.0.38
cat /etc/default/grub

If you change this file, run 'update-grub' afterwards to update

/boot/grub/grub.cfg.

For full documentation of the options in this file, see:

info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=0
GRUB_DISTRIBUTOR=lsb_release -i -s 2> /dev/null || echo Debian
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

Uncomment to enable BadRAM filtering, modify to suit your needs

This works with Linux (no patch required) and with any kernel that obtains

the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)

#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

Uncomment to disable graphical terminal (grub-pc only)

#GRUB_TERMINAL=console

The resolution used on graphical terminal

note that you can use only modes which your graphic card supports via VBE

you can see them in real GRUB with the command `vbeinfo'

#GRUB_GFXMODE=640x480

Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux

#GRUB_DISABLE_LINUX_UUID=true

Uncomment to disable generation of recovery mode menu entries

#GRUB_DISABLE_RECOVERY="true"

Uncomment to get a beep at grub start

#GRUB_INIT_TUNE="480 440 1"

GRUB_THEME=/usr/share/grub/themes/zorin/theme.txt
nadine01@nadine01:~$
No way the laptop wanted to boot in whatever mode. I installed Zorin on usb, and started the laptop from de usb. I tried the "try zorin" and "repair boot". But that didn't work. So in the end I reinstalled the lot. But now my Zorin is different from before: can't pin favorite apps or programs, not possible to put shortcuts on de desktop etc.. And I won't start about the sambashare which worked flawlesy before. I don't understand

I'm at a loss right now. Your drivers seem to be fine and so does your hardware.

I'd say try a reinstall once more? :man_shrugging:

Sorry I couldn't be of more help.

So kind to take a look at everything. I don't have a clue either. I'm gonna try a new zorin download and hope all will end wel/

1 Like

When you download, don't use a Download Accelerator Manager as this will corrupt the image of the .iso. Don't forget to check the SHA256 sum of the iso to ensure the download is not corrupted.
Lastly, how did you install Zorin? USB or DVD? If USB what program did you use?

straight on startup, without any other program. The first time it went as a dream... In the meantime I reinstalled it. Hopefully this time it will go as expected.