Problem opening apps - 15.3 Core

I have just done a software update. Then tried to open Thunderbird by single click on Taskbar icon. Window stating Thunderbird already open. Weird.
Repeated with Firefox, same result.

I then did a Power Off, Restart.
Still Get same problem with Thunderbird and Firefox and more, see screenshot.

Desktop problem

When I tried to view screenshot by clicking the file in my Downloads folder, a message then displayed at top of screen stating “Screenshot is ready” and Image Viewer icon was in Taskbar. i.e. the image did not open with Image Viewer when file double clicked as did before.

Has something in last Zorin software update today messed up the (Gnome) Desktop?
The only things I witnessed being added by todays update was something about initramfs tools etc.

Well. Since my OP above I have done yet another Power down/ Restart.
I have now retested opening Thunderbird, Firefox by both single clicking taskbar icons, and then by double clicking desktop icons. Also double clicking screenshot .png file to view in Image Viewer.
This time the Gnomes are better behaved and I am not getting spurious warnings about app already open or image opened but minimised on taskbar.
I hope that was a one-off glitch. I do not know if the software update (which did not require a restart) was responsible or a coincidence.
I will report here again if the desktop Gnomes misbehave any more, otherwise assume this problem is resolved.

Sorry to hear, zab.
Firefox is notorious for not completely shutting down, even on Windows.
But your problems with others indicate its not just Firefox.
Zorin desktop and Gnome packages are on Synaptic Package Manager and you could try reinstalling them from there. But I don’t know if that will fix your problem (or even address it properly), so maybe better waiting for Aravisian or Swarf (or anyone else who knows what they’re doing - unlike me :roll_eyes: )?

Thanks @carmar, Thought i had it fixed yesterday (re my second post above).
I did another small Zorin software update just after booting today and problem came back.
The desktop icon was calling for 2 instances of Firefox with one double-click.
So I opened up Settings>Devices>Mouse & Touchpad and played with different mouse click speeds. Seemed OK.
Then tried opening FF from start menu with double-click. That was OK.
Also opening FF from taskbar icon with single click OK.
So I binned the desktop icon and dragged a fresh one from Start Menu. Maybe coincidence but seems OK again after that.

After this instability, I went to to Settings>Sound to check my speakers still worked. Nope!
Wriggled volume slider frantically back and forth a few times. Tested speakers again and now OK. I have said elsewhere, sound problems do not follow science but art…martial art! But always seems to work for me :face_with_raised_eyebrow:

1 Like

Hey, I don’t know everything!

Take a look here about initramfs - I had an issue updating initramfs on a different install following cloning of a failing drive to a new one of a different OS, whilst not disconnecting (either physically or BIOSly) my Zorin drive and I had to reinstall Zorin - something to bear in mind for future reference (Note to self! LOL!):

@swarfendor437. Thanks. Just read that. Something to consider. At the moment I am keeping an eye out for bad behaviour. Including the potential of a sick mouse.

Today I had same problem, but no software updates today.
I used settings to swap over the mouse keys left to right. That resulted in single instances of Firefox launch when right (acting as left) double click used.
I have now plugged in a replacement mouse. Can’t blame software for everything, just most things.


@zabadabadoo Or should that read “…just mouse things.” :wink:

1 Like

Never a Ban Button around when you need it…