Problem to install a 3rd party software

Here's my problem, as a mixed gas diver, I plan my dive profiles using this software : MultiDeco by HHSsoftware. I've been using it for years, and there's a Linux version (Mint, Ubuntu, Deb as stated on the website)

I've used it previously under Linux Mint on my laptop without any problem. But since I switched to Zorin, I can't install it.

I've followed the directions given in the readme file provided (i.e lauching the "Install-Mint_Ubuntu_Deb.sh" file in a terminal) but after the install starts, the terminal windows disappears and the app is nowhere to be found.

Any help's welcome.

Concerning my laptop, here's the inxi output :

System:
Host: jm-HP-Notebook Kernel: 5.15.0-58-generic x86_64 bits: 64
Desktop: Gnome 3.38.4 Distro: Zorin OS 16.2
Machine:
Type: Laptop System: HP product: HP Notebook v: Type1ProductConfigId
serial: <superuser/root required>
Mobo: HP model: 81F1 v: 64.29 serial: <superuser/root required>
UEFI: Insyde v: F.09 date: 05/19/2016
Battery:
ID-1: BAT1 charge: 20.2 Wh condition: 34.3/41.4 Wh (83%)
CPU:
Topology: Dual Core model: Intel Celeron N3060 bits: 64 type: MCP
L2 cache: 1024 KiB
Speed: 572 MHz min/max: 480/2480 MHz Core speeds (MHz): 1: 572 2: 1003
Graphics:
Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx
Integrated Graphics
driver: i915 v: kernel
Display: x11 server: X.Org 1.20.13 driver: i915 resolution: 1366x768~60Hz
OpenGL: renderer: Mesa DRI Intel HD Graphics 400 (BSW) v: 4.6 Mesa 21.2.6
Audio:
Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series
High Definition Audio
driver: snd_hda_intel
Sound Server: ALSA v: k5.15.0-58-generic
Network:
Device-1: Realtek RTL8188EE Wireless Network Adapter driver: rtl8188ee
IF: wlp2s0 state: up mac: 74:c6:3b:a5:4b:e6
Device-2: Realtek RTL810xE PCI Express Fast Ethernet driver: r8169
IF: enp3s0 state: down mac: 98:e7:f4:82:1b:92
Drives:
Local Storage: total: 931.51 GiB used: 309.96 GiB (33.3%)
ID-1: /dev/sda vendor: Western Digital model: WD10JPVX-60JC3T0
size: 931.51 GiB
Partition:
ID-1: / size: 915.32 GiB used: 309.95 GiB (33.9%) fs: ext4 dev: /dev/sda2
Sensors:
System Temperatures: cpu: 34.0 C mobo: 27.8 C
Fan Speeds (RPM): N/A

Gday @JMBL , Welcome to the community,
Most distro's have different commands..
eg. sudo apt-get install "program name"
I dont see the app in the software app, So try installing direct from the,
website
May be easier?

Note ZorinOS is based on Ubuntu 20.04

Hi @Ocka.

Thank you for the welcome and the suggestion.

I fear I wasn't clear enough, I did download the app from the website and followed the given instructions but, as stated, with no success.

I've duly noted that Zorin OS is based on Ubuntu, that's why I was hoping to install the app without fuss, as I did previously on Linux Mint, but it seems I was mistaken.

try
sudo apt-get -f install programs-name
or
sudo apt install --reinstall programs-name
may fix the install,
then reboot.
Or start from scratch,

sudo apt update
then
sudo apt upgrade

after this is completed run
sudo apt purge
&
sudo apt autoremove

Now for installing again.
Run,
sudo apt -y install programs-name
this should gather everything it needs

Also try here for further info on installing.

What is the error output for the install?

sometimes the install .sh will declare what OS it will work on such as amd-pro drivers, and going in and changing "Ubuntu" to "Zorin OS" in the .sh file will allow the install to continue.

Or it might be a missing dependency that can be manually installed first

I tested the required software on installation-proces on my Zorin 16.2 Core - Kernel 6.1.7 xx (what was the tricky part lol) .

Ok
Open Terminal and set your path to the unpacked Tar file. In my case this was called multideco map or folder.
---- If this step is too difficult for you there is an easy PRO - way I'd like to share:
Open Terminal and set it to the left (or right) of your screen. Now open your Home-map or folder. Click to the downloaded Tar and unpacked map. Set this window on the opposit side of your terminal-window (terminal left, home-folder right e.g. ) .
Now just continious LEFT-click the multideco-map and GRAB, DRAG and DROP it into the TERMINAL ! (Not double click!! lol)
The TERMINAL will show you the PATH of the multideco - map (or folder).
Remove in the terminal the quote marks ' ' so that the path remains over. Use the arrow-keys of the Keyboard to do it. Now add in the beginning of the remaining path cd
Normally the terminal will show that it is now in the /home/your account name/ Downloads/ multideco xxxxx $ _

---------- End Pro-way of path to file in the terminal

Now simple type in the terminal : (again a PRO-tip: rename the file for easy manipulation in the terminal : right click the file in your map, and choose rename and don't forget the extension: e.g. xxx.sh as new name)

sudo ./Install-Mint_Ubuntu_Deb.sh

And the installer will do it's job all the way , with a nice thumbnail in your Zorin-menu .
So this Software DOES WORK on Zorin 16.2

Uninstalling this software = same procedure but use the

sudo ./UN-install-Mint_Ubuntu_Deb.sh

Uninstalling gives a small error warning, but it has no real problem at all, just do a sudo apt clean , sudo apt autoremove and all will be fine.

So if it even runs fine on a Kernel 6.1.7 xxx it will run fine on 5.15.058 !

1 Like

@Ocka sorry mate, but none of it his working, keep getting the error message : "Impossible de trouver le paquet Install-Mint_Ubuntu_Deb.sh
"

1 Like

@seanhinkley The error message is "Impossible de trouver le paquet Install-Mint_Ubuntu_Deb.sh"

No missing dependency apparently.

"changing "Ubuntu" to "Zorin OS" in the .sh file will allow the install to continue." => how should I do that ?

Sorry doesn't help and I must say I'm not sure I did everything correctly.

Well, some new development around here... It works now, could even insert my registration key.

Just rerun the install as stated by the developer but from my home folder, and this time it worked perfectly.

The idea to install from the home folder came from what @joshuaorbit told me. Did it all through Gnome and problems seemed like a thing from the past.

Thank you all for your time and suggestions, it helped the new kid on the block a lot. See ya later I hope.

1 Like

Sounds like you're double-clicking the Install-Mint_Ubuntu_Deb.sh file to run it, a Terminal window pops up, but it errors out and the Terminal window closes before you can get the error, correct?

Open a terminal window and then run the Install-Mint_Ubuntu_Deb.sh file from within that Terminal window, so it doesn't immediately close... then you'll be able to see the error. To get the path of the .sh file, right click it and select Properties.

I've not experienced a .deb file that requires a .sh file to install... generally you can just double-click the .deb file, the Software application will pop up, and you install it from there.

1 Like

I need to mention maybe that it is a tar.xz - file with a dubious .deb name ...... I would normally walk miles away from things like these. But that is no help either.
So I broke a leg .... and did the install.
it is a xxxxxxx .Deb/sh - file ....... so 3th-party software comming from an Android-minded website ...... Not shure if I really helped or solved this problem, but the point is it installs as ./ xxxxxxxx .sh -file would normally do.

The washing out of my system was something else ...... I really don't like these things at all ! People should be banned asking for this kind of potentional trouble. @Mr_Magoo @JMBL @337harvey

Sorry you got in trouble, but I'm not responsible for what the dev did well or not.

As far as I'm concerned, there are not so many software on the subject of mixed gas diving and that one is the only one (except for Subsurface) that runs on Linux. I've been using it for 10 years on various systems and not having to learn to use a new one is time saving and reassuring.

Enjoy the coming week end, guys.

1 Like

No trouble at all !
But be much more carefull about 'installing 3rd party software in the wild'.
Not all are Saints, and not all software is what it promisses that it is.
No real warranties anywhere ......
So, I am happy it works but in general this is not a good idea for installs like this example.
That is why Ubuntu prevents more and more this kind of odd situations.
If it does not work, seek for an alternative before you just click and install it.
But as said, no harm done.

Glad you got it sorted!

What i ment above is in the amdgpu_install script you find the below section and change ubuntu to Zorin Os to make it install in zorinos :slight_smile: otherwise it says its a non supported distribution even though its ubuntu 20.04 based

1 Like

I see Subsurface on Software Center, did you try that or you installed only from other sources?

Sorry, but my problem wasn't with Subsurface, which I do not use, but with Multideco a commercial software. The problem is solved now.

1 Like