Problem Updating NordVPN

Well my reinstalling Zorin 16 Pro using Rescuezilla went extremely well UNTIL I tried to update NordVPN using the terminal ..... I went online and found these instructions .....

"The only exception for automatic updates is NordVPN’s Linux app. If you’re wondering how to update NordVPN for Linux, simply run these commands:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get install nordvpn

Once done, you will have the latest NordVPN version. "

First command went well no problem ..... as far as the "sudo apt-get upgrade" not so good ..... first off it took 43 mins to complete and filled 43 pages of 12 pt type .... I should have known something was wrong but to late to stop it once it got started .....

The third command worked fine and NordVPN was installed ..... HOWEVER .... I noticed that my Bluetooth keyboard was disconnected ..... and it took forever to get it connected again ..... I seemed to have a big problem using the terminal to load certain programs mostly telling me I didn't have permission ...... even though I used sudo ..... it gave me some suggestions but when I copied and pasted these suggestions .... as I have done in the past ..... in the command line these didn't work with no further suggestions .... there were other problems but to numerous for me to remember ....

When I got up this morning and opened Zorin it took 4-5 mins. to load to the sign-in screen and it was totally different that the normal Cinnamon sign-in screen .... sign in box was completely different .... didn't take a picture .... and the background had changed ..... signed in and again took several mins ..... my Bluetooth keyboard didn't work again and my wallpaper I used yesterday had changed .....

Moral to this sad story is I believe I messed up by doing that "sudo apt-get-upgrade" ..... but no problem not going to spend days trying to find the all problems ..... I have all the tools handy to wipe .... and install Zorn from Rescuezilla again and everything worked ..... this time I will NOT do the "sudo apt-get-upgrade" .....

By the way I use Windows and Macrorit Free Partition Software ..... to completely wipe a HD as I've had problems in the past trying to format an OS while I was using it .... I find it much easier than gParted but that's just me ....

I'm off to install Zorin 16 Pro from Rescuezilla once again ....

Here is another problem I just thought of .... I can't change my NVIDIA drivers I get this message .....

And another one terminal command ....

the could not get a lock on /var/cache/apt/* apt is already running, this usually happens when software updater is running in the background and you manually run apt.

for the bluetooth keyboard, sounds like an updated driver is causing issues, i would skip sudo apt-get upgrade and just do the following

sudo apt update
sudo apt install nordvpn

then use the software updater to update Zorin itself,and look through the packages and uncheck any bluetooth related ones additional driver updates will be shown there,

2 Likes

Thanks .... I have Nordvpn installed and operational now after playing with it for quite sometime now th problem is it keeps telling me to sign in but when I try the stupid website says "OOOOPS something is wrong please go back to the website" ..... 0-and around and around we go ..... still working on that ..... looks like a browser problem rather than an OS one ..... all these programs on this version .... 12-09-2010 ... are way out of date including my browser .....

Got the keyboard partially fixed I have to turn off the bluetooth put the keyboard in search mode turn the bluetooth back on ..... hit the bluetooth icon in the task bar and choose a setting and we are back in business ...... again an inconvenience but doable

I really think I need to copy my Home Folder that I saved in it's entirely including Hidden Folders and paste it over this version I am presently using to see if it will up date this one ..... but I'm going to start a different thread on that so as to keep all this mess separate ..... good or bad idea ??????

1 Like

I just backup my documents, and reinstall everything. I don't bother with settings and stuff. If my system is screwy it buggy I don't want to copy corrupted files or settings over, that goes for Linux window or macos.

3 Likes

OK so maybe just my Documents .... Downloads ..... Pictures and Videos ..... there shouldn't be anything in them that could effect anything or could there ???? .... no hidden folders

2 Likes

This only means that something else like Synaptic, Software store or a Terminal is running connected to APT.
Closing it will release the lock.

EDIT: All the other replies popped up. Weird. Anyway... I see SeanHinkley covered the above already...
Moving on:

No, there shouldn't be anything in those folders that can affect system files and operation.

This is unlikely. If anything, the /.config files, if backed up, may re-introduce a problem.

I think you should run the command sudo apt upgrade but do not press the y key. Instead, copy and paste here the printout of what will be upgraded.

1 Like

I already made a hard copy of the entire 42 pages are you sure you want me to post all that ..... :grin: ....... oooops ..... I see you just want to see what will be upgraded ..... can do ..... am waiting till some of my folders are getting downloaded to this copy of Zorin ..... don't want to mess something up .....

Here you go I forgot I already downloaded them also .......

mike@mike-ROG-Strix-G731GT-G731GT:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
audacity audacity-data gir1.2-animation-glib-0
gir1.2-ges-1.0 libanimation-glib0 libanimation0
libflac++6v5 libges-1.0-0 libid3tag0 libjs-jquery-ui
libportsmf0v5 libsuil-0-0 libvamp-hostsdk3v5
libwxbase3.0-0v5 libwxgtk3.0-gtk3-0v5 pitivi
python-matplotlib-data python3-cycler python3-kiwisolver
python3-matplotlib python3-numpy python3-pyparsing
zorin-os-feedback
Use 'sudo apt autoremove' to remove them.
The following packages have been kept back:
fonts-zorin-os-core gir1.2-javascriptcoregtk-4.0
gir1.2-webkit2-4.0 libjavascriptcoregtk-4.0-18
libreoffice-base-core libreoffice-calc
libreoffice-common libreoffice-core libreoffice-draw
libreoffice-gnome libreoffice-gtk3
libreoffice-help-common libreoffice-help-en-us
libreoffice-impress libreoffice-writer
libuno-cppuhelpergcc3-3 libwebkit2gtk-4.0-37
linux-generic-hwe-20.04 linux-headers-generic-hwe-20.04
linux-image-generic-hwe-20.04 python3-uno
uno-libs-private ure zorin-os-pro-productivity-apps
The following packages will be upgraded:
846 base-files bash bind9-dnsutils bind9-host bind9-libs
bluez bluez-cups bluez-obexd bsdutils busybox-initramfs
busybox-static ca-certificates copperdeck3 cpp-9 cups
cups-bsd cups-client cups-common cups-core-drivers
cups-daemon cups-ipp-utils cups-ppdc cups-server-common
curl dbus dbus-user-session dbus-x11 dirmngr
distro-info-data dnsmasq-base dpkg dpkg-dev e2fsprogs
empire-theme fdisk firefox firefox-locale-en flatpak
fonts-croscore-config-zorin-os fonts-inter-zorin-os
fonts-jetbrains-mono-zorin-os fonts-michroma-zorin-os
fonts-opensymbol fonts-roboto-mono-zorin-os
fonts-sans-forgetica-zorin-os
fonts-space-grotesk-zorin-os g++-9 gcc-9 gcc-9-base
ghostscript ghostscript-x gir1.2-flatpak-1.0
gir1.2-gdesktopenums-3.0 gir1.2-gdkpixbuf-2.0
gir1.2-gst-plugins-base-1.0 gir1.2-gstreamer-1.0
gir1.2-polkit-1.0 gnome-shell-extension-x11gestures
gnome-shell-extension-zorin-connect
gnome-shell-extension-zorin-connect-browsers
gnome-shell-extension-zorin-magic-lamp-effect
gnome-shell-extension-zorin-menu
gnome-shell-extension-zorin-window-move-effect
gnome-tour gnupg gnupg-l10n gnupg-utils gpg gpg-agent
gpg-wks-client gpg-wks-server gpgconf gpgsm gpgv
grub-common grub-pc grub-pc-bin grub-theme-zorin
grub2-common gsettings-desktop-schemas gstreamer1.0-alsa
gstreamer1.0-gl gstreamer1.0-gtk3
gstreamer1.0-plugins-base gstreamer1.0-plugins-base-apps
gstreamer1.0-plugins-good gstreamer1.0-pulseaudio
gstreamer1.0-tools gstreamer1.0-x gthumb gthumb-data
gzip intel-microcode isc-dhcp-client isc-dhcp-common
klibc-utils libarchive13 libasan5 libasn1-8-heimdal
libavcodec58 libavfilter7 libavformat58 libavutil56
libblkid1 libbluetooth3 libc-bin libc-dev-bin libc6
libc6:i386 libc6-dbg libc6-dev libcom-err2
libcryptsetup12 libcups2 libcupsimage2 libcurl3-gnutls
libcurl4 libdbus-1-3 libdpkg-perl libdrm-amdgpu1
libdrm-common libdrm-intel1 libdrm-nouveau2
libdrm-radeon1 libdrm2 libegl-mesa0 libegl1 libevdev2
libexempi8 libexiv2-27 libexpat1 libext2fs2 libfdisk1
libflatpak0 libfreerdp-client2-2 libfreerdp2-2
libfreetype6 libfribidi0 libgbm1 libgcc-9-dev
libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-bin
libgdk-pixbuf2.0-common libgl1 libgl1-mesa-dri
libglapi-mesa libgles2 libglvnd0 libglx-mesa0 libglx0
libgmp10 libgnutls30 libgs9 libgs9-common
libgssapi3-heimdal libgstreamer-gl1.0-0
libgstreamer-plugins-base1.0-0
libgstreamer-plugins-good1.0-0 libgstreamer1.0-0
libharfbuzz-icu0 libharfbuzz0b libhcrypto4-heimdal
libheimbase1-heimdal libheimntlm0-heimdal
libhttp-daemon-perl libhx509-5-heimdal libinput-bin
libinput10 libjpeg-turbo8 libklibc libkrb5-26-heimdal
libksba8 libldap-2.4-2 libldap-common libldb2 libllvm12
liblouis-data liblouis20 liblzma5 libmount1
libmysqlclient21 libnss-systemd libnss3 libntfs-3g883
libostree-1-1 libpam-systemd libpcre2-16-0 libpcre2-32-0
libpcre2-8-0 libpcre3 libperl5.30 libpolkit-agent-1-0
libpolkit-gobject-1-0 libpoppler-cpp0v5 libpoppler-glib8
libpoppler97 libpostproc55 libpq5 libpython3.8
libpython3.8-minimal libpython3.8-stdlib libqt5core5a
libqt5dbus5 libqt5gui5 libqt5network5 libqt5opengl5
libqt5printsupport5 libqt5sql5 libqt5sql5-sqlite
libqt5test5 libqt5widgets5 libqt5xml5
libreoffice-style-colibre libreoffice-style-elementary
libreoffice-style-yaru libroken18-heimdal libruby2.7
libsasl2-2 libsasl2-modules libsasl2-modules-db
libseccomp2 libsepol1 libsmartcols1 libsmbclient
libsnmp-base libsnmp35 libspeex1 libspeexdsp1
libsqlite3-0 libss2 libssl1.1 libstdc++-9-dev
libswresample3 libswscale5 libsystemd0 libtiff-tools
libtiff5 libudev1 libuno-cppu3
libuno-purpenvhelpergcc3-3 libuno-sal3
libuno-salhelpergcc3-3 libuuid1 libwayland-client0
libwayland-cursor0 libwayland-egl1 libwayland-server0
libwbclient0 libwind0-heimdal libwinpr2-2 libxatracker2
libxml2 libxslt1.1 linux-libc-dev locales logsave
mercury mesa-va-drivers mesa-vdpau-drivers
mesa-vulkan-drivers moebius mount networkd-dispatcher
nordvpn ntfs-3g openssl openvpn orca perl perl-base
perl-modules-5.30 plomb policykit-1 poppler-utils
predator prowler2021 python-apt-common python3-apport
python3-apt python3-distupgrade python3-jwt python3-ldb
python3-louis python3-mako python3-paramiko python3-pil
python3-problem-report python3-software-properties
python3-update-manager python3.8 python3.8-minimal
qt5-gtk-platformtheme rfkill rsync rsyslog ruby2.7
samba-libs snapd software-properties-common
software-properties-gtk systemd systemd-sysv
systemd-timesyncd tar tcpdump tranquility tzdata
ubuntu-release-upgrader-core ubuntu-release-upgrader-gtk
udev unzip update-manager update-manager-core util-linux
uuid-runtime vim-common vim-tiny vivaldi-stable
wireless-regdb xdg-desktop-portal xdg-desktop-portal-gtk
xserver-common xserver-xephyr xserver-xorg-core
xserver-xorg-legacy xwayland xxd xz-utils zlib1g
zlib1g:i386 zorin-appearance zorin-auto-theme
zorin-desktop-themes zorin-exec-guard
zorin-exec-guard-app-db zorin-icon-themes
zorin-os-artwork zorin-os-default-settings
zorin-os-desktop zorin-os-minimal
zorin-os-printer-test-page zorin-os-pro-creative-suite
zorin-os-standard
344 upgraded, 0 newly installed, 0 to remove and 24 not upgraded.
Need to get 523 MB of archives.
After this operation, 188 MB of additional disk space will be used.
Do you want to continue? [Y/n]

Id skip the following
bluez bluez-cups bluez-obexd bsdutils

sudo apt-mark hold bluez bluez-cups bluez-obexd bsdutils

Then try

sudo apt upgrade

That should upgrade all the packages except those bluez (Bluetooth) ones.

If you need to update them in the future to do so just

sudo apt-mark unhold bluez bluez-cups bluez-obexd bsdutils

I wonder if microcode and amdgpu1 are the cause of some of your graphics issues?
And why are ubuntu-release-upgrader listed at all? This is the Direct Upgrade feature, which is default disabled on Zorin OS until that tool is ready and deployed.

You have quite a few apps listed as Held.
Ignoring the LibreOffice stuff... Holding these back while the rest upgrades could cause conflicts in package dependent calls.
I do not understand why these are held.

Man...that is hosed up, and I don't even know as much as most others here do! :smile: I have reinstalled Zorin Pro several times due to "me problems" and to me it looks like you may have been installing/removing other packages with Terminal while the system was installing/upgrading.

After you did your reinstall, did you copy over your original system settings? I would be tempted to do another install and select the NVIDIA drivers offered, and after the install wait a few minutes and let the OS settle itself and then use Software updater and get the latest Zorin, reboot and then use Software to update what it wants to. Being the known coward that I am I would not remove any packages until the system was on its final setup.

1 Like

Sorry folks but I can't reply to you right now ..... I broke all my fingers with a hammer ..... now maybe I will quit tinkering with stuff .... I totally fowled up the new Zorn OS I just installed yesterday big time ..... I as so ashamed I didn't even bother to try and get help on the board .....

But all s well once again as I formatted the HD and reinstalled Zorn 16 Pro from Rescuezilla and we are once again on the road to recovery .... but this time I will make a new backup of Zorn on Rescuezilla as I don't quite trust myself with Timeshift yet .... I want to do this while EVERYTHING is working great .... cause you never know what tomorrow will bring ....

Be back later .... I'm like a bad penny .... I always turn back up .... :roll_eyes: :grin:

1 Like

Welcome to the club, newbie.

I've done this so many times lol, there's a reason I will start suggesting a reinstall after a certain point, because i may or may not have wasted weeks on end in the past trying to solve self inflicted issues and it can get discouraging. :slight_smile:

now the big question, was the hammer for construction, or were you fixing the computers attitude :rofl:

2 Likes

:grin: ... no it was for my fingers to keep reminding me to keep my busy fat fingers out of stuff that I had no business getting into .....

By the way all these turmoils I was having with my old wireless mouse and keyboard disappeared ..... they are now working flawlessly .... also the 3 buttons .... Min ... Max ... and Delete in the very top right hand corner are working just fine ....

Last night after I had reinstalled Zorn from my Rescuezilla backup and installed my old saved Documents .... Downloads .... Games ..... Pictures ... Videos and the .icons & .themes (only) from my Hidden Files I made another Rescuezilla backup just in case I manage to do something stupid again ....

I love Rescuezilla but last night I found something I finally dislike about the program ...... if you don't have enough space needed for your backup it will start backing it up anyway .... and after it didn't advance for more than 30 mins I had to abort it and clear some old files from that HD and start all over .....

Also the fact that you can do subsequent partial backups ..... it is either the whole drive or nothing .....

Timeshift looks like a much better option for that .... I did a whole drive backup of my old buggy system on Timeshift but don't want to install it for obvious reasons ..... I'm going to play with this system for a while yet to make sure it stays healthy before I try another whole disk backup with Timeshare ..... besides I need to learn more about the program ....

Onward and Upward ..... :grin:

I finally got NordVPN to work .... I went to their website numerous times to no avail ..... even spent wasted time with their animated problem solver ..... it had me reinstall Nord and one of the steps was to run "sudo apt upgrade" again but this time with out the -y any way doesn't seem to be any problems with the upgrade this time but Nord still didn't work .... I kept getting a "no such command" or something to that effect ....

Well in desperation for some odd reason I went to Synaptic and searched for NordVPN not expecting to find it but there it was ..... downloaded it typed in a few commands in the terminal and got a web page to put in my browser ..... it opened to a sign in page and a few minutes later I was able to open NordVpn from the terminal once again ..... :+1: :grin:

1 Like