Problem With Charging

Greetings Community,

I've been using zorin for two years I guess & I'm really in love with it but suddenly from a week I've been facing an issue which is quite a problem for me now.
I noticed my charger was connected to the laptop & it did made charging connected sound but didn't charged a single percentage & neither made it stable on that percentage instead kept falling till it switched off my laptop. I want to know what's actually wrong there because, I've tried reinstalling my current version which is 15.3 core & after this problem I've also tried the latest version but still the issue persists & I installed & installed another OS too like ubuntu, mint, manjaro, mint, arch, garuda only to see that there's the same issue everywhere.
Really need your help now.
I did tried looking for drivers if there's any additional ones but no luck there too.

my laptop: HP Pavilion 14ec model.

I hope I'll hear back from some of you too

Websearch of "no battery charging HP Pavilion 14ec model ubuntu 20.04"

Found this: power management - Battery not charging but detected - Ask Ubuntu

Question: does the battery charge when plugged in and laptop switched off?
(another user had this problem)

1 Like

This is strongly indicative of an issue with the battery. From the use case of 15.3, we can see it is unlikely that a kernel upgrade included a regression that caused it.
Don't panic, yet... This doesn't mean that the battery is bad.
It may mean that the communication between the battery and the system is not working correctly.
Things you can try:
Remove the CMOS battery
If you have the setting in BIOS /EFI settings > Config for Disable Built-in Battery, select it
Hold the power button off for a good solid 30 seconds to drain capacitors.
Replace CMOS battery and reset in BIOS

Turn the notebook computer on and Do Not Charge. Use as normal until it is nearing death and then switch over to frivolous work or throw on an uninteresting video and let the notebook fully die.
Charge the notebook overnight.
The following day, power on the notebook and remove from charger. Use as normal until the battery dies again, then charge overnight again.

I realize that this is lengthy but... What this will do is recalibrate the battery sensor.

A possible cause: Not fully discharging a battery and then charging it repeatedly over a long period of time.
This is actually true for many devices, any OS or no OS at all... it includes rechargeable AA batteries, too.
Batteries are funny little animals and not as reliably centered as we would like to believe. Electron Exchange occurs in reality quite differently from how the Pop-Sci diagrams make it look in simplified form. And this can lead to artifacts.
By fully discharging capacitors and battery, you essentially give a known starting point: Zero.
Electron flow from Zero must then follow and maintain a path of least resistance.
Instead of electron flow starting at the last free movement, it now must start at the only available free movement at the bottom.

I realize that I laid this out rather poorly, but I hope it makes sense.

If the above does not work at all... Then you may have a dying or faulty battery.


Also, Try reinstalling the Indicator Plugin.

and Try This, If the above does Not work.
cmd Can be accessed using the advanced options of a win 10 boot drive.

At the command prompt, type powercfg /restoredefaultschemes and press Enter
Reboot back into Zorin - did the behavior change?

Also some BIOS have a setting called Flexi-Charger make sure it is Enabled


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.