Problem with my headset's output and microphone

Hi guys,
I recently downloaded Zorin OS and it's great!

One little problem tho...
I use G435 Headest and on Windows it worked completely fine, but on Zorin it's a bit different. Output is okay with A2DP, but the microphone is set to my laptops one (TigerLake) instead of the one from headset for some reason.
The problem is, whenever I change the microphone to be the one from headset, it changes the output to HFP and I can't change it back to A2DPwithout the microphone being from laptop.

Thanks for reading,

Seuen

Welcome to the Forum!

Did You tried PulseAudio Control? It is a Tool to adjust Input/Output Sound Stuff. To install it open the Terminal and type sudo apt install pavucontrol

1 Like

Thanks for a reply.

I just tried it out and the headset's microphone doesn't show up in Input devices only TigerLake.

1 Like

OK lets see if alsamixer can help you with microphone input channel settings.

In terminal (ctrl+alt+t) type:

alsamixer

In alsamixer, first hit F6 and check correct soundcard is listed and selected.

Use arrow keys to move from one channel to another.
If channels show as [MM] muted, unmute by typing "M"

Have a play around with your capture (input, microphone) channels.
Try setting [Auto-Mute] channel=disabled
Also try changing [Loopback] from disabled/enabled to see if helps.

Sound problems are sometimes illogical and difficicult to solve, hence advice to "play around"

If you find a alsamixer setup that works, save it using:

sudo alsactl store

You can post a screenshot of your alsamixer, which may give us something to check. If you do that, hit F5 to show all sound channels. Scale your window to show them all, not with arrows on right edge.

1 Like

I played a bit, but nothing seems to work.
Here's a screenshot of my alsamixer with every sound channel as you said:

Also, the mic works it's just very quiet for some reason. But it changes output to HFP which is lower quality in comparison to A2DP. Changing back to A2DP with G435 microphone just makes it again HFP.

I can't see much wrong there. Have you increased all channels to 100%

You may wish to websearch using:
"sof-hda-dsp mic sound Ubuntu 22.04" or
"ALC257 mic sound Ubuntu 22.04"
as Z17 is based on Ubuntu 22.04.

From my own searches, there seem to be many users of ALC257 with sound issues, including a bug report.

1 Like

On the first Entry stand ''Headphones Stereo Microphone (unplugged)'' isn't this you Headset Mic? when I understand that right it will be controlled over this ''Tiger Lake-LP smart Sound Audio Controller''.

You see at the Site these green Markers. Could You mark the Headphones Mic? And then make a Reboot of Your System.

Another Thing: Take a Look at the Configuration Tab. When you there click on the listed Audio Sources You can turn off what you not need.

1 Like

I tried changing the Headphones Stereo Microphone (unplugged), but it is the only option. The headset is on bluetooth, or a "Dongle" which I use so they're plugged in.

Also the microphone isn't visible in pavucontrol, which is a bit weird because it's okay in the Zorins settings. Just when I use it the output changes to HFP somehow and I can't change it back A2DP which is way higher quality.

For any info just ask and thanks for all the help so far. Sadly everything I tried out didn't work.

Okay, so I'm a bit stupid, because I found out A2DP doesn't support microphone.
It's a bit sad message for me because I enjoy Zorin and it's the only linux distro that did that. I'm probably gonna switch to another distro or back to Windows, if I don't find any solution.

can u see me the configuration tab in pavucontrol?

I don't think anything was wrong there.
I'm also gonna close this topic, but I don't know how.
That's because I distro hopped.

Thanks for all the help,
Seuen