Problem with suspended mode on Asus Zenbook duo

I have a really weird problem. When I install Zorin on my Asus Zenbook duo, everything seems to work fine, but when I close the lid or press the power button to go into suspend mode (I think) the second monitor won't turn off and the laptop gets hot and warm. I have the last NVidia driver update, the last Zorin update, and the last update of everything. There's nothing in the BIOS like "Sleep Mode" so I can't change any of those settings. I've given it to local IT support to check if I have any hardware issues, but they haven't found anything.

Can anyone help me or has at least the same problem?


What is the output of

cat /etc/UPower/UPower.conf

cat /etc/systemd/logind.conf

You can use the noparse tags </> in the reply toolbar to format the output automatically for the forum.

This is the UPower output

# Only the system vendor should modify this file, ordinary users
# should not have to change anything.


# Enable the Watts Up Pro device.
# The Watts Up Pro contains a generic FTDI USB device without a specific
# vendor and product ID. When we probe for WUP devices, we can cause
# the user to get a perplexing "Device or resource busy" error when
# attempting to use their non-WUP device.
# The generic FTDI device is known to also be used on:
# - Sparkfun FT232 breakout board
# - Parallax Propeller
# default=false

# Don't poll the kernel for battery level changes.
# Some hardware will send us battery level changes through
# events, rather than us having to poll for it. This option
# allows disabling polling for hardware that sends out events.
# default=false

# Do we ignore the lid state
# Some laptops are broken. The lid state is either inverted, or stuck
# on or off. We can't do much to fix these problems, but this is a way
# for users to make the laptop panel vanish, a state that might be used
# by a couple of user-space daemons. On Linux systems, see also
# logind.conf(5).
# default=false

# Policy for warnings and action based on battery levels
# Whether battery percentage based policy should be used. The default
# is to use the time left, change to true to use the percentage, which
# should work around broken firmwares. It is also more reliable than
# the time left (frantically saving all your files is going to use more
# battery than letting it rest for example).
# default=true

# When UsePercentageForPolicy is true, the levels at which UPower will
# consider the battery low, critical, or take action for the critical
# battery level.
# This will also be used for batteries which don't have time information
# such as that of peripherals.
# If any value is invalid, or not in descending order, the defaults
# will be used.
# Defaults:
# PercentageLow=10
# PercentageCritical=3
# PercentageAction=2

# When UsePercentageForPolicy is false, the time remaining at which UPower
# will consider the battery low, critical, or take action for the critical
# battery level.
# If any value is invalid, or not in descending order, the defaults
# will be used.
# Defaults:
# TimeLow=1200
# TimeCritical=300
# TimeAction=120

# The action to take when "TimeAction" or "PercentageAction" above has been
# reached for the batteries (UPS or laptop batteries) supplying the computer
# Possible values are:
# PowerOff
# Hibernate
# HybridSleep
# If HybridSleep isn't available, Hibernate will be used
# If Hibernate isn't available, PowerOff will be used

and this is the logind output

#  This file is part of systemd.
#  systemd is free software; you can redistribute it and/or modify it
#  under the terms of the GNU Lesser General Public License as published by
#  the Free Software Foundation; either version 2.1 of the License, or
#  (at your option) any later version.
# Entries in this file show the compile time defaults.
# You can change settings by editing this file.
# Defaults can be restored by simply deleting this file.
# See logind.conf(5) for details.


Change this value in /etc/UPower/UPower.conf to
I realize this seems counter-intuitive but...

In /etc/systemd/logind.conf

On this one (/etc/systemd/logind.conf), change the value to "no" and also remove the (#) at the front (The hashtag at front tells the system to ignore that line and you do not want that line ignroed) so that it is looks just like:

Gaining Root access:

You have two options. Use the Terminal Text Editor elevated to root (easiest):

sudo nano /etc/UPower/UPower.conf

Change the "ignoreLid" value, then once done, tap ctrl+x to exit the editor, the y key to say yes to save, then the enter key to save current configuration.
Repeat that for:

sudo nano /etc/systemd/logind.conf

The GUI Option:
Elevate to root in terminal

sudo -i

Then in the elevated terminal prompt, launch your file manager


Navigate to "Other Locations > Computer", then to the paths outlined above.
/etc/UPower/ then right click on UPower.conf and open with Text editor. Be sure to Save The File after making changes.
Then to the path /etc/systemd/ and right click on logind.conf and repeat as above, being sure to save the file before closing it.
In the elevated terminal, exit root, then close out the terminal and elevated File manager.

Reboot and test.

The values are changed, but the problem is still the same.

After closing the lid, the laptop seems to go into suspend mode, but the second screen is backlit.
When I wake the laptop up, everything starts running fine.

Is the screen active; that is, showing the desktop and allowing interaction with it?

the screen is black, you can't work with it, but it is slightly backlit around the edges.

Ah, I understand you now.

Can you please check if your computer manufacturers BIOS / EFI Settings contain a "Deep Sleep" or "Sleep" setting?

BIOS unfortunately does not contain any "Sleep" settings

Are you logging in on Wayland or X11 window management?

Are you using Intel, Nvidia or AMD graphics?

I went up and read O.P.
You state you are on latest Nvidia Drivers - which drivers?

EDIT: Also please check this thread:

  1. I am logging with X11

  2. and drivers should be the latest. I installed nvidia-driver-520
    but I can't use


I am getting error

NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

I recommend using the 510 (proprietary tested) driver, currently.

The 520 has been shown to be problematic, as of this date, across a variety of cards on Ubuntu-based distros.

Does zorin use 520.56.06 driver ? i can confirm that that one works perfectly fine on my end.

I installed 510 nvidia drivers, but it is only proprietary not proprietary, tested

1 Like

I think I've used them in the past, but they didn't work either


I tried to use this command

systemctl suspend

and leave notebook for 10min in suspended mode, but it just heats up... :frowning:

This is a mistake on my part. You are right - the current available option is "proprietary" for 510.

Okay, I can't believe it, but I found a solution.

First, I want to thank you guys for your help. Without you, I probably never would have solved this problem.

So anyway, there is what help me. (These steps are what I did)

Change this value






and in


change this:


to this:


  1. NVidia drivers what am I currently using:

Using NVIDIA Server Driver metapackage from nvidia-driver-510-server (proprietary)

  1. Check the output of



cat /sys/power/mem_sleep

It has to be

s2idle [deep]

when it is not, do this

sudo -i
echo 'deep' > /sys/power/mem_sleep

That's all :slight_smile:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.