Problema com WIFI no Zorin OS

Acabei de instalar o Zorin OS em meu notebook, e não está reconhecendo o wireless dele, aceitando apenas internet cabeada. Tentei procurar por algumas soluções mas nenhuma funcionou.

iwconfig
lo no wireless extensions.

enx023260087905 no wireless extensions.

inxi -zn
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
driver: N/A
IF-ID-1: enx023260087905 state: unknown speed: -1 duplex: half
mac:

sudo lshw
descrição: Notebook
produto: TP550LA (ASUS-NotebookSKU)
fabricante: ASUSTeK COMPUTER INC.
versão: 1.0
serial: EAN0WU013864408
largura: 64 bits
capacidades: smbios-2.7 dmi-2.7 smp vsyscall32
configuração: boot=normal chassis=notebook family=TP sku=ASUS-NotebookSKU uuid=f6ce8fbf-1893-984f-bb51-382c4aecfa78

*-network DISPONÍVEL
descrição: Ethernet controller
produto: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
fabricante: Realtek Semiconductor Co., Ltd.
ID físico: 0
informações do barramento: pci@0000:02:00.0
versão: 10
largura: 64 bits
clock: 33MHz
capacidades: pm msi pciexpress msix vpd bus_master cap_list
configuração: latency=0
recursos: porta de E/S:e000(tamanho=256) memória:f7c04000-f7c04fff memória:f7c00000-f7c03fff

Please ensure that Secure Boot is disabled in BIOS / EFI settings. Secure boot disallows this driver to boot.

If secure boot is disabled and still not loading wifi, connect using working Ethernet port or using your cell phone as a hotspot connected with USB cable.
Then run:

git clone https://github.com/HRex39/rtl8852be.git

cd rtl8852be

make -j8

sudo make install

sudo modprobe 8852be


Certifique-se de que o arranque seguro está desativado nas definições da BIOS / EFI. O arranque seguro não permite que este controlador arranque.

Se o arranque seguro estiver desativado e continuar a não carregar a rede wifi, ligue-se através de uma porta Ethernet em funcionamento ou utilize o seu telemóvel como ponto de acesso ligado com um cabo USB.
Em seguida, execute:

git clone https://github.com/HRex39/rtl8852be.git

cd rtl8852be

make -j8

sudo make install

sudo modprobe 8852be

o Secure boot está desativado.

Quando eu executei o "make -j8" ele deu alguns erros:

cc1: some warnings being treated as errors
make[3]: *** [scripts/Makefile.build:251: /home/gabrielft02/rtl8852be/platform/platform_linux_pc_pci.o] Erro 1
make[2]: *** [/usr/src/linux-headers-6.5.0-15-generic/Makefile:2037: /home/gabrielft02/rtl8852be] Erro 2
make[1]: *** [Makefile:234: __sub-make] Erro 2
make[1]: Saindo do diretório '/usr/src/linux-headers-6.5.0-15-generic'
make: *** [Makefile:637: modules] Erro 2

E este é o relatório completo apos rodar o "make -j8":

/home/gabrielft02/rtl8852be/os_dep/linux/os_intfs.c: In function ‘rtw_net_set_mac_address’:
/home/gabrielft02/rtl8852be/os_dep/osdep_service_linux.c: In function ‘rtw_change_ifname’:
/home/gabrielft02/rtl8852be/os_dep/osdep_service_linux.c:810:28: warning: passing argument 1 of ‘_rtw_memcpy’ discards ‘const’ qualifier from pointer target type [-Wdiscarded-qualifiers]
810 | _rtw_memcpy(pnetdev->dev_addr, adapter_mac_addr(padapter), ETH_ALEN);
| ~^~~~
/home/gabrielft02/rtl8852be/os_dep/osdep_service_linux.c:48:24: note: expected ‘void *’ but argument is of type ‘const unsigned char *’
48 | void _rtw_memcpy(void *dst, const void src, u32 sz)
| ~~~~^
/home/gabrielft02/rtl8852be/os_dep/linux/os_intfs.c:79:28: warning: passing argument 1 of ‘_rtw_memcpy’ discards ‘const’ qualifier from pointer target type [-Wdiscarded-qualifiers]
79 | _rtw_memcpy(pnetdev->dev_addr, sa->sa_data, ETH_ALEN); /
set mac addr to net_device */
| ~^~~~
In file included from /home/gabrielft02/rtl8852be/include/drv_types.h:25,
from /home/gabrielft02/rtl8852be/os_dep/linux/os_intfs.c:17:
/home/gabrielft02/rtl8852be/include/osdep_service.h:281:24: note: expected ‘void *’ but argument is of type ‘const unsigned char *’
281 | void _rtw_memcpy(void *dec, const void *sour, u32 sz);
| ^
/home/gabrielft02/rtl8852be/os_dep/linux/os_intfs.c: In function ‘rtw_ndev_init’:
/home/gabrielft02/rtl8852be/os_dep/linux/os_intfs.c:294:9: error: too many arguments to function ‘netif_napi_add’
294 | netif_napi_add(dev, &adapter->napi, rtw_recv_napi_poll, RTL_NAPI_WEIGHT);
| ^
~~~~~~~~~
In file included from /home/gabrielft02/rtl8852be/include/osdep_service_linux.h:31,
from /home/gabrielft02/rtl8852be/include/osdep_service.h:42:
./include/linux/netdevice.h:2639:1: note: declared here
2639 | netif_napi_add(struct net_device *dev, struct napi_struct *napi,
| ^~~~~~~~~~~~~~
/home/gabrielft02/rtl8852be/os_dep/linux/os_intfs.c: In function ‘rtw_os_ndev_register’:
/home/gabrielft02/rtl8852be/os_dep/linux/os_intfs.c:623:25: warning: passing argument 1 of ‘_rtw_memcpy’ discards ‘const’ qualifier from pointer target type [-Wdiscarded-qualifiers]
623 | _rtw_memcpy(ndev->dev_addr, adapter_mac_addr(adapter), ETH_ALEN);
| ^~~~~~
/home/gabrielft02/rtl8852be/include/osdep_service.h:281:24: note: expected ‘void *’ but argument is of type ‘const unsigned char *’
281 | void _rtw_memcpy(void *dec, const void *sour, u32 sz);
| ^
/home/gabrielft02/rtl8852be/os_dep/osdep_service_linux.c: In function ‘rtw_random32’:
/home/gabrielft02/rtl8852be/os_dep/osdep_service_linux.c:850:16: error: implicit declaration of function ‘prandom_u32’; did you mean ‘get_random_u32’? [-Werror=implicit-function-declaration]
850 | return prandom_u32();
| ^
~~~~~~
| get_random_u32
/home/gabrielft02/rtl8852be/platform/platform_linux_pc_pci.c: In function ‘pci_cache_wback’:
/home/gabrielft02/rtl8852be/platform/platform_linux_pc_pci.c:21:17: error: implicit declaration of function ‘pci_dma_sync_single_for_device’; did you mean ‘dma_sync_single_for_device’? [-Werror=implicit-function-declaration]
21 | pci_dma_sync_single_for_device(hwdev, *bus_addr, size,
| ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
| dma_sync_single_for_device
make[3]: *** [scripts/Makefile.build:251: /home/gabrielft02/rtl8852be/os_dep/linux/os_intfs.o] Erro 1
make[3]: ** Esperando que outros processos terminem.
/home/gabrielft02/rtl8852be/platform/platform_linux_pc_pci.c: In function ‘pci_cache_inv’:
/home/gabrielft02/rtl8852be/platform/platform_linux_pc_pci.c:30:17: error: implicit declaration of function ‘pci_dma_sync_single_for_cpu’; did you mean ‘dma_sync_single_for_cpu’? [-Werror=implicit-function-declaration]
30 | pci_dma_sync_single_for_cpu(hwdev, *bus_addr, size, direction);
| ^~~~~~~~~~~~~~~~~~~~~~~~~~~
| dma_sync_single_for_cpu
/home/gabrielft02/rtl8852be/platform/platform_linux_pc_pci.c: In function ‘pci_get_bus_addr’:
/home/gabrielft02/rtl8852be/platform/platform_linux_pc_pci.c:39:29: error: implicit declaration of function ‘pci_map_single’; did you mean ‘dma_map_single’? [-Werror=implicit-function-declaration]
39 | *bus_addr = pci_map_single(hwdev, vir_addr, size, direction);
| ^~~~~~~~~~~~~~
| dma_map_single
/home/gabrielft02/rtl8852be/platform/platform_linux_pc_pci.c: In function ‘pci_unmap_bus_addr’:
/home/gabrielft02/rtl8852be/platform/platform_linux_pc_pci.c:50:17: error: implicit declaration of function ‘pci_unmap_single’; did you mean ‘dma_unmap_single’? [-Werror=implicit-function-declaration]
50 | pci_unmap_single(hwdev, *bus_addr, size, direction);
| ^~~~~~~~~~~~~~~~
| dma_unmap_single
cc1: some warnings being treated as errors
make[3]: *** [scripts/Makefile.build:251: /home/gabrielft02/rtl8852be/os_dep/osdep_service_linux.o] Erro 1
/home/gabrielft02/rtl8852be/platform/platform_linux_pc_pci.c: In function ‘pci_free_noncache_mem’:
/home/gabrielft02/rtl8852be/platform/platform_linux_pc_pci.c:97:17: error: implicit declaration of function ‘pci_free_consistent’ [-Werror=implicit-function-declaration]
97 | pci_free_consistent(pdev, size, vir_addr, *bus_addr);
| ^~~~~~~~~~~~~~~~~~~
cc1: some warnings being treated as errors
make[3]: *** [scripts/Makefile.build:251: /home/gabrielft02/rtl8852be/platform/platform_linux_pc_pci.o] Erro 1
make[2]: *** [/usr/src/linux-headers-6.5.0-15-generic/Makefile:2037: /home/gabrielft02/rtl8852be] Erro 2
make[1]: *** [Makefile:234: __sub-make] Erro 2
make[1]: Saindo do diretório '/usr/src/linux-headers-6.5.0-15-generic'
make: *** [Makefile:637: modules] Erro 2

It looks like the driver is not compatible with the 6.5 kernel.

Let's try using DKMS

sudo apt update && sudo apt install r8168-dkms

Quando executei esse comando também deu um erro. Parece que está corrompido algum arquivo. Olha o registro:

sudo apt update && sudo apt install r8168-dkms
[sudo] senha para gabrielft02:
Atingido:1 Index of /ubuntu jammy InRelease
Obter:2 Index of /ubuntu jammy-updates InRelease [119 kB]
Atingido:3 Index of /ubuntu jammy-backports InRelease
Atingido:4 Index of /ubuntu jammy InRelease
Obter:5 Index of /ubuntu jammy-security InRelease [110 kB]
Baixados 229 kB em 2s (93,5 kB/s)
Lendo listas de pacotes... Pronto
Construindo árvore de dependências... Pronto
Lendo informação de estado... Pronto
Todos os pacotes estão atualizados
Lendo listas de pacotes... Pronto
Construindo árvore de dependências... Pronto
Lendo informação de estado... Pronto
r8168-dkms já é a versão mais recente (8.049.02-1ubuntu1.2).
O seguinte pacote foi instalado automaticamente e já não é necessário:
libwmf0.2-7-gtk
Utilize 'sudo apt autoremove' para o remover.
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
1 pacotes não totalmente instalados ou removidos.
Depois desta operação, 0 B adicionais de espaço em disco serão usados.
Você quer continuar? [S/n] s
Configurando r8168-dkms (8.049.02-1ubuntu1.2) ...
Removing old r8168-8.049.02 DKMS files...
Deleting module r8168-8.049.02 completely from the DKMS tree.
Loading new r8168-8.049.02 DKMS files...
Building for 6.5.0-15-generic
Building initial module for 6.5.0-15-generic
Error! Bad return status for module build on kernel: 6.5.0-15-generic (x86_64)
Consult /var/lib/dkms/r8168/8.049.02/build/make.log for more information.
dpkg: erro ao processar o pacote r8168-dkms (--configure):
o subprocesso instalado, do pacote r8168-dkms, o script post-installation retor
nou erro do status de saída 10
A processar 'triggers' para initramfs-tools (0.140ubuntu13.4) ...
update-initramfs: Generating /boot/initrd.img-6.5.0-15-generic
Erros foram encontrados durante o processamento de:
r8168-dkms
E: Sub-process /usr/bin/dpkg returned an error code (1)

*Tive que tirar alguns links do registro por que o fórum deixa mais que 5

Can you try 8169 instead?

sudo apt update && sudo apt install r8169-dkms
2 Likes

It is interesting to me that two different drivers are not playing nicely with 6.5 kernel...

1 Like

Eu acabei de rodar com r8169-dkms como vc disse. E no final ele diz não ter encontrado o pacote r816-dkms :pensive:.

sudo apt update && sudo apt install r8169-dkms
[sudo] senha para gabrielft02:

Baixados 2.114 kB em 2s (918 kB/s)
Lendo listas de pacotes... Pronto
Construindo árvore de dependências... Pronto
Lendo informação de estado... Pronto
Todos os pacotes estão atualizados
Lendo listas de pacotes... Pronto
Construindo árvore de dependências... Pronto
Lendo informação de estado... Pronto
E: Impossível encontrar o pacote r8169-dkms

Eu estou a quase 2 dias tentando resolver isto mas não encontro nada. você acha que talvez devesse recorrer a um kernel mais antigo para testar?
Começando a ficar sem esperanças

I would try it, since nothing else seems to be working.


Eu tentaria, uma vez que nada mais parece estar a funcionar.

sudo apt install linux-image-5.15.0-83-generic linux-headers-5.15.0-83-generic linux-modules-5.15.0-83-generic linux-modules-extra-5.15.0-83-generic

Reboot - but bap the esc key (if needed) to go to the Grub menu at boot.
Select Advanced Options for Zorin and then select Zorin on 5.15.0-83 to boot up (do not select the one with the Recovery Option).

Once you reach the desktop, open terminal and check that you are running on the 5.15.0-83 kernel


Reinicie - mas toque na tecla esc (se necessário) para ir para o menu Grub na inicialização.
Selecione Advanced Options for Zorin e então selecione Zorin on 5.15.0-83 para inicializar (não selecione aquela com a opção Recovery).

Quando chegar ao ambiente de trabalho, abra o terminal e verifique se está a correr com o kernel 5.15.0-83

uname -r

Now, try installing the driver:


Agora, tente instalar o driver:

sudo apt update && sudo apt install r8168-dkms

2 Likes

Agradeço pelo seu tempo, Aravisian.
Obrigado.

1 Like