Problema de actualizacion de paquetes

Buenos días! Acabo de actualizar Zorin OS 17 Core, pero me dice que están pendientes de actualizar estos tres paquetes, los he intentado instalar manualmente pero no se actualizan porque me dice que ya dispongo de la versión más reciente.
libgl1-mesa-dri/jammy 24.1.0~rc2+git2405011502.f3ff3d86efc~j~mesarc6 i386 [actualizable desde: 24.0.6+git2404242010.334cba5e200~j~mesarc5]
libglapi-mesa/jammy 24.1.0~rc2+git2405011502.f3ff3d86efc~j~mesarc6 i386 [actualizable desde: 24.0.6+git2404242010.334cba5e200~j~mesarc5]
libglx-mesa0/jammy 24.1.0~rc2+git2405011502.f3ff3d86efc~j~mesarc6 i386 [actualizable desde: 24.0.6+git2404242010.334cba5e200~j~mesarc5]
❯ sudo apt upgrade
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias... Hecho
Leyendo la información de estado... Hecho
Calculando la actualización... Hecho
Los siguientes paquetes se han retenido:
libgl1-mesa-dri:i386 libglapi-mesa:i386 libglx-mesa0:i386
0 actualizados, 0 nuevos se instalarán, 0 para eliminar y 3 no actualizados.


Good morning! I just updated Zorin OS 17 Core, but it tells me that these three packages are pending to be updated, I have tried to install them manually but they do not update because it tells me that I already have the latest version.
libgl1-mesa-dri/jammy 24.1.0~rc2+git2405011502.f3ff3d86efc~j~mesarc6 i386 [upgradable from: 24.0.6+git2404242010.334cba5e200~j~mesarc5]
libglapi-mesa/jammy 24.1.0~rc2+git2405011502.f3ff3d86efc~j~mesarc6 i386 [upgradable from: 24.0.6+git2404242010.334cba5e200~j~mesarc5]
libglx-mesa0/jammy 24.1.0~rc2+git2405011502.f3ff3d86efc~j~mesarc6 i386 [upgradable from: 24.0.6+git2404242010.334cba5e200~j~mesarc5]
❯ sudo apt upgrade
Reading package list... Fact
Creating a Dependency Tree... Fact
Reading the status information... Fact
Calculating the upgrade... Fact
The following packages have been retained:
libgl1-DRI-TABLE:I386 LIBGLAPI-TABLE:I386 LIBGLX-TABLE0:I386 0 updated, 0 new will be installed, 0 to delete, and 3 not updated.

@Neo1 Have you upgraded from Z16 to Z17 using the Zorin Upgrader tool?
If true, do you have any Focal repositories left over from the upgrade process?

@Neo1 ¿Has actualizado de Z16 a Z17 con la herramienta Zorin Upgrader? Si es true, ¿tiene algún repositorio focal sobrante del proceso de actualización?


No, hice una instalación limpia de Zorin OS 17, no tenía instalado previamente Zorin 16.

No, I did a clean install of Zorin OS 17, I did not have Zorin 16 installed previously.

You say this problem occurred after accepting a software update, but is ZorinOS Core running OK regardless of those reports?

I have never seen this issue myself, so do not have an immediate answer.

You may wish to refer to this thread and see if it offers any help: Using the terminal instead of the Software Updater app

Dice que este problema ocurrió después de aceptar una actualización de software, pero ¿ZorinOS Core se ejecuta correctamente independientemente de esos informes?
Nunca he visto este problema por mí mismo, así que no tengo una respuesta inmediata.
Es posible que desee consultar este hilo y ver si ofrece alguna ayuda: Usar el terminal en lugar de la aplicación Software Updater

1 Like

Si, he descargado esta mañana la actualización en Zorin con Software Updater, después ha ido a la terminal y he mirado a ver si quedaba algo por actualizar y he visto que me salían los tres paquetes mencionados y no ha sido posible la actualización de los mismos. Por lo demás Zorin parece funcionar perfectamente, si busco actualizaciones por Software Updater me dice que el sistema está actualizado, si lo hago por la terminal, me dice que está pendiente la actualización de estos tres paquetes. Esto ya me pasó en el pasado con Linux Mint y utilicé timeshift, para crear un punto de restauración anterior, pero haciendo esto, tuve problemas con el sistema y decidí aprovechar para instalar Zorin. Supongo que cuando se instalen, las próximas versiones de los paquetes, se solucionará sólo.

Yes, this morning I downloaded the update in Zorin with Software Updater, then I went to the terminal and I looked to see if there was anything left to update and I saw that the three mentioned packages appeared and it was not possible to update them . Otherwise Zorin seems to work perfectly, if I check for updates through Software Updater it tells me that the system is updated, if I do it through the terminal, it tells me that the update of these three packages is pending. This has already happened to me in the past with Linux Mint and I used timeshift to create a previous restore point, but doing this, I had problems with the system and decided to take the opportunity to install Zorin. I guess when the next versions of the packages are installed, it will fix itself.

Start Software Updater, but Stop it before it Loads. Click on Settings, go to first tab and change Software source from Custom to Main Server. Then try updating again. You will need to reload Software Updater for the changes to take effect.

I have done what you told me, but it hasn't worked, it's still the same.

OK, are the apps installed from Software or did you install them separately? In the past on a different OS I could not update Vivaldi Browser, I had to do it manually by downloading from official website. The system becomes aware of updates but can't access the source. If this is not the case you could try removing 'gnome-software' (which is what 'Software' is) and reinstalling it. @Aravisian has posted on how to do this quite a few times now.

Las descargué desde el software update, el paquete que zorin me marcaba como actualización pendiente, posteriormente desde la terminal, hice sudo apt update y vi que marcaba los tres paquetes pendientes de actualización. Echaré un vistazo a lo que me indicas, en cualquier caso, como no impide usar el sistema adecuadamente, es probable que espere un tiempo a ver si con la siguiente actualizacion de mesa se soluciona. Muchas gracias a todos por la ayuda!!

I downloaded them from the software update, the package that Zorin marked as pending update, later from the terminal, I did sudo apt update and saw that it marked the three packages pending update. I will take a look at what you tell me, in any case, since it does not prevent me from using the system properly, I will probably wait a while to see if the next table update solves it. Thank you very much everyone for the help!!


I must say the forum is awesome! Is it using DeepL in autotranslating replies?

For this particular issue, likely the user needs to use Software & Updates > Zorin Software tab to ensure that the first four options are checkmarked. Then sudo apt update && sudo apt full-upgrade

If no good, then sudo apt --fix-broken install

sudo dpkg --remove --force-remove-reinstreq libgl1-dri-table:I386 libglapi-table:I386 libglx-table0:I386

sudo apt install --reinstall libgl1-dri-table:I386 libglapi-table:I386 libglx-table0:I386


Forum is not auto-translating. For my part, I have been using a separate web translator in another browser tab. I don't know how Neo1 has done it. But we have been able to communicate Spanish/English OK.

When I clicked on a response from him it showed original Spanish then quickly refreshed to English!

1 Like

Traductor de se hace de forma automá lo sabía.....

❯ sudo dpkg --remove --force-remove-reinstreq libgl1-mesa-dri
dpkg: problemas de dependencias impiden la desinstalación de libgl1-mesa-dri:amd64:
xorg depende de libgl1-mesa-dri.
libglx-mesa0:amd64 depende de libgl1-mesa-dri.

dpkg: error al procesar el paquete libgl1-mesa-dri:amd64 (--remove):
problemas de dependencias - no se desinstala
Se encontraron errores al procesar:

  • List item

❯ sudo apt install --reinstall libgl1-dri-table:I386 libglapi-table:I386 libglx-table0:I386
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias... Hecho
Leyendo la información de estado... Hecho
E: No se ha podido localizar el paquete libgl1-dri-table:I386
E: No se ha podido localizar el paquete libglapi-table:I386
E: No se ha podido localizar el paquete libglx-table0:I386

Neither of the two commands worked...there seems to be a dependency problem with xorg.....