Problemi con driver nvidia (language: italian)

Mi trovo parecchio in difficoltà nell'utilizzo della distro in quanto sto riscontrando continuamente problemi video, questo sia su Zorin , sia su Ubuntu. Ora sto utilizzando Zorin Os 16 nella speranza che fosse un po' meglio il supporto grafico ma purtroppo non è così.
Utilizzo il mio laptop sempre con due monitor: uno integrato e l'altro esterno collegato via HDMI. Il mio pc ha due schede grafiche: una intel 630 e una nvidia gtx 1650 a cui è attaccato il monitor.
Il setup non dava alcun problema lato video, l'immagine era fluida senza scatti su entrambi i monitor (strano visto che l'esecuzione da usb di solito danno questi problemi). Una volta finita l'installazione, ecco il problema: Funziona solo il monitor principale del pc e non il monitor esterno. Provato a vedere nelle impostazioni e il monitor esterno non viene proprio rilevato, anche se stacco e riattacco il cavo hdmi e nelle informazioni del pc nella voce Grafica si vedeva solo la scheda intel. Vado su Software e aggiornamenti, driver aggiuntivi e vedo che la versione del driver nvidia è nvidia-driver-525-open (proprietario, testato). La prima cosa che ho fatto è stato quello di testare tutti gli altri driver e la situazione di è capovolta. All'avvio (boot screen) funzionano entrambi i monitor (il secondo parte in ritardo e fuori sincronia rispetto al primo) e dopo aver caricato l'interfaccia, il primo monitor diventa nero e solo quello esterno risulta utilizzabile. Guardando le impostazioni schermo vedo solo il monitor esterno e nelle info trovo la scheda nvidia e non più la intel. Questo problema l'ho riscontrato su tutti i driver Nvidia. Ho provato, a questo punto, il driver xserver.xorg-video-nouveau (open source). Entrambi i monitor si vedevano, peccato che il secondo mostravas dei fastidiosi effetti di Screen Tearing, mentre il primo monitor non aveva alcun problema.
A questo punto mi manca solo da scaricare manualmente i driver nvidia per linux, peccato che ho già provato su ubuntu questa procedura e più che errori di chiavi, secure boot e altre cose di cui non ne capivo un fico secco non vedevo, con il risultato finale che dopo il riavvio mi saltarono tutti i driver di qualsiasi periferica (quindi non solo video). Quindi, essendo una distro basata su ubuntu, non mi aspetto un risultato diverso. Al momento mi trovo costretto ad "arrendermi" utilizzando il driver xorg, senza risolvere il problema. Capisco che l'unico sistema operativo adatto a chi vuole tutto pronto è Windows (e io non pretendo questo altrimenti me ne sarei rimasto con quel sistema), ma mettere in crisi un utente che, per lo meno, prova a smanettare con tutte le guide possibili e immaginarie che si trovano su internet mi sembra esagerato.
Domanda... Qualcuno ha riscontrato e risolto questo problema? Se si come ha fatto? Grazie e perdonatemi per il papiro.

Modello PC:
HP Pavilion Gaming Laptop dk0047nl

CPU: INTEL CORE I7 9 GEN
RAM: 16 GB DDR4
GUPs: INTEL UHD 630 / NVIDIA GEFORCE FTX 1650M

Risultato del terminale al comando inxi -g:
diego@diego-HP-Pavilion-Gaming-Laptop-15-dk0xxx:~$ inxi -G
Graphics:
Device-1: Intel UHD Graphics 630 driver: i915 v: kernel
Device-2: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] driver: nvidia
v: 418.226.00
Display: x11 server: X.Org 1.20.13 driver: nvidia
resolution: 1920x1080~60Hz
OpenGL: renderer: GeForce GTX 1650/PCIe/SSE2 v: 4.6.0 NVIDIA 418.226.00
diego@diego-HP-Pavilion-Gaming-Laptop-15-dk0xxx:~$

1 Like

English translation.

I'm having a lot of trouble using the distro as I'm constantly having video problems, both on Zorin and on Ubuntu. I'm now using Zorin Os 16 in hopes that the graphics support would be a little better but sadly that's not the case.
I always use my laptop with two monitors: one built in and the other external connected via HDMI. My pc has two graphics cards: an intel 630 and an nvidia gtx 1650 to which the monitor is attached.
The setup didn't give any problems on the video side, the image was fluid without jerks on both monitors (strange since running from usb usually gives these problems). Once the installation is finished, here is the problem: Only the main monitor of the pc works and not the external monitor. Tried to see in the settings and the external monitor is not really detected, even if I detach and reattach the hdmi cable and in the pc information in the Graphics item you could only see the intel card. I go to Software and Updates, Additional Drivers and see the nvidia driver version is nvidia-driver-525-open (proprietary, tested). The first thing I did was to test all the other drivers and the tables turned. At startup (boot screen) both monitors work (the second starts late and out of sync with the first) and after loading the interface, the first monitor goes black and only the external one is usable. Looking at the screen settings, I only see the external monitor and in the info I find the nvidia card and no longer the intel. I've had this problem on all Nvidia drivers. I tried, at this point, the xserver.xorg-video-nouveau (open source) driver. Both monitors could be seen, a pity that the second showed annoying Screen Tearing effects, while the first monitor had no problems.
At this point I only need to manually download the nvidia drivers for linux, a pity that I have already tried this procedure on ubuntu and more than key errors, secure boot and other things I didn't understand a nut I didn't see, with the result final that after the restart all the drivers of any device (therefore not only video) skipped me. So, being an ubuntu-based distro, I don't expect a different result. At the moment I find myself forced to "give up" using the xorg driver, without solving the problem. I understand that the only operating system suitable for those who want everything ready is Windows (and I don't expect this otherwise I would have stayed with that system), but putting a user in crisis who, at least, tries to tinker with all the guides possible and imaginary that are on the internet seems to me exaggerated.
Question... Has anyone encountered and solved this problem? If yes, how did he do it? Thank you and forgive me for the papyrus.

PC Model:
HP Pavilion Gaming Laptop dk0047nl

CPU: INTEL CORE I7 9th GEN
RAM: 16GB DDR4
GUPs: INTEL UHD 630 / NVIDIA GEFORCE FTX 1650M

Terminal output to inxi -g command:
diego@diego-HP-Pavilion-Gaming-Laptop-15-dk0xxx:~$ inxi -G
Graphics:
Device-1: Intel UHD Graphics 630 driver: i915 v: kernel
Device-2: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] driver: nvidia
see: 418.226.00
Display: x11 Server: X.Org 1.20.13 Driver: nvidia
resolution: 1920x1080~60Hz
OpenGL: renderer: GeForce GTX 1650/PCIe/SSE2 v: 4.6.0 NVIDIA 418.226.00
diego@diego-HP-Pavilion-Gaming-Laptop-15-dk0xxx:~$

1 Like

Ah, beh, è vero che noi dovremmo sforzarci di leggere le guide e i consigli per far funzionare le cose come dovrebbero ma a volte sembra che qualunque cosa tu faccia, anche esattamente identica passo per passo, non vada mai bene e quindi hai voglia di spaccare tutto :computer::hammer::face_with_symbols_over_mouth:.
Computer Pc GIF
È vero che in Windows "è tutto pronto" ma sembra quasi normale avere qualche problema una volta passati a Ubuntu (o comunque uscire da Windows) perché non ci hai ancora fatto l'abitudine. Anch'io ci sto ancora provando a fare certe cose, poi però non è che posso mettermi a cercare ogni singola cosa che non capisco o non so fare, la cosa diventerebbe infinita. Ma tanto per abbreviare, sembra che i tuoi problemi (per adesso :neutral_face:) siano limitati a visualizzare correttamente gli schermi esterni collegati, giusto? Ho letto tutto il tuo messaggio e mi sono perso :face_with_spiral_eyes:. Se puoi, non che a me dispiaccia, dovresti scrivere in inglese sennò gli altri dovranno sempre passare al traduttore :open_book::face_with_monocle:.


Ah, well, it's true that we should strive to read the guides and tips to make things work as they should but sometimes it seems that whatever you do, even exactly the same step by step, never goes well and so you feel like smashing everything :computer::hammer::face_with_symbols_over_mouth:.
Computer Pc GIF
It's true that in Windows "everything is ready" but it seems almost normal to have some problems once you switch to Ubuntu (or otherwise get out of Windows) because you haven't gotten used to it yet. I'm still trying to do certain things too, but then it's not like I can go after every single thing I don't understand or don't know how to do, it would become endless. But just to abbreviate, it seems that your problems (for now :neutral_face:) are limited to displaying the external connected screens correctly, right? I read your whole message and got lost :face_with_spiral_eyes:. If you can, not that I mind, you should write in English or else others will always have to go to the translator :open_book::face_with_monocle:.

Dai almeno non sono cattivo come la signora nella gift :rofl:, povero Mac...
Comuqne il problema per il momento riguarda la parte video. Quando collego il monitor esterno succede un putiferio. Ora sto usando il driver xorg che mi permette di vedere l'immagine su entrambi i monitor, ma il secondo purtroppo mostra un effetto tearing quando l'immagine si muove e questo mi fa impazzire quando guardo video e film, oltre al fatto che l'immagine è sempre scattosa, il che mi fa innervosire ancora di più.. I driver nvidia purtroppo non fanno funzionare entrambi i monitor ma solo quello esterno, tranne il 525 che non funziona proprio e quindi funziona solo la scheda intel e il monitor integrato.

Well come on at least I'm not as mean as the lady in the gift :rofl:, poor Mac...
However the problem for the moment concerns the video. When I connect the external monitor there is a ruckus. Now I'm using the xorg driver which allows me to see the image on both monitors, but the second one unfortunately shows a tearing effect when the image moves and this freaks me out when I watch videos and movies, besides the fact that the picture isn't smooth at all, which makes me more nervous. The nvidia drivers unfortunately don't make both monitors work but only the external one, except for the 525 driver which doesn't work at all and therefore only the intel card works and therefore only the integrated monitor stays on.

Sorry for my bad english and I hope I didn't write like a goat :rofl:

1 Like

Hai creato un nuovo messaggio invece di modificare quello originale :thinking:? O vedo doppio :thinking::thinking:?

Anch'io ho un problema video, ho guardato un film in CD e in alcuni momenti apparivano alcune sezioni triangolari che si sovrapponevano l'una con l'altra. Io per vedere se riesco a risolvere attiverò l'opzione Scala frazionaria in Impostazioni > Schermi, se non cambia passerò a Zorin Desktop in Wayland che si trova nell'icona dell'ingranaggio in basso a destra nella schermata di accesso o applicherò anche entrambe le cose insieme, oltre a questo non saprei dove mettere le mani, non sono esperto in audio e video fino al punto di risolvere problemi così tecnici. Nel mio caso potrebbe benissimo essere un problema di codifica, dei codec video, quelle cose che non capisco a pieno. Nel tuo caso potrebbe essere una configurazione sbagliata dello schermo esterno stesso, io per esempio ho dovuto regolare certe impostazioni della mia televisione collegata al portatile con cavo VGA perché i colori erano un po' sballati. Addirittura adesso in realtà i colori vengono alterati parecchio, non so cosa gli succede, più passa il tempo mentre sono collegato e più cambiano tonalità da soli. Potresti provare a usare uno strumento per test di monitor.


Did you create a new message instead of editing the original one :thinking:? Or am I seeing double :thinking::thinking:?

I too have a video problem, I was watching a CD movie and at certain times some triangular sections appeared overlapping each other. I to see if I can fix it I will activate the Fractional Scale option in Settings > Screens, if it doesn't change I will switch to Zorin Desktop in Wayland which is in the gear icon in the bottom right corner of the login screen or I will also apply both together, other than that I wouldn't know where to put my hands, I am not an expert in audio and video to the point of solving such technical problems. In my case it could very well be an encoding problem, of the video codecs, those things I don't fully understand. In your case it could be a misconfiguration of the external screen itself, I for one had to adjust certain settings on my television connected to the laptop with a VGA cable because the colors were a little off. Even now actually the colors are altered quite a bit, I don't know what happens to them, the more time passes while I'm connected the more they change hues on their own. You might try using a monitor test tool.

Si ho fatto mezzo casino, avevo modificato un messaggio e poi ho visto che era sparito, pensavo di averlo cancellato :rofl:
Comunque ho fatto il test e il difetto che ho notato (oltre al fatto che a random mi scalava a 30 fps) è il seguente:

Yeah I screwed up, I edited a post and then I saw it was gone, I thought I deleted it :rofl:
Anyway I did the test and the flaw I noticed (besides the fact that it randomly scaled the frames to 30 fps) is the following:

1 Like

Nella schermata di login ho notato in basso a destrra che c'è la modalità Wayland. Avviandolo in quel modo il problema è "quasi" svanito (quasi perchè ho fatto ancora il test che hai messo e qualche scatto qua e là lo fa, però molto meno rispetto a prima), oltre ad un incremento notevole delle prestazioni generali del computer. Il problema comunque non sembra proprio essersi risolto in quanto qualche scatto l'ho notato dal test, confrontato con il monitor principale per vedere se era il sito e invece c'era una leggera differenza tra i due monitor... Qualche idea?

I noticed in the login screen there is Wayland mode. Starting it the problem has "almost" disappeared (almost, because I did the test you put in the comment and there are a few lags, but much less than before), as well as a significant improvement of the general performance of the computer. However, the problem doesn't seem to have been solved, I noticed a few lags from the test, compared with the integrated monitor to see if it was the site and instead there was a slight difference between the monitors... Any idea?

1 Like

Forse è stato rilevato il testo in italiano e quindi il messaggio era in attesa dell'approvazione di un moderatore, infatti anch'io se pubblico risposte qui in italiano i miei messaggi sono visibili a me ma non pubblici fino all'approvazione. Niente di grave, però allunga i tempi di risposta.

Il problema video che vedo nella tua foto è praticamente lo stesso che ho visto quando ho guardato un film da un CD, sovrapposizioni tra diverse parti dello schermo in alcune scene, formando una specie di frammentazione, o meglio, in questo caso, una specie di taglio. In più, l'ho visto anche in certi giochi ma nei giochi di solito si risolve facilmente disattivando il filtraggio delle texture o altre opzioni e è fatta, non saprei per quando succede ovunque o altri problemi simili, non sono così esperto :expressionless:.

Almeno questo, io ho attivato Zorin Desktop in Wayland ma non ho visto cambiamenti, almeno niente di evidente ma lo devo provare anch'io per vedere se risolvo quel problema del film. Ti sei ricordato di attivare Scala frazionaria dopo l'accesso con Zorin Desktop in Wayland? Magari insieme riescono a risolvere.

Adesso che ci penso, potresti anche controllare se in Driver aggiuntivi appaiono aggiornamenti per i tuoi driver Nvidia. Nel mio caso no perché ho AMD ma forse tu vedi qualcosa.



Perhaps the text in Italian was detected and so the message was awaiting approval by a moderator, in fact even I if I post replies here in Italian my messages are visible to me but not public until approved. No big deal, it does lengthen the response time though.

The video problem I see in your picture is pretty much the same one I saw when I watched a movie from a CD, overlaps between different parts of the screen in some scenes, forming a kind of fragmentation, or rather, in this case, a kind of cut. Plus, I've also seen it in certain games but in games it's usually easily solved by turning off texture filtering or other options and it's done, I wouldn't know for when it happens everywhere or other similar problems, I'm not that experienced :expressionless:.

At least this, I activated Zorin Desktop in Wayland but I didn't see any change, at least nothing noticeable but I have to try it too to see if I solve that movie problem. Did you remember to activate Fractional Scale after logging in with Zorin Desktop in Wayland? Maybe together they can solve it.

Now that I think about it, you might also check if updates for your Nvidia drivers appear in Additional Drivers. In my case no because I have AMD but maybe you see something.


Probabilmente potresti risolvere applicando sudo apt install zorin-os-restricted-extras nel terminale, me l'ha suggerito seanhinkley e infatti quando poi ho controllato ancora lo stesso film il problema era sparito quindi per me :+1:. Grazie seanhinkley :sunglasses:.


You could probably solve it by applying sudo apt install zorin-os-restricted-extras in the terminal, seanhinkley suggested it to me and in fact when I later checked the same movie again the problem was gone so for me :+1:. Thank you seanhinkley :sunglasses:.

Ciao grazie per la risposta. Il problema video l'ho risolto avviando il sistema con Wayland e settando il driver su xorg.

Hi, thank you for the answare. I solved this problem starting my pc in wayland mode and using xorg drivers.

1 Like

I marked the last post above by Rescalli as "Solution"

1 Like