Problems Connecting to wi-fi


Newbie here.

I'm having trouble connecting my Lenovo T400 to wi-fi. I'm running Zorin 15.3 32 bit. Really love it! If there's some way of connecting to wi-fi through settings or terminal, or if anyone could recommend a good external wireless adapter, I'd really appreciate it.

Here are some details:

user@user-ThinkPad-T400:~$ inxi -n
Network: Card-1: Intel 82567LM Gigabit Network Connection driver: e1000e
IF: enp0s25 state: up speed: 1000 Mbps duplex: full
mac: 00:1c:25:a1:9e:5d
Card-2: Intel PRO/Wireless 5100 AGN [Shiloh] Network Connection
driver: iwlwifi
IF: wlp3s0 state: down mac: 00:22:fa:7c:3f:8c


sudo ip link set wlp3s0 up

If that doesn’t work, try:

I tried the sudo command and got the following response:
RTNETLINK answers: Operation not possible due to RF-kill

I think the Linux Mint forum solution is a little beyond me at this point. When I tried it, I got a warning and a page of text I didn't understand. One day, I'll be able to understand more of it but for now, I think I'll go the route of a wireless extender with and ethernet port.

Thanks so much for your help! I really appreciate it.

Would you mind trying this? intel wireless - "SIOCSIFFLAGS: Operation not possible due to RF-kill"? - Ask Ubuntu

If you get a warning or a page of text; you can post a screenshot of it for further assistance.

Thanks, I will do so in the future. I'm just getting used to terminal and want to make sure I understand the basics a bit more before messing around in there.


I don't think I know enough to follow those directions. I'm not sure of where to place breaks or how to tell if the commands are wraparound or not, or whether a block of commands should be issued in a chain or all at one go.

I need to learn a few more basics and will work with an external solution in the meantime. I'll bookmark the above passage and see if I can make more sense of it in a few months.

Thanks again!

Often, you can copy and paste (right click or... In terminal, the keyboard shortcuts ctrl+v and ctrl+c are replaced with ctrl+shift+v and ctrl+shift+c) and avoid spacing concerns.
Terminal commands do wrap around.
If you see a block of commands, then enter each line one at a time.

If a USB Wifi Adapter works, that is a perfectly viable solution, too.

Awesome, thanks!

I found out the solution...the wireless was hard blocked, not soft blocked. All I had to do was turn on the wi-fi toggle switch on the front of my computer!

Problem solved!


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.