Problems installing WINE

Hi, All. I know this has been posted about before, but I've scoured many of the previous posts on this subject, and none of the solutions seem to work for me.

I've tried both installing WINE as outlined on and installing the Zorin Windows App Installer, but neither work. I am always met with a message saying I have unmet dependencies. I keep trying to back track and install those dependencies, but it still doesn't work. I think one of the problems is that sudo apt install libc6 says that I have libc6 version 2.31 installed, and it doesn't see an updated version to install, and WINE keeps asking for libc6 version >=2.34.

Any help you can provide would be greatly appreciated.

I am single booting Zorin 16 Core natively/locally.

Here is the output from inxi -Faz:

  Kernel: 5.13.0-27-generic x86_64 bits: 64 compiler: N/A 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.13.0-27-generic 
  root=UUID=aa1a6b0b-f887-4d25-8ec9-2447635b4855 ro quiet splash 
  Desktop: Gnome 3.38.4 wm: gnome-shell dm: GDM3 
  Distro: Zorin OS 16 base: Ubuntu 20.04 LTS Focal 
  Type: Laptop System: Microsoft product: Surface Laptop 3 
  v: 124I:00036T:000M:0300000D:0B:07F:1C:05P:48S:01E:0Y:0K:0U:02 
  serial: <filter> Chassis: type: 9 serial: <filter> 
  Mobo: Microsoft model: Surface Laptop 3 serial: <filter> UEFI: Microsoft 
  v: 9.106.140 date: 04/30/2021 
  ID-1: BAT1 charge: 40.1 Wh condition: 40.1/45.8 Wh (88%) volts: 8.5/7.6 
  model: SMP M1087273 type: Li-ion serial: <filter> status: Full cycles: 341 
  Topology: Quad Core model: Intel Core i5-1035G7 bits: 64 type: MT MCP 
  arch: Ice Lake family: 6 model-id: 7E (126) stepping: 5 microcode: A6 
  L2 cache: 6144 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 23961 
  Speed: 1232 MHz min/max: 400/3700 MHz Core speeds (MHz): 1: 1214 2: 1300 
  3: 1300 4: 1170 5: 1206 6: 1265 7: 1281 8: 1225 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel Iris Plus Graphics G7 vendor: Microsoft driver: i915 
  v: kernel bus ID: 00:02.0 chip ID: 8086:8a52 
  Display: x11 server: X.Org 1.20.13 driver: i915 compositor: gnome-shell 
  resolution: 2256x1504~60Hz 
  OpenGL: renderer: Mesa Intel Iris Plus Graphics (ICL GT2) 
  v: 4.6 Mesa 21.3.4 - kisak-mesa PPA direct render: Yes 
  Device-1: Intel Smart Sound Audio driver: snd_hda_intel v: kernel 
  bus ID: 00:1f.3 chip ID: 8086:34c8 
  Sound Server: ALSA v: k5.13.0-27-generic 
  Device-1: Intel Killer Wi-Fi 6 AX1650i 160MHz Wireless Network Adapter 
  driver: iwlwifi v: kernel port: 3000 bus ID: 00:14.3 chip ID: 8086:34f0 
  IF: wlp0s20f3 state: up mac: <filter> 
  Local Storage: total: 119.24 GiB used: 34.21 GiB (28.7%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 vendor: SK Hynix model: HFM128GDGTNG-87A0A 
  size: 119.24 GiB block size: physical: 512 B logical: 512 B 
  speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 80041C00 scheme: GPT 
  ID-1: / raw size: 118.74 GiB size: 116.38 GiB (98.01%) 
  used: 34.21 GiB (29.4%) fs: ext4 dev: /dev/nvme0n1p2 
  System Temperatures: cpu: 40.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 317 Uptime: 7h 02m Memory: 7.36 GiB used: 3.15 GiB (42.8%) 
  Init: systemd v: 245 runlevel: 5 Compilers: gcc: 9.3.0 alt: 9 Shell: bash 
  v: 5.0.17 running in: gnome-terminal inxi: 3.0.38

Please bear in mind that you cannot install Libc6 2.34
Doing so will break the system.

That being said... I can confirm that Zorin-windows-app-support Does Not Depend on libc6 2.34
What method of Wine Installation are you using?

1 Like

I'm not sure I understand your question, so bare with me if I don't answer it correctly...

I was following the steps from Ubuntu - WineHQ Wiki, and I've tried the repo for each version of Ubuntu listed. I've then tried to install the stable branch after each.

Here is the output it gives me:

The following packages have unmet dependencies:
 winehq-stable : Depends: wine-stable (=
E: Unable to correct problems, you have held broken packages.

Then, if I sudo apt install wine-stable, I get the following, hence why I mentioned libc6 2.31 vs 2.34:

The following packages have unmet dependencies:
 wine-stable : Depends: libc6 (>= 2.34) but 2.31-0ubuntu9.2 is to be installed
               Depends: wine-stable-i386 (=
               Depends: wine-stable-amd64 (= but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I'm not sure if this is relevent, but when I try to sudo apt install zorin-windows-app-support, I get this output:

The following packages have unmet dependencies:
 zorin-windows-app-support : Depends: wine or
                                      winehq-stable but it is not going to be installed
                             Depends: playonlinux but it is not going to be installed
                             Depends: wine32:i386
E: Unable to correct problems, you have held broken packages.

It looks like you installed the Wrong Repository.
You need to remove it, then add the correct one.

sudo add-apt-repository --remove 'deb impish main'
sudo add-apt-repository 'deb focal main'

sudo apt --fix-broken install

sudo apt update && sudo apt install --install-recommends winehq-stable

Sidenote: Attempting to install zorin-windows-app-support after installing the Wine Repository will only confuse things, as the Zorin-windows-app-support package is in the Zorin repository. If using it, do not add any Wine Repository. If you prefer the later version of Wine offered, then use the Wine repository and install wine --recommends, not zorin-windows-app-support.


Hey! Thanks so much!

I also had to remove hirsute after impish, but then adding focal, fixing, and installing worked great!

I see what you are saying now about the Windows App Repository. When I first went searching trying to figure out how to install my software, the internet suggested I use Lutris, and Lutris told me I needed to install WINE. I didn't realize until days into trying this that Zorin OS has the Windows App Repository and allows me to directly install .exe files.

Anyway, I got it installed via the WAR after fixing my WINE installation, so thanks again!

1 Like

There are other users on here that will have good working knowledge of Wine and other compatibility layers, like Lutris, POL (Play On Linux) and Proton.
Learning is fine, but learning with guidance and help is great.
Feel free to confirm things using the forum as a resource prior to moving forward with attempts, if that makes the journey a bit smoother.

Also please remember in future that Zorin OS uses the Focal repository for any application. If you see an error of "The repository does not have a Focal Release file" then remove the repository as it is outdated.
If you see a list of options for which repo to use, always choose the Focal repo.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.