Problems upgrading from Zorin 16.3 to 17 Pro

Hi everyone,

I just purchased a license for Zorin 17 Pro and tried upgrading my existing 16.3 OS via the 'Upgrade Zorin OS' service, however I keep getting failure messages and I don't know how to interpret them. Zorin support has not helped at all. I'm hoping someone here might be able to tell me what's going wrong. In particular, I see a recurring phrase that something is configured multiple times but I don't know how to fix this. Thanks for any help anyone has!

Here's the error message below:

[CHECKING] Started
[CHECKING:Validating Upgrade Attempt] Started
[CHECKING:Validating Upgrade Attempt] Completed
[CHECKING:Checking Filesystem] Started
[CHECKING:Checking Filesystem] Completed
[CHECKING:Creating Necessary Files] Started
[CHECKING:Creating Necessary Files] Completed
[CHECKING:Adding GPG Keys] Started
[CHECKING:Adding GPG Keys] Completed
[CHECKING:Restarting Apt] Started
[CHECKING:Restarting Apt] Completed
[CHECKING:Simulating Flatpak Transaction] Started
[CHECKING:Simulating Flatpak Transaction] Completed
[CHECKING:Processing Apt Repos] Started
[CHECKING:Processing Apt Repos] Completed
[CHECKING:Updating Apt Repos] Started
[CHECKING:Updating Apt Repos] Retrying
[CHECKING:Updating Apt Repos] Retrying
[CHECKING:Updating Apt Repos] Retrying
[CHECKING:Updating Apt Repos] Retrying
[CHECKING:Updating Apt Repos] Retrying
[CHECKING:Updating Apt Repos] Retrying
[CHECKING:Updating Apt Repos] Retrying
[CHECKING:Updating Apt Repos] Retrying
[CHECKING:Updating Apt Repos] Retrying
[CHECKING:Updating Apt Repos] Retrying
[CHECKING:Updating Apt Repos] Fatal Error: { error-repo-download-failed: E:The repository 'Ubuntu Packages For R - Brief Instructions focal-cran-40/ Release' does not have a Release file., W:Updating from such a repository can't be done securely, and is therefore disabled by default., W:See apt-secure(8) manpage for repository creation and user configuration details., W:Skipping acquire of configured file 'main/binary-i386/Packages' as repository 'https://brave-browser-apt-release.s3.brave.com stable InRelease' doesn't support architecture 'i386', W:Target Packages (main/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list.d/zorin-upgrader-simulate.list:1 and /etc/apt/sources.list.d/zorin.list:13, W:Target Packages (main/binary-i386/Packages) is configured multiple times in /etc/apt/sources.list.d/zorin-upgrader-simulate.list:1 and /etc/apt/sources.list.d/zorin.list:13, W:Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list.d/zorin-upgrader-simulate.list:1 and /etc/apt/sources.list.d/zorin.list:13, W:Target Translations (main/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list.d/zorin-upgrader-simulate.list:1 and /etc/apt/sources.list.d/zorin.list:13, W:Target DEP-11 (main/dep11/Components-amd64.yml) is configured multiple times in /etc/apt/sources.list.d/zorin-upgrader-simulate.list:1 and /etc/apt/sources.list.d/zorin.list:13, W:Target DEP-11 (main/dep11/Components-all.yml) is configured multiple times in /etc/apt/sources.list.d/zorin-upgrader-simulate.list:1 and /etc/apt/sources.list.d/zorin.list:13, W:Target DEP-11-icons-small (main/dep11/icons-48x48.tar) is configured multiple times in /etc/apt/sources.list.d/zorin-upgrader-simulate.list:1 and /etc/apt/sources.list.d/zorin.list:13, W:Target DEP-11-icons (main/dep11/icons-64x64.tar) is configured multiple times in /etc/apt/sources.list.d/zorin-upgrader-simulate.list:1 and /etc/apt/sources.list.d/zorin.list:13, W:Target DEP-11-icons-hidpi (main/dep11/icons-64x64@2.tar) is configured multiple times in /etc/apt/sources.list.d/zorin-upgrader-simulate.list:1 and /etc/apt/sources.list.d/zorin.list:13, W:Target CNF (main/cnf/Commands-amd64) is configured multiple times in /etc/apt/sources.list.d/zorin-upgrader-simulate.list:1 and /etc/apt/sources.list.d/zorin.list:13, W:Target CNF (main/cnf/Commands-all) is configured multiple times in /etc/apt/sources.list.d/zorin-upgrader-simulate.list:1 and /etc/apt/sources.list.d/zorin.list:13 }
[CHECKING:Updating Apt Repos] Failed
[CHECKING] Failed
[CHECKING:Restoring System] Started
[CHECKING:Restoring System] Error: { error-repo-download-failed: E:The repository 'Ubuntu Packages For R - Brief Instructions focal-cran-40/ Release' does not have a Release file. }
[CHECKING:Restoring System] Completed

Welcome to the Forum!

It seems that there are 2 Repo's that make Problems. The Brave One and this R One. You could try to delete them for now and add them again later after the Upgrade.

1 Like