Problems when choosing Nvidia option on install

I’m trying to install Zorin OS to my PC onto a separate SSD. But I’m experiencing issues when trying to install.

I have a RTX 3070 as the GPU, so I’m trying to install using the Nvidia option. However, when selecting it, I’m only seeing my motherboard logo and nothing happens.

I tried doing the ”safe graphics” option and that seems to work.

1 Like

Which nvidia driver are you using? 525 or 535? 525 is the default on Zorin OS

Sorry, I'm a bit confused. But am I supposed to select which driver to use in some way? I've only downloaded the ISO and formatted a USB drive that I'm now booting the installer from, so I haven't done anything other than that. But I might be completely misunderstanding your question.

It's not clear - did you install Zorin OS and then after that get a black screen? Or do you get a black screen running the Live USB?

I get the black screen selecting the option "Try or Install Zorin OS (modern NVIDIA drivers)" from the initial menu when booting from the USB. I then instead tried the option "Try or Install Zorin OS (safe graphics)" and that worked. Although when I now try to boot the installed OS from the SSD I installed it to, I get the same problem again with the black screen.

You can use the nomodeset grub parameter.

sudo nano /etc/default/grub

Change the line: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
To exactly:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

tap ctrl+o to overwrite, then the enter key to save current configuration. Tap ctrl+x to exit the editor.
Now you must run

sudo update-grub

for the changes to take effect.
Reboot and test...

1 Like

The reason is that your card is so new. So with the commands @Aravisian showed you can get you into Graphic interface - Then you can install the latest nvidia driver.

1 Like

@Aravisian Thank you! I was able to get into recovery mode and made the changes from there. And I can now boot into Zorin without the black screen.

@Storm I see! What is the recommended way of installing the latest drivers?

Do you prefer gui or command?

If gui there's a an app in Zorin OS called - Software & Updates. In the Addtional Driver tab, you'll find the driver(s).

Or you can by commandline

sudo apt update && sudo apt upgrade
sudo apt install nvidia-driver-535

The first line will update your system - important!
the next line install nvidia driver 535

When trying the GUI method, all checkboxes are greyed out/disabled. Is that normal?

Nope, it should look like:

Try command way I wrote earlier, if you get a black screen, hit [alt]+[ctrl]+[F5] and purge the driver

sudo apt remove --purge *nvidia*
sudo reboot

Alright. In my case, it says "NVIDIA Corporation: Unknown" in the top, followed by: "This device is using a manually-installed driver". I remember seeing some message during the installation about detecting devices, could it be that the installer tried installing something based on what devices that were discovered during that?

The only option that is active is "Continue using a manually installed driver".

It also says "No proprietary drivers are in use" at the bottom.

I'll try the solution you suggested above in the terminal.

@Storm I didn't get any black screen and now when I look in the Software & Updates app, it says that I'm using "NVIDIA driver metapackage from nvidia-driver-535 (proprietary)".

So I guess that fixed it? It still says "NVIDIA Corporation: Unknown" at the top, but is that because it's too new for Zorin to recognise?

Should I remove the nomodeset grub parameter now?

Aye. You'll find Nvidia settings. See if all the functions are there.

Sorry, where would I find those settings?

Under System Tools in Zorins app menu

I only have "NVIDIA X Server Settings" and opening that doesn't show much I'm afraid. Just an empty box.

TRy reboot and check it again

If Nvidia Settings is still empty, I'll need some more info-

sudo apt install inxi
inxi -G

@Storm I'll try your suggestion, just wanted to provide some info that I found following the official guide for activating Nvidia here on I had a look under Settings > About and under Graphics it says "llvmpipe (LLVM 12.0.0, 256 bits)".

Also, during boot I noticed an error that says:

[drm:nv_drm_load [nvidia_drm]] ERROR [nvidia-drm] [GPU ID 0x00000100] Failed to allocate NvKmsKapiDevice
[drm:nv_drm_probe_devices [nvidia_drm]] ERROR [nvidia-drm] [GPU ID 0x00000100] Failed to register device