Problems with airplane mode

Hello everyone, I am having a detail that I just noticed recently, I am currently using Zorin OS Core 16.3 on an HP Pavilion g4 1215dx, the keyboard of this laptop, as in many manufacturers, has keys with some functions, the vast majority They work without problems but there are 3 that don't work, of which only 1 interests me, which is the airplane mode. Basically, pressing the key activates airplane mode but the LED lighting does not change from white (total functions activated) to red (airplane mode activated) and I cannot deactivate airplane mode again unless I access the system configuration

Have you run any firmware updates?

Which kernel are you on?

uname -r

1 Like

ACPI (the service that handles funtion key combinations and their actions, if one is available) is updated per kernel. Your hardware may require a newer kernel in order to have and support the function key action of "airplane mode".

Aravisian's request is valid for this reason, and can give us the opportunity to either help you upgrade your kernel (hardware connectivity and support), or help you find the scripts necessary in order to restore this functionality.

It my be as simple as adding a toggle option in the script, but we need information to recommend a direction.

I suppose that by firmware you mean BIOS, I have never done a BIOS update but it has the latest BIOS update, what I think is that years ago when I had 0 knowledge about hardware and software I sent this laptop to be formatted with Windows 7 and I think they updated the BIOS there.

I have also executed the command through the terminal and it gave me what can be seen in the image

I add as a last comment that I have tried USB Live with Linux Mint and the button works correctly there, I tried the same with a Zorin Live to confirm if it was a problem with my installation or not, exactly the same thing happens on the USB as on the system installed

Now that I think about it, I could try to take Ubuntu with its Live, it just occurred to me since I know that Zorin has the Ubuntu kernel and for this reason it takes many functions of this OS

Captura de pantalla de 2023-12-13 01-46-39

You must likely need the 6.2 kernel, which is in Zorin 17. The other distros you mention are most likely running that version kernel, which is why it works with them.

You can install the 6.2 kernel in Zorin 16.3, without much issue (I would test other hardware first to be sure, like wifi, graphics cards and the like). After verifying this, you can use the tutorial in the tutorial and guides category to update your kernel.

Well, I tested Zorin OS 17 via USB Live and the button works correctly. Regarding the proposal of updating the system kernel, I would prefer not to try to update it manually because I can leave the kernel corrupted, so I am going to wait for version 17 to come stable. Help is appreciated. I'm going to close the discussion.

My recommendation was to apply this to 16.3 while you wait for 17s release. I had also mentioned testing 17, to see if that kernel works for you. If not, you would need a newer version of the kernel.

As it does work, when 17 is officially released, at least you know the functionality works. Until then, installing the newer kernel isn't difficult in 16.3.

I'm glad you know that Zorin 17 will support your hardware and resolve the issue. Let us know if you need assistance in the kernel upgrade in Zorin 16.

Do not worry, there is little risk of this.
On Zorin OS 16, you can run

sudo add-apt-repository ppa:tuxinvader/lts-mainline

sudo apt update && sudo apt install linux-generic-6.03

Reboot and test.

If it gives any trouble, you can boot into Advanced Options for Zorin and select the previous working kernel to boot from.
Then in terminal run

sudo apt remove --purge linux-generic-6.03

1 Like

I have carried out the steps as you have explained to me and after a somewhat slow reboot I have the updated kernel, currently the system seems stable and the button works without problems. Thank you very much everyone for the help

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.