Problems with mouse in Linux

Title says "Linux" because I have experienced this problem in other distros as well.

Left click on my mouse stops working after I wake up the PC from sleep. Strangely enough, this only happens if I manually suspend the computer.

Also, especially when gaming, the cursor starts moving and clicking randomly. It only lasts for a short period of time but occurs frequently.

I am not a technical expert or anything, but I suspect this has something to do with Linux or my PC hardware. I feel like it's highly unlikely that it has something to do with my mouse as I just bought a new one recently.

I have asked this in another forum and so far have gotten no replies, any suggestions here would be welcome.

What sort of mouse is it i.e. USB, Bluetooth etc. Also make/model would help.

Have you visited Zorin/Settings/Mouse and Trackpad and tested the mouse there?

It is a Logitech M171 wireless mouse.

Disabling the touchpad in the Mouse and Touchpad settings seems to have fixed the issue for now. Maybe something is wrong with my touchpad.
But I won’t be jumping to any conclusions as I did the same thing in another distro and the issue returned after a while.

Have you tried moving the mouse receiver to a different USB port?

Just did a websearch using "Logitech M171 Ubuntu 20.04" found this:

I have tried and it did not fix the issue.

Have you tried to see if 'solaar' works?: