Problems with Nvidia drivers, locked out at lock screen

Hello, Zorin forum! This is my very first post, and I really hope someone will be able to help me out with my problem.

I booted my PC up to Zorin OS about a week ago, only to be greeted with a lock screen with no bar to type in my password (pictured below.) Nothing would happen no matter what I did (except for opening the Terminal.)

After a lot of trial and error, I purged my Nvidia driver in the Terminal and rebooted. After that, I was able to access Zorin again, but now my screen resolution is locked at 1024x768.

No matter which graphics driver I use, I always either get stuck with low resolution or get the lock screen bug again. I like using Zorin/Linux for Blender, so I really hope there’s a way to correct this.

My specs:

OS - Zorin 17
CPU - Intel Core i9-10900F CPU 2.80GHz
GPU - NVIDIA GeForce RTX 3050
RAM - 16 GB

Using terminal, please run

sudo apt remove --purge '^nvidia-.*'

sudo apt install nvidia-driver-545

You may want

sudo apt install nvidia-dkms-545

I recommend the Xswat teams updates for mesa, etc:

sudo add-apt-repository ppa:ubuntu-x-swat/updates

sudo apt update && sudo apt full-upgrade

I tried out both of the Nvidia drivers you recommended. Unfortunately, both give me the same impassable lock screen error from before.

Is the monitor cable plugged into the Nvidia GPU port or the motherboard GPU port?

It may actually be the i9 Intel graphics where the issue is, instead of Nvidia.
Have you tried Prime-Select?

The monitor is plugged into my graphics card. Something I forgot to mention earlier is that I’m using a DisplayPort cable, but I can try switching to an HDMI.

Can you explain how to do a Prime-Select? I can definitely try after work.

I also have an RTX 3060 both monitors connected using DP cables.
I am on the 550 driver with Linux Kernel 6.6.5

No problems. But... I was on the same card with the 5.15 kernels and as low as the 470 driver with no problems then, either. The 525 and 535 drivers both dropped the processing onto my CPU instead of the GPU, so they both caused overheating issues.

You can use one of the below options in terminal. Once set, it remains that way until you change it.
Nvidia only:

sudo prime-select nvidia

Intel only:

sudo prime-select intel

Or usage based on need:

sudo prime-select on-demand

Strangely, when I try to do the ”prime-select nvidia” command, I get an error saying ”no integrated GPU detected.”

It's odd for a few reasons. I'm not trying to use integrated graphics; I'm pretty sure my processor can’t even do that sort of thing. My monitor is definitely plugged into the graphics card, not the motherboard. I have the previously suggested Nvidia driver installed. Also, my graphics card looks like it's operating like normal. The MSI logo lights up and the fans run when the computer is powered.

I believe that the i9 includes the Intel Arc graphics.

Even though you are using Nvidia dedicated graphics, the integrated Intel graphics are still necessary.

Please try upgrading your kernel with Secure Boot disabled in your BIOS Settings:

sudo add-apt-repository ppa:tuxinvader/jammy-mainline

sudo apt update && sudo apt install linux-generic-6.06

Just upgraded the kernel after I double-checked to make sure that Secure Boot is off. Still getting the same ”no integrated GPU detected” error.

Well, let's move back to the resolution issue since chasing prime may be a wild goose chase.
What is your terminal output for

nvidia-smi

Interestingly, I notice that the output appears to say my graphics card is off, even though it certainly looks like it's getting power and fully functional.

Sorry for the delay, I needed to step away for other work.
The output shows the card as on - detected but not in heavy active use.

The model number ends in F which suggests that your CPU lacks integrated Intel Graphics as you stated before.

So... it's gotta be usin' somthin'...

It's definitely a tricky case. I tried switching over to the Windows partition of my SSD, and not only did it detect the GPU just fine, I was able to run a 3DMark graphics test without any issues. I think that would rule out the graphics card being the problem.

Interestingly, when I purge the Nvidia drivers and switch to the default Nouveau display driver, the GPU outputs a functional display (and I can make it past the lock screen.) Honestly would not have an issue with Nouveau if I could choose a resolution higher than 1024x768.

Nvidia 3050 seems to be a pretty different build from the 3060.

Exciting news: I somehow managed to fix it! :tada::tada: The solution turned out to be insanely easy too. I powered off my PC, removed the GPU for a few seconds, and then put it back and rebooted. Literally just “unplug and plug in again.” In hindsight, the problems may have come about because I hadn’t used my computer in a couple of weeks.

Interestingly, when I check the card with nvidia-smi, it still shows as off in the output. Still, it looks like everything is running normally. I got my 1080p resolution back, and there’s no issues running Steam games or anything.