Problems with resizing a partition

So, i made an dual-boot with Ubuntu Budgie to test it, and after i decided to keep it and went to make it's partition larger, the disk manager doesn't let me resize it.

I tried using the Ubuntu disk manager first, didn't get it to resize the partition, and tried also with the Zorin disk manager, same results.

Here's how my disk looks like now, i really want to know why it keeps those "free spaces" different from each other, and if i can fix it.


(The disk manager in the picture above is the one of Zorin OS 16.2 Core)

I really don't want to delete my current Zorin OS install, but if i don't find a solution i think i'll have to... Anyway, thanks in advance!

I am assuming you tried on a LiveUSB right?

Just wanted to verify you haven’t installed Ubuntu Budgie yet and are trying to repartition after the fact.

No no, i installed Budgie alongside Zorin to test it, and tried to resize it using the system already installed on my HDD.

Try on a LiveUSB. This might break Grub though. So be prepared to install Budgie again or use something like boot-repair-tool

Okay, i'll prepare my usb stick and see if it works.

Any luck? Drives do not like to be partitioned when they are in use.

Hey! Using my phone now, no luck, i can only resize the zorin partition for about 120gb and that leaves 100gb of wasted space... Any ideas?

Oh and also i deleted the Budgie partition to reinstall it, and its displayed as a different "free space" partition (meaning theres a 100gb one, a 120gb one and a weird one with 1,1mb)

Are the "free space" partitions connected or separated? You might need to move a partition to bring all of the free space together.

1 Like

Separated, i'll see if i can send a photo of it

I think I see. The 121GB and 128GB one right? See if you have the option (on the LiveUSB) to move partitions to bring the free space together into one lump

Nope, they stay in place, dragging or using the menu doesnt work...

Install GParted. I am not certain Disks has the ability to move a partition. Was googling that. But I am certain GParted can.

It shows a little GParted guide on that link

For some reason GParted has the same result, resize/move is grayed out and making a partition and trying to resize it doesn't let me make it bigger.

(ill take a look on the video you sent, give me a second)

It doesn't let me, the only option is to shrink the partition.

I guess my recommendation for the moment is to leave it alone and wait for someone who might know a bit more about this than myself to come along. I would not want to give bad advice.

If you did anything that will not allow it to boot reinstalling Budgie on the same partition it is already on will definitely reinstall Grub and allow you to reboot into your systems. I am not certain why it is not letting you move a partition. I know sometimes a Swap partition can complicate it but you do not have one.

Upload an image of how GParted shows your partition table as well so others can take a look of exactly what is going on

It's alright, do you think i should reinstall both OSes after wiping the entire disk? Theres not really much personal data, it's mostly the updating and installing stuff that takes a while (my ethernet cable takes about half an hour to work).

If that means fixing the problem i might try to do it.

That will certainly solve the issue. But I am nearly certain there is a solution to your problem that would not require that if you did not want to take that route

Image of GParted:

(I got to make the Zorin partition larger but it doesnt let me get the other 120gb)

Alright, i'll wait to see if someone can help me out, if i don't get to fix it i'll just wipe everything tomorrow. Thank you so much for the help, anyway :pray:

1 Like