Problems with the flatpak interface

I just started using Zorin OS and when I was installing some applications I noticed that the flatpak ones has some bug with the interface.

For example, this happened to me while using EasyEffects


Do you know what could be the cause?

Are you using AMD graphics?

Yes, I have AMD Radeon vega 8 graphics

AMD Graphics drivers are included in the kernel. It looks like the issue you are having stems from Flatpak isolating the application from the system.
You might try using Flatseal to give those applications system permissions - or use an APT version of the package instead of Flatpak.

I have tried giving EasyEffects full permissions to see if it works but it still doesn't work. Maybe I should try updating the kernel?

it's most likely just the OpenGL runtimes not having been downloaded

I'd personally suggest running flatpak update, and if that doesn't download it automatically, to run the following:

flatpak install runtime/org.freedesktop.Platform.GL.default runtime/org.freedesktop.Platform.GL32.default
1 Like

It seems that they were already installed


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.