Problems with Wine after updating Zorin

After having spent some time perfecting the system updater, I decided to update Zorin OS 17.1 from version 16.3, at the moment the system is stable and I have no problems in the system but if I have problems with Wine, you see I have some games installed with Wine since I updated I can't open one of the games which needs an image of the CD on which it was installed, so I extracted the image with AnyBurn from Windows and it hasn't given any problems until I update the system version, to find out More details about what's happening. I ran the game from the system terminal and it gave me these 2 errors.

wine: Read access denied for device L"\??\D:\", FS volume label and serial are not available.
*I think the problem may come from here because D: is the virtual Wine location for images mounted on Linux

the next error is the following.

04c0:err:sync:RtlpWaitForCriticalSection section 7BD7A2C0 "dlls/ntdll/loader.c: loader_section" wait timed out in thread 04c0, blocked by 04bc, retrying (60 sec)

*and the console goes into an infinite loop until you close the terminal

I know this is a Wine issue but I wanted to investigate here first to see if this problem is "common"

Did you tried to reinstall Wine?

1 Like

Well...does this only happen with specific disks? If not I'll just try running a Skyrim CD/DVD from Wine and see if that works :eyes:

I have not tried reinstalling Wine but I would leave it as the last option, first I will do what the @anon2532484 said to do, I have other games that require the installation CD/DVD for verification

I have tried reinstalling Wine several times and I still have the problem, I cannot find the solution, I have tried several possible solutions and nothing

This topic gives the suggestion that it is a permissions issue:
https://forum.winehq.org/viewtopic.php?t=37602

This one is more generic. It implies that a communication error is involved, but RtlpWaitForCriticalSection has a lot of very different causes.

Correcting the first error may even correct the second one...

Sorry for being away for several days but I've been busy, now that I've taken some time off I decided to go back to Zorin OS 16.3 and everything works normally, I doubt it's a system problem and rather it's a Wine problem, taking into account the leap version from 6.0.3 to 9.0. Maybe I'll stay with 16.3 for a while and then I'll try again, although it would be nice to know, and if possible, how to download an old version of Wine.

In Zorin 17.1, with the inclusion of Bottles, that is about three clicks.


Your Bottle > Settings > Runner

You can get download versions from Bottles' settings.