Programs installation problems

I needed to use windows OS in a VirtualBox so I tried to download orecal and I got this error
image
it;s not my 1st time to get this error after downloading a deb file and trying to install it

I tried this
It looks like a partial upgrade happened, corrupting the list.
Try:

sudo -i

rm /var/lib/apt/lists/partial/*

exit

sudo apt update

and I got
root@blackjokercore-X750JB:~# rm /var/lib/apt/lists/partial/*
rm: cannot remove '/var/lib/apt/lists/partial/*': No such file or directory
root@blackjokercore-X750JB:~#
root@blackjokercore-X750JB:~# exit
logout

I just kill GNOME Software whenever it decides to gift me an error, the next time it doesn't dare again :smiling_imp:.

2 Likes

Could you open the Terminal, and here type:

sudo apt install 

with a blank space after "install", and then drag your *.deb file on the terminal?
So you'll see something like

sudo apt install /home/nicolo/Downloads/debfile.deb

and then press enter?


Here what I got

Aren't sudo apt --fix-broken install, sudo apt-get update --fix-missing or sudo apt-get update --fix-broken suitable? BlackJoker, don't enter them, I just proposed them, I'm not aware of consequences :smile:.

That is usually the solution when you see the held packages message.
It would have been best to get Virtual Box .deb package from the official website:

https://www.virtualbox.org/wiki/Linux_Downloads

And if not installed already, install gdebi.
No issues with my VM of Zorin 17:

If you are running Zorin 16 then choose the Ubuntu 20.04 from that page.

But for me it is virt-manager ... every time!

It is what I used to capture Zorin 17 as a VM inside of KDE neonuser in order to create the Unofficial Manual for Zorin 17 Core.

3 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.