Proton doesnt work on csgo

so i play csgo and proton doesn't open the game and when i play native the workshop maps dont show properly and my skins in the inventory are glitched

From Steam, you can select different versions of Proton to use. By default the experimental version is enabled, and using a lower version may actually give better results sometimes, especially after experiencing issues with updates.

If that doesn't make any difference, I would suggest running Steam from the terminal as that would show any logged errors that can point to the cause of these issues.

1 Like

ive tried like 5 proton verisons so how do i run from terminal

its still doesnt work im gonna keep trying different proton versions till it works

Don't trouble yourself too much with that, if one of the latest versions other than the experimental one didn't work it's likely not the issue here.

To run Steam from the terminal simply open up a terminal window (search for "terminal" in the start menu) and run steam.

same thing

Have you verified the CS:GO files?

Verify the integrity of CSGO's files

Open Steam and select its Library tab. Right-click Counter-Strike: Global Offensive >and select Properties. Select Local Files on the Counter-Strike: Global Offensive >Properties window that opens. Press the Verify Integrity button to run the scan

already done that

1 Like

Are you seeing any error messages in the terminal when you run steam from there? It's not exactly user-friendly as there are probably many messages combined in that output, so you should take some time to read through and examine the output there. They could also be helpful for the Steam support team or community if you report this issue to them as well.

Another thing you can try is to launch the game by passing additional launch options as described here:

I can't really say which ones you should apply but this page does a very good job at suggesting and explaining a bunch of them specifically for CSGO. Hopefully there's something here that can help.

no errors in the terminal i will post my launch options maybe one of them messes with workshop maps

-novid -nojoy -nod3d9ex -high -noaafonts -lv -nod3d9ex1 -nohltv -freq 60 -limitvsconst -r_emulate_gl -softparticlesdefaultoff +r_drawparticles 0 +cl_forcepreload 1 +violence_hblood 0 +mat_disable +fancy_blending 1

Unfortunately this is as far as I can go with this issue. I don't play a lot of games and the only option I've ever had to provide at launch is -novid and -nojoy to allow Civilization VI to load.

I guess the only thing left to try is remove those options that enhance the game in some way separately, and see if you have some better results with it. You could also ask in the Steam forums directly, or search for similar issues reported under Ubuntu 20.04 since that's what ZorinOS 16 uses as its base.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.