ProtonVPN 'secretstorage' error

Hi

Have had ProtonVPN working in from since I switched to Zorin from Mint, but in the last week or so (since Proton changed to the new icons) I have been getting an: 'Error: name 'secretstorage' is not defined' output when I try to start ProtonVPN.

Anyone had this problem, any solutions? I have tried un and reinstalling, no response from cli or gui.

Cheers

Hi @Tinkr !

I use Proton VPN and have used it for a long time. I haven't had any issues even after the latest upgrade, but searching for your error message, it looks like a python thing.

Check if [Fixed] ModuleNotFoundError: No module named ‘secretstorage’ – Finxter helps (potentially pip install secretstorage).

When you say "no response from cli or gui", does that mean nothing changed (you still get the error), or nothing happens (no error now)?

2 Likes

It's probably worth mentioning that sometimes when you uninstall programs there are files left behind in case that the program is re-installed in the future. If the issue is with one of those files, then re-installing won't solve the problem which could be your case.

According to the ProtonVPN documentation you can take this steps:

# To uninstall the official app:
sudo apt-get autoremove protonvpn

# Remove any leftover files:
rm -rf ~/.cache/protonvpn
rm -rf ~/.config/protonvpn
3 Likes

Thanks for the lead, I'm chasing that up, no master on Python, but I do have multiple versions with 2.7 seeming to be the default, but I think its 3.0 that has 'secretstorage' so maybe that isn't being seen... ?

Yes cheers for that, I have fully removed and searched through usr/bin etc. for anything left behind in the uninstall aswell. Hasn't been successful yet tho.

Is the error still the same? secretstorage also exists for Python 2.7, but it needs to be pip install SecretStorage==2.3.1 (latest version which supports 2.7, past that, it's 3.x only), assuming your default python --version is 2.7 and pip --version is also for python 2.7.

Mmm I think it's worth reaching out to their support and see if they can provide more assistance on this.

Yeah error is still the same. I just tried that pip install and it came back that [Defaulting to user installation because normal site-packages is not writeable. Requirement already satisfied: SecretStorage==2.3.1 in /usr/lib/python3/dist-packages (2.3.1)

So Proton should be finding secretstorage easily enough??

I have been in contact with them, they just recommended the full uninstall and purge similar to what you listed. Initially they said Zorin is an unsupported distribution and weren't going to offer help... Just going to go back to them now, it seems like this Python thing could be the problem.

It's a shame you're having trouble, but I'd guess it's something with the dependencies since it's working fine for me. I usually just mention Zorin is a Ubuntu flavor, which people are more familiar with and understand how to help, since they'll have a lot in common anyway.

I guess my final suggestion would be to try and install secretstorage for python3, assuming you have it, and that's what's being used by Proton VPN (my default is 3.8).

Check if you have it:

python3 --version

If so, try installing the latest secretstorage:

pip3 install SecretStorage

Good luck and let us know!

2 Likes

Yes telling them it was debian based and almost the same as ubuntu/mint was how I got help. My default python is 2.7 (tho 2, 3, 3.8 and 3.9 are also installed).

The secretstorage version I have installed is 2.3.1 and it is in the usr/lib/python3/dist-packages folder...

The python3 --version command returns "Python 3.8.10"

And the pip3 install SecretStorage command returns:
"Defaulting to uer installation because normal site-packages is not writable. Requirement already satisfied: SecretStorage in /usr/lib/phython3/dist-packages (2.3.1)"

I have also just had a "HPLIP - no system tray detected on this system" when I booted. Don't know if could be related to the ProtonVPN app looking for system tray. I looked through the forum topics on this subject.

I'm sorry, I have no other idea for this. Maybe @Aravisian can come to the rescue with some other suggestion!?

1 Like

I would be googling like a maniac trying. :wink:
I have never used ProtonVPN. While I do use Protonmail, VPN's as a service generally do not garner my respect much.
I do not trust leaving my port management to someone else.
I have been following this thread, mostly stumped...

I gave the Admins of the forum notice earlier today that this coming week, I will be in a scarce state due to events here. So currently, I cannot even promise to research the issue and post what I find as I may have little net access (I am not yet sure if the HotSpot device will properly work in the remote location I will be in).

2 Likes

Hi Aravisian

Thanks for the comment, yeah I've trundled myself though the searches (sans google as I don't remotely trust them... :smiley: ). No luck so far...

I don't particularly want to have to go back to Mint, guess I could do a fresh Zorin install in a virtual machine and see if get it to work there...

Cheers

1 Like

Installed cleanly on a virtual machine, maybe I just need to do a clean install of Zorin on my machine...

Sounds like a common catch-all solution, so we could hope!

1 Like

Hey all!
I had the same issue which I resolved by installing the 3.3.3 version of secretstorage which is latest i think.
in terminal type:

sudo pip3 install secretstorage==3.3.3

you can check the latest version and change the 3.3.3 to that if it changes in future. hope it helps in resolving your issue too

is there a screenshot of the problem?