Pulse Effects autostart

New here - first post!

Alright, straight to it.. I installed Pulse Effects for an EQ, clean up the sound; and it works - but, I have to open the application after startup.. every time. I have 'enable service at login' option enabled. No change.

I noticed the version I have installed is the flatpak version, newest. But, not beta. The other versions from Software and apt just... don't work. No way to enable the EQ or change any settings. The only version that works is from Software and flatpak.

I did have a custom startup entry to open Pulse Effects but, that got weird and wouldn't start correctly.

I'm only asking because I've not seen a resolution for the issue. My other machine has Ubuntu MATE Lunar Lobster with Pulse Effects - starts normally at login.

Any suggestions would be awesome!!

Hi, and welcome!

You can try to install Gnome Tweaks and add it to the "Startup Applications" from there, as suggested in this thread:

1 Like

Have tried that, unfortunately, as well. The option within Pulse Effects enables / disables that option within tweaks. The only option that did work was with a custom startup command to open. Though it did open, the service wouldn't stay active, and still won't start on login correctly.

Opening after start works. Until I see anything come through about it, guess it's really not that big a deal. The other machine without issues I installed through apt in terminal but, straight Ubuntu MATE.

Maybe 17 will fix some stuff.. Thanks though!

One limitation of the flatpack package format is that is isolated from the rest of the environment so the setting to start as a background service may not be working for you. What I'd suggest is add this command inside ZorinOS's "Startup Applications". I've just installed and tested this myself and things seem to work fine.

Note that this will launch the program in full screen which you may not want. According to the project's documentation, you can also provide the --gapplication-service flag at the end of the command to run it as a service.

And btw you may notice from the link above that this project has actually been renamed to EasyEffects and it has its own package. It doesn't seem to be available through apt ZorinOS but there is one available as a flatpak, in case you want to give that a try.

Going to grab my ZenBook and give this a try.. Thanks!!

Now, about Easy Effects - did see that as well.. should I be using that instead of Pulse Effects? I can't remember if I tried that or not; either way - going to try both; and yeah! I do not know why flatpaks are so separated from everything else. Any idea if the new 17 update will be cleaning that up? Pules Effects is literally the ONLY one that's being so weird.

I'll let you know what happens.


No more c rap sound!.. on boot lol

Did not try Easy Effects, since this works - tried the other version through Software listed as 'ZorinOS Package' but, no presets, no EQ enabling, nothing. Weird.. But absolutely works now!

I don't know, never used neither package, but it's something that I caught my attention. They may be the exact same package except with a different name, or maybe there are some differences... I'll let you try it out and report back :slight_smile:

Flatpak is a package format that is meant to be sandboxed from the rest of the system, for several reasons. This has some benefits but also introduces some new challenges to get things working, but this varies widely from one package to another. Sometimes you will never be able to tell the difference, some other times nothing will work at all. Unfortunately, I'm not knowledgeable enough to give a better answer.

ZorinOS 17 will be based on a more recent version of Ubuntu so PulseEffects/EasyEffects should be available as a more updated version as well. This may be enough to justify using the .deb package if it suits your needs, but if not you can always go back to use the flatpak option.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.