Pyperclip module not found under ZorinOS 16 Pro

I just upgraded from ZorinOS 15.3 Premium to 16 Pro. Some of the Python apps that I developed on 15.3 use the pyperclip module. The apps worked on 15.3, but complain that this module is not found under OS 16. There were no errors reported during the installation of pyperclip. It all works if I run within VS Code ... but not outside of it. I found a number of other posts about pyperclip, but none just like my problem.

What versions of python do you currently have installed?

Python 3.8.10 -- it came with OS 16. I'm not certain, but I think I had 3.8.6 under OS 15.3.

What python2 do you have, as well?
And ensure that the proper package is installed:

sudo apt-get install -y python-pyperclip

Here is how I installed it::
pip install pyperclip

I should add that in the Python interactive app, I can import pyperclip without any errors.

python2 --version says that there is no python2..

I think it moved to python 3

Try;

sudo apt install python3-pyperclip
2 Likes

Thank-you Storm! That fixed it. What a relief.

3 Likes