Questions about text in Zorin

I'm just trying to use text just like in windows.

When I double click it says

Do you want to run xx.txt , or display it's contents ?
text is an executable text file

Run in Terminal / Display / Cancel / Run

I have 4 Options and when I click display I get to run the text file and read or write.

How do I just make it display right away ?

I went to properties -> permissions -> Execute: Allow executing file as program.

I unchecked it , but it automatically gets CHECKED back again.

So I can't uncheck it.

I'm new to linux so if I could, I would prefer to not use commands if possible.

Also these text files opens in the same "Text Window". As if it's a
"Web Browser" tabs. Like in firefox tabs.
I do see an option for "New window". However it's still like opening an additional
browser window.

How do I make it open text files as if it's windows. Like double click, text files opens in new window every time. No tabs.

Right click -> Open With...

Make sure you tick the option below that says "Always use for this file type", and then choose the file from the list that you want to use.

I don't know if there's an option to always open new documents in separate windows, but you can try to drag and drop the tab outside of the window and it will open a new one for you.

1 Like

I found if you right click the txt file & goto properties> under Permissions, uncheck ( allow executing file as program. txt files open normally.
Hope this may help.
P.s. i see this doesn't work on external drives,( hence it will as you said just re-check it), the txt file must made/created within the os. if you copy a txt file from an external source. you will have to do this procedure "Once" again. Then it will continue to open.

Answer #1 nautilus - Ubuntu claims "executable text file" (e.g. .txt,.csv,.sh but not .xls) despite absence of `x` permission - Ask Ubuntu

Handles local and external drives.

I figured out how to view text files with double click just like in windows.
This method works for entire computer. I had no idea and figured that text files that are inside the external drives certainly doesn't work to uncheck it
unlike the text files in the pc that is not the external drive.
So the method below is best for every situation. Since Zorin os is making things simple and similar to windows, it would've been better if they made this option as a default.

Right click 2nd icon away from zorin icon (windows icon of zorin) -> New window
or
Double click on Home icon if you made one. (which is my pc in windows.)

Click on the 3rd icon away from the magnifying glass icon on top.
Which looks like 3 lines from top to bottom for options.

Preferences

Behavior tab

Executable text files

Check on "Display Them".

Awesome. I solved one problem. But there are a lot of things I want to change and need to learn. Long way to go. lol

Dragging the tab away to the empty desktop certainly opens a new window
so I can view separately except it would definitely be better if I could open in
a new window. I guess it's hard to imitate the simple windows method in a different linux os.

1 Like

That is it in a nutshell. :+1:

Must remember that although ZorinOS is designed to ease Windows refugees into the Linux desktop OS envirinment. ZorinOS is not a Windows clone, so commands and actions may not be the same as Windows. With a little persistence, people find it quite easy to learn to use, just don't expect it to be verbatim Windows.

@jumpboy Excellent my friend great work, i just reversed my suggestion & applied your method & YES works even on external drives, Thanks heaps for a great explanation, & the effort.
Cheers