Quick Flash does not see the USB. Gabyte X370-gaming 5, BIOS update to F51f

I have downloaded the F51f update to my USB flash drive and extracted files. After restarting Quick Flash does not see the USB drive, only shows my SSD boot drive. I booted into windows10 and same results. Can't install new processor until Bios is updated.

Does anyone have any ideas on what to do.

Which format is the USB drive? It needs to be formatted in FAT32

1 Like

Or in FAT.

Also, ensure that you have Legacy USB enabled.

1 Like

@Storm Fat 32 and I will double check Legacy is enabled.

Here is everything related?
Other PCI devices ROM Priority -- UEFI
Storage Boot Optiom Control -- Legacy Only
USB Legacy Support -- Enabled
XHCI Hand-off -- Enabled
USB Mass storage driver support -- Enabled
Port 60/64 Emulation -- Disabled
Samsung Flash Drive 1100 -- Auto

In this case, please try formatting the USB in FAT (not FAT32). Once done, proceed as before and see if it is recognized.

Gigabyte Q-Flash say's must be in Fat32/16/12

FAT is same as FAT16

How to format without booting into Windows? The USB drive shows up under Computer and the folders are located /media/ezorb/DOCE-7114.
Is this correct?

You can format the USB stick using Zorin OS using the Disks tool in your app menu.
Select the USB stick from the list, then click the gear (settings) icon.
You can choose to Format from there.

It did not give me a choice of Fat16. It said something like format to Fat to be use with ?

Yes, FAT and FAT16 are the Same Format.

It will be about 45 min more.

Under the gear. It shows:
Size 128GB
Device /dev/sdc1
Partition Type NTFS/exFAT/HPFS
Contents Unknown
Job shows progress of Erasing Device
Is this correct?
AND
Under File System/ezorb/root folder with Red X and core folder with Red X
Is this correct.

Got a different USB drive formatted it to Fat32 loaded the BIOS F51f files and it installed. Problem was the new Samsung 1100 flash drive.

1 Like