R4 version doesn't work on certain computers

Hello Zorin Community I have found another issue with the latest release of Zorin

it seems that the r4 and r1 versions do not work on certain laptops, as far as my research has gone

HP, Razer and Dell laptops do not work if any others do not work please comment thank you!

@Derek Can you please provide more information than "do not work" i.e. what happens?, what do you see? what error messages? etc.

Doesn't show up in boot options just knows that the USB plugged in

The r1 issue is known, which is what led to the creation of the versions that followed it. if r4 is the latest listed, that is the one we need to focus on.

just tried the original version also doesn't work, I don't know what to do, am on Kubuntu trying to get back to zorin

I'm going to try if Ubuntu works, to see if it's an issue with my system or not

It's been a while since confronting this issue... But there were several workarounds that resolved being able to install covered on the forum at the time of Z16 Core release.
I just tried searching the forum for these posts but... Apparently my skills in this are simply lacking...

to add I'm using the USB Disk Creation tool, is it known to have issues with Zorin ISO's? should I try using Balena

To me, all of those point to looking in the BIOS for a fix. For example, my desktop Rampage II Extreme mobo supposedly allows booting from USB but in reality it refuses to do so leading me to resort to other measures (either DVD or installing Unetbootin on another SATA).

1 Like

I avoid Balena... I know of no known issues with the USB Disk Creation tool, though you can try unetbootin or multiboot or others just to be sure.

1 Like

I have booted Zorin on the Device multiple times with the Same USB and other OS's on the same USB so I assume it's an issue with the ISO file it self I'll give a try with Ubuntu, if I have the same issue

Could be. Please verify the checksum: Stuck installation - #12 by carmar

Update: I've tried all versions of the Core except R1 -none seem to work but Ubuntu 21.10 did work correctly so I am going to flash the R1 version to see if it works, if it does we know we can remove The Razer Blade 15 late 2020 from the list

Seems that all versions of Zorin OS 16 do not work on the Razer Blade 15, which needs to be fixed

yes it seems your system does need looking at... As all my computers ..laptop or desktop work fine with Zorin