Randomly unable to navigate GUI with keyboard/mouse

Hello all. I'm having a frustrating issue that started happening in the past week. Hoping someone can help troubleshoot. Randomly I'm unable to use the mouse or keyboard to navigate within windows. The Menu/Windows key brings up the Zorin menu, but existing windows such as Chrome or the Settings app don't respond to any clicks either with the mouse or keyboard. All apps are affected when this occurs.

I can navigate through windows with Alt-Tab. I can launch a terminal session with CTL-ALT-T. From the terminal session, all keys function normally. xev reports that the keys are being pressed and they are the expected scancodes.

In Chrome, for example, I can use CTRL-W to close windows, but the events don't register.

I have tried:

  • Deleting all dotfiles and dotdirs in home directory and recreating
  • External keyboard and wired mouse
  • Ubuntu Live CD (works, no issues)

If I kill gnome-shell it starts working again. System is fully updated as of an hour ago. If I strace gnome-shell there's a lot of logs but don't see anything that jumps out as the cause.

Any help is appreciated. I don't/can't re-install at the moment.

Hi, and welcome.

You can try to refresh the desktop via Alt+F2 and simply entering r at the window prompt. I'm afraid I don't know what can be the cause of the underlying problem, but hopefully this gives you a quick way of getting back up and running. Note that this will not work if you are on Wayland.

You can use the Zorin Built in Settings > Extensions manager or Gnome Tweak Tool

sudo apt install gnome-tweaks

I recommend disabling all gnome shell extensions except for the Zorin App Menu.
Test if issue occurs. If it does not- begin re-enabling extensions until it does occur, thereby narrowing down which extensions is the fault.
Shortcut: Start by disabling all non-essential gnome shell extensions and test and see if you get lucky...

Thank you for the reply. When it occurs again I will try this.
I am not running Wayland at the moment, but may try switching over. I do see the Xorg process at the top of the top/btop output. Not super high, but at 6% when the system is otherwise idle.

Thank you. I will try this. gnome-tweaks was installed and I have disabled all extensions for now.

There appears to be some issue specifically with button press events. Because it's occurring with both a wired and bluetooth mouse, I was thinking it was some sort of input driver.

In syslog there are a few hundred of these messages:

syslog:Oct 9 00:00:06 delilah gnome-shell[34281]: clutter_actor_hide: assertion 'CLUTTER_IS_ACTOR (self)' failed
syslog:Oct 9 00:00:09 delilah gnome-shell[34281]: clutter_container_get_children: assertion 'CLUTTER_IS_CONTAINER (container)' failed
syslog:Oct 9 00:00:09 delilah gnome-shell[34281]: clutter_container_add_actor: assertion 'CLUTTER_IS_CONTAINER (container)' failed
syslog:Oct 9 00:00:09 delilah gnome-shell[34281]: clutter_actor_show: assertion 'CLUTTER_IS_ACTOR (self)' failed
syslog:Oct 9 00:00:09 delilah gnome-shell[34281]: clutter_actor_hide: assertion 'CLUTTER_IS_ACTOR (self)' failed

There are hundreds of these messages in journalctl:

Feb 18 19:17:58 delilah dbus-daemon[907]: [system] Rejected: destination has a full message queue, 0 matched rules; type="error", sender="(unset)" ((bus)) interface="(unset)" member="(unset)" error name="org.freedesktop.DBus.Error.ServiceUnknown" requested_reply="1" destination=":1.238" (uid=1000 pid=43191 comm="/usr/bin/gnome-shell " label="unconfined")
Feb 18 19:17:58 delilah dbus-daemon[907]: [system] Rejected: destination has a full message queue, 0 matched rules; type="error", sender="(unset)" ((bus)) interface="(unset)" member="(unset)" error name="org.freedesktop.DBus.Error.ServiceUnknown" requested_reply="1" destination=":1.238" (uid=1000 pid=43191 comm="/usr/bin/gnome-shell " label="unconfined")

I don't see any HID events to speak off in the logs except for some disconnects when I turned on/off the mouse or unplugged to switch devices.

Found this: Nvidia 495 log spam - full message queue / Kernel & Hardware / Arch Linux Forums

Checking journalctl again, I see 150K of these "Rejected: destination has a full message queue..." errors. This laptop is also running NVidia drivers (from Zorin repos). These are coming in at 50 or so per second from what I can see.

I'm going to try rolling the drivers to Nvidia vanilla.

1 Like

DigitalHermit, would you be so kind as to provide your system specs? Particularly, manufacturer, model, year of make and RAM size. The CPU and GPU would possibly be beneficial also.

It sounds like a controller issue, but with wired and wireless, I can't be certain. I'm wondering how full your drive is and if it needs a cleaning. Logs, caches and temp files can fill a drive if it isn't larger than the minimum required.

Thanks for the reply 337harvey...

I'm running on a Dell XPS 15 9500, purchased in January 2021. It has 64G currently. lspci and dmidecode show the following:

00:00.0 Host bridge: Intel Corporation Device 9b44 (rev 02)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor PCIe Controller (x16) (rev 02)
00:02.0 VGA compatible controller: Intel Corporation UHD Graphics (rev 05)
00:04.0 Signal processing controller: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Thermal Subsystem (rev 02)
00:08.0 System peripheral: Intel Corporation Xeon E3-1200 v5/v6 / E3-1500 v5 / 6th/7th/8th Gen Core Processor Gaussian Mixture Model
00:12.0 Signal processing controller: Intel Corporation Comet Lake PCH Thermal Controller
00:13.0 Serial controller: Intel Corporation Device 06fc
00:14.0 USB controller: Intel Corporation Comet Lake USB 3.1 xHCI Host Controller
00:14.2 RAM memory: Intel Corporation Comet Lake PCH Shared SRAM
00:14.3 Network controller: Intel Corporation Wi-Fi 6 AX201
00:15.0 Serial bus controller [0c80]: Intel Corporation Comet Lake PCH Serial IO I2C Controller #0
00:15.1 Serial bus controller [0c80]: Intel Corporation Comet Lake PCH Serial IO I2C Controller #1
00:16.0 Communication controller: Intel Corporation Comet Lake HECI Controller
00:1c.0 PCI bridge: Intel Corporation Device 06b8 (rev f0)
00:1c.6 PCI bridge: Intel Corporation Device 06be (rev f0)
00:1d.0 PCI bridge: Intel Corporation Comet Lake PCI Express Root Port #9 (rev f0)
00:1e.0 Communication controller: Intel Corporation Comet Lake PCH Serial IO UART Host Controller #0
00:1f.0 ISA bridge: Intel Corporation Device 068e
00:1f.3 Audio device: Intel Corporation Comet Lake PCH cAVS
00:1f.4 SMBus: Intel Corporation Comet Lake PCH SMBus Controller
00:1f.5 Serial bus controller [0c80]: Intel Corporation Comet Lake PCH SPI Controller
01:00.0 3D controller: NVIDIA Corporation Device 1f95 (rev a1)
Processor Information
	Socket Designation: CPU 1
	Type: Central Processor
	Family: Core i7
	Manufacturer: Intel(R) Corporation
	Signature: Type 0, Family 6, Model 165, Stepping 2

Drive is at about 50% capacity:

> Filesystem        Size    Used   Avail  Use% Mounted on
> /dev/nvme0n1p2    916G    429G    441G   50%   /

You may be onto something with wired/wireless. I've completely disconnected the mouse and been using trackpad only. After a few hours I have not seen the issue again. I had previously replaced the mouse (Logitech Pebble) with another one and the issue and it also would go into the error state. I ordered a USB wireless mouse so I can test that also.

Other notes: I re-enabled the Gnome extensions via Tweaks. Even with all of them off the issue persisted. I do like the Zorin look-and-feel and it was a pain to have the generic Gnome desktop.

Also unloaded the VMWare kmods which did not fix the issue.

1 Like

It could be an incompatibility between the touchpad and mouse drivers, though this would be very rare indeed!

In the USB port you use, and the mouse USB connector, do you see any foreign particles? I doubt it, but anything is possible. Also, did you install the xserver input package? The command is sudo apt install xserver-xorg-input-all. Attempt this and see if the error occurs still. Might need to reboot after install to load the drivers.

Do you have auto-login enabled perchance? Slow keys in accessibility enabled?

Have you followed up on this idea you had earlier?

Thanks for verifying. So we know it is not an issue with Gnome Shell extensions and by that reasoning, is not likely an issue with Gnome Shell itself - rather Gnome Shell is being affected.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.