Realtek audio drivers for zorin os education

I need help with installing realtek drivers(along with hd audio manager) on Zorin, I had installed zorin the previous week and since then I am trying to use my headset's microphone instead of the built-in one but my laptop wouldn't do it ;-;
I have tried almost every guide on the web that I could find but still whenever I go to the sound settings, it just doesnt show my headset's mic instead it only shows the headset as an output device, however on windows whenever i plugged in the same headset in the same jack a popup would appear and i would choose "headset" and the mic worked fine but with Zorin, I just can't seem to do that!
Any help would be deeply appreciated!

Hi and welcome to the Forum.
Which version and flavour of Zorin do you have e.g. Z15.3 Core, Lite etc, or maybe Z16 Beta?

Is your headset/mic combo a USB or 3.5mm jack device?

First have a look at Zorin>Settings>Sound to see if that looks right for both headset and mic.

I would then suggest a look at running Alsamixer in terminal and check all your input and output settings and levels. Whilst in Alsamixer, have an experiment with "Loopback". Default is "Disabled" but have a go with it "Enabled", you can always toggle the setting back as was.

If you do find a Alsamixer setting that gets you working, you can save it using:

sudo alsactl store

Let us know if you already tried all that.

What is your machine and what sound card does it have?

1 Like

Facing the same issue. Can't access my microphone on Lenovo Yoga 510 having Realtek audio. I have installed Zorin OS 15.3 Education edition.

@Suyog Hi and welcome to the forum.
Have you tried what I mentioned in my previous post above yours?
Can you also tell us what sound card your machine has.

1 Like

I have been through many forums and always come to an active thread on realtek. User and voice seem to have problems with installation and upgrading their Realtek drivers. So, one needs to install compatible drivers with his/her system in order to fix the problem regarding audio.

Good afternoon,
Realtek HD-Audio drivers give quite a few problems with Linux. In my case I have an Asus laptop with the Realtek ALC294 codec, with which no audio is heard on the system. I found a thread where they explain a solution for the audio to be heard again, and that user also provides another solution to the problem that the audio can not be regulated and goes from 0% to 100%. This problem is reported but not yet patched in the Linux Kernel.