Realtek rtl8723be Dropping Issue

Hello everyone,
I installed Zorin OS Education Lite 16 in my sister's HP 13-c000nt laptop, and we're amazed. But we're experienced issues with the wireless card. Wifi connection is dropping from time to time, and works only until stop and start wifi if it works. I tried to disable all kinds of power management about networking, but so far I cannot fix the issue. I managed to figure out (I hope) what is the problem. On journalctl, the dropping happens after starting network script dispatcher. Here some specs, and full journalctl logs:

inxi -Fxz
System:
  Kernel: 5.13.0-28-generic x86_64 bits: 64 compiler: N/A 
  Desktop: Xfce 4.16.0 Distro: Zorin OS 16 base: Ubuntu 20.04 LTS Focal 
Machine:
  Type: Laptop System: Hewlett-Packard product: HP Stream Notebook PC 13 
  v: Type1 - ProductConfigId serial: <filter> 
  Mobo: Hewlett-Packard model: 802A v: 56.10 serial: <filter> UEFI: Insyde 
  v: F.05 date: 11/28/2014 
Battery:
  ID-1: BAT0 charge: 27.7 Wh condition: 27.7/27.7 Wh (100%) 
  model: Hewlett-Packard Primary status: Discharging 
CPU:
  Topology: Dual Core model: Intel Celeron N2840 bits: 64 type: MCP 
  arch: Silvermont rev: 8 L2 cache: 1024 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 8666 
  Speed: 521 MHz min/max: 500/2582 MHz Core speeds (MHz): 1: 550 2: 569 
Graphics:
  Device-1: Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display 
  vendor: Hewlett-Packard driver: i915 v: kernel bus ID: 00:02.0 
  Display: x11 server: X.Org 1.20.13 driver: modesetting 
  unloaded: fbdev,vesa resolution: 1366x768~60Hz 
  OpenGL: renderer: Mesa DRI Intel HD Graphics (BYT) v: 4.2 Mesa 21.0.3 
  direct render: Yes 
Audio:
  Device-1: Intel Atom Processor Z36xxx/Z37xxx Series High Definition Audio 
  vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  Sound Server: ALSA v: k5.13.0-28-generic 
Network:
  Device-1: Realtek RTL8723BE PCIe Wireless Network Adapter 
  vendor: Hewlett-Packard driver: rtl8723be v: kernel port: 1000 
  bus ID: 02:00.0 
  IF: wlp2s0 state: up mac: <filter> 
Drives:
  Local Storage: total: 29.12 GiB used: 20.33 GiB (69.8%) 
  ID-1: /dev/mmcblk0 model: SDW32G size: 29.12 GiB 
Partition:
  ID-1: / size: 28.04 GiB used: 20.32 GiB (72.5%) fs: ext4 
  dev: /dev/mmcblk0p2 
Sensors:
  System Temperatures: cpu: 35.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 172 Uptime: 7m Memory: 1.82 GiB used: 722.7 MiB (38.7%) 
  Init: systemd runlevel: 5 Compilers: gcc: 9.3.0 clang: 10.0.0-4ubuntu1 
  Shell: bash v: 5.0.17 inxi: 3.0.38 
sudo lshw -C network
  *-network                 
       açıklama: Kablosuz arayüz
       ürün: RTL8723BE PCIe Wireless Network Adapter
       üretici: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:02:00.0
       mantıksal ad: wlp2s0
       sürüm: 00
       serial: 2c:33:7a:41:6e:23
       genişlik: 64 bits
       saat: 33MHz
       kapasiteler: pm msi pciexpress bus_master cap_list eternet physical wireless
       yapılandırma: broadcast=yes driver=rtl8723be driverversion=5.13.0-28-generic firmware=N/A ip=192.168.1.145 latency=0 link=yes multicast=yes wireless=IEEE 802.11
       kaynaklar: irq:17 ioport:1000(boyut=256) bellek:90500000-90503fff
iwconfig
lo        no wireless extensions.

wlp2s0    IEEE 802.11  ESSID:"Anafor"  
          Mode:Managed  Frequency:2.427 GHz  Access Point: 54:83:3A:14:F2:51   
          Bit Rate=72.2 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:off
          Link Quality=70/70  Signal level=-24 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:20   Missed beacon:0
/etc/modprobe.d/rtl8723be.conf
	options rtl8723be fwlps=0 ips=0
sudo systool -a -v -m rtl8723be | grep -A8 "Parameters"
[sudo] dilara için parola:         
  Parameters:
    ant_sel             = "2"
    aspm                = "1"
    debug_level         = "0"
    debug_mask          = "0"
    disable_watchdog    = "N"
    fwlps               = "N"
    ips                 = "N"
    msi                 = "N"
systemctl list-unit-files --state=enabled
STATE                                       VENDOR PRESET
acpid.path                                 enabled enabled      
cups.path                                  enabled enabled      
accounts-daemon.service                    enabled enabled      
anacron.service                            enabled enabled      
apparmor.service                           enabled enabled      
autovt@.service                            enabled enabled      
avahi-daemon.service                       enabled enabled      
binfmt-support.service                     enabled enabled      
blueman-mechanism.service                  enabled enabled      
bluetooth.service                          enabled enabled      
console-setup.service                      enabled enabled      
cron.service                               enabled enabled      
cups-browsed.service                       enabled enabled      
cups.service                               enabled enabled      
dbus-fi.w1.wpa_supplicant1.service         enabled enabled      
dbus-org.bluez.service                     enabled enabled      
dbus-org.freedesktop.Avahi.service         enabled enabled      
dbus-org.freedesktop.ModemManager1.service enabled enabled      
dbus-org.freedesktop.nm-dispatcher.service enabled enabled      
dbus-org.freedesktop.resolve1.service      enabled enabled      
dbus-org.freedesktop.thermald.service      enabled enabled      
dbus-org.freedesktop.timesync1.service     enabled enabled      
dmesg.service                              enabled enabled      
e2scrub_reap.service                       enabled enabled      
getty@.service                             enabled enabled      
gpu-manager.service                        enabled enabled      
grub-common.service                        enabled enabled      
grub-initrd-fallback.service               enabled enabled      
irqbalance.service                         enabled enabled      
kerneloops.service                         enabled enabled      
keyboard-setup.service                     enabled enabled      
lm-sensors.service                         enabled enabled      
ModemManager.service                       enabled enabled      
network-manager.service                    enabled enabled 
Şub 07 01:49:40 mulitaskmachine kernel: rtlwifi: AP off, try to reconnect now
Şub 07 01:49:40 mulitaskmachine kernel: wlp2s0: Connection to AP 54:83:3a:14:f2:51 lost
Şub 07 01:49:40 mulitaskmachine wpa_supplicant[492]: wlp2s0: CTRL-EVENT-DISCONNECTED bssid=54:83:3a:14:f2:51 reason=4 locally_generated=1
Şub 07 01:49:40 mulitaskmachine NetworkManager[457]: <warn>  [1644187780.5692] sup-iface[0x5581546b9920,wlp2s0]: connection disconnected (reason -4)
Şub 07 01:49:40 mulitaskmachine wpa_supplicant[492]: wlp2s0: CTRL-EVENT-REGDOM-CHANGE init=CORE type=WORLD
Şub 07 01:49:40 mulitaskmachine NetworkManager[457]: <info>  [1644187780.5946] device (wlp2s0): supplicant interface state: completed -> disconnected
Şub 07 01:49:40 mulitaskmachine NetworkManager[457]: <info>  [1644187780.5948] device (p2p-dev-wlp2s0): supplicant management interface state: completed -> disconnected
Şub 07 01:49:40 mulitaskmachine NetworkManager[457]: <info>  [1644187780.6829] device (wlp2s0): supplicant interface state: disconnected -> scanning
Şub 07 01:49:40 mulitaskmachine NetworkManager[457]: <info>  [1644187780.6830] device (p2p-dev-wlp2s0): supplicant management interface state: disconnected -> scanning
Şub 07 01:49:55 mulitaskmachine NetworkManager[457]: <warn>  [1644187795.8465] device (wlp2s0): link timed out.
Şub 07 01:49:55 mulitaskmachine NetworkManager[457]: <info>  [1644187795.8541] device (wlp2s0): state change: activated -> failed (reason 'ssid-not-found', sys-iface-state: 'managed')
Şub 07 01:49:55 mulitaskmachine avahi-daemon[449]: Withdrawing address record for fe80::a646:ae59:6a82:96cb on wlp2s0.
Şub 07 01:49:55 mulitaskmachine NetworkManager[457]: <info>  [1644187795.8566] manager: NetworkManager state is now DISCONNECTED
Şub 07 01:49:55 mulitaskmachine avahi-daemon[449]: Leaving mDNS multicast group on interface wlp2s0.IPv6 with address fe80::a646:ae59:6a82:96cb.
Şub 07 01:49:55 mulitaskmachine NetworkManager[457]: <warn>  [1644187795.8595] device (wlp2s0): Activation: failed for connection 'Anafor'
Şub 07 01:49:55 mulitaskmachine avahi-daemon[449]: Interface wlp2s0.IPv6 no longer relevant for mDNS.
Şub 07 01:49:55 mulitaskmachine NetworkManager[457]: <info>  [1644187795.8624] device (wlp2s0): state change: failed -> disconnected (reason 'none', sys-iface-state: 'managed')
Şub 07 01:49:55 mulitaskmachine dbus-daemon[456]: [system] Activating via systemd: service name='org.freedesktop.nm_dispatcher' unit='dbus-org.freedesktop.nm-dispatcher.service' requested by ':1.10' (uid=0 pid=457 comm="/usr/sbin/NetworkManager --no-daemon " label="unconfined")
Şub 07 01:49:55 mulitaskmachine NetworkManager[457]: <info>  [1644187795.8875] dhcp4 (wlp2s0): canceled DHCP transaction
Şub 07 01:49:55 mulitaskmachine avahi-daemon[449]: Withdrawing address record for 192.168.1.145 on wlp2s0.
Şub 07 01:49:55 mulitaskmachine NetworkManager[457]: <info>  [1644187795.8876] dhcp4 (wlp2s0): state changed bound -> done
Şub 07 01:49:55 mulitaskmachine avahi-daemon[449]: Leaving mDNS multicast group on interface wlp2s0.IPv4 with address 192.168.1.145.
Şub 07 01:49:55 mulitaskmachine systemd[1]: Starting Network Manager Script Dispatcher Service...
Şub 07 01:49:55 mulitaskmachine avahi-daemon[449]: Interface wlp2s0.IPv4 no longer relevant for mDNS.
Şub 07 01:49:55 mulitaskmachine dbus-daemon[456]: [system] Successfully activated service 'org.freedesktop.nm_dispatcher'
Şub 07 01:49:55 mulitaskmachine systemd[1]: Started Network Manager Script Dispatcher Service.
Şub 07 01:49:55 mulitaskmachine nm-dispatcher[2630]: run-parts: failed to stat component /etc/network/if-post-down.d/avahi-daemon: No such file or directory
Şub 07 01:49:58 mulitaskmachine NetworkManager[457]: <info>  [1644187798.5196] device (wlp2s0): supplicant interface state: scanning -> inactive
Şub 07 01:49:58 mulitaskmachine NetworkManager[457]: <info>  [1644187798.5229] device (p2p-dev-wlp2s0): supplicant management interface state: scanning -> inactive
Şub 07 01:50:05 mulitaskmachine systemd[1]: NetworkManager-dispatcher.service: Succeeded.

Have you tried:

sudo modprobe rtl8723be

Or
Have you tried installing a different driver?

Edit: You might also try:

sudo tee /etc/modprobe.d/rtl8723be.conf <<< "options rtl8723be ant_sel=1"

Source:
https://itectec.com/ubuntu/ubuntu-realtek-rtl8723be-wifi-drivers-not-working-after-upgrading-to-5-4-0-37/

1 Like

I tried modprobing with no luck. ant_sel 1 doesn't work at all, only ant_sel 2. I didn't try another driver, because I couldn't find drivers in github, where sometimes ago there was (https://github.com/lwfinger/rtlwifi_new). I think when the driver included to linux kernel, they decided there was no point to maintain driver packages. If there is any other source, I could try. Thanks for your answer.

1 Like

What about this driver:

It should appear in Downloads. Extract it
ctrl+alt+t

cd ~/Downloads/rtlwifi_new-master

make

sudo make install

sudo modprobe -v rtl8723be ant_sel=2

iwconfig

Grab your wlpID and use it for by replacing wlpEXAMPLE with the one shown by iwconfig:

sudo ip link set wlpEXAMPLE up

Scan strength:

sudo iw dev wlpEXAMPLE scan

echo "options rtl8723be ant_sel=2" | sudo tee /etc/modprobe.d/50-rtl8723be.conf
1 Like

Thank you very much, I'll try and write the results. Do I have to remove the old driver?

You can if you want - it shouldn't matter since you are directing the module proper as to which driver to use.

1 Like

The process gives this error:

 make
make -C /lib/modules/5.13.0-28-generic/build M=/home/dilara/rtlwifi_new-master modules
make[1]: Entering directory '/usr/src/linux-headers-5.13.0-28-generic'
  CC [M]  /home/dilara/rtlwifi_new-master/btcoexist/halbtc8192e2ant.o
  CC [M]  /home/dilara/rtlwifi_new-master/btcoexist/halbtc8723b1ant.o
  CC [M]  /home/dilara/rtlwifi_new-master/btcoexist/halbtc8723b2ant.o
  CC [M]  /home/dilara/rtlwifi_new-master/btcoexist/halbtc8821a1ant.o
  CC [M]  /home/dilara/rtlwifi_new-master/btcoexist/halbtc8821a2ant.o
  CC [M]  /home/dilara/rtlwifi_new-master/btcoexist/halbtcoutsrc.o
  CC [M]  /home/dilara/rtlwifi_new-master/btcoexist/rtl_btc.o
  LD [M]  /home/dilara/rtlwifi_new-master/btcoexist/btcoexist.o
  CC [M]  /home/dilara/rtlwifi_new-master/rtl8188ee/dm.o
  CC [M]  /home/dilara/rtlwifi_new-master/rtl8188ee/fw.o
  CC [M]  /home/dilara/rtlwifi_new-master/rtl8188ee/hw.o
  CC [M]  /home/dilara/rtlwifi_new-master/rtl8188ee/led.o
  CC [M]  /home/dilara/rtlwifi_new-master/rtl8188ee/phy.o
  CC [M]  /home/dilara/rtlwifi_new-master/rtl8188ee/pwrseq.o
  CC [M]  /home/dilara/rtlwifi_new-master/rtl8188ee/pwrseqcmd.o
  CC [M]  /home/dilara/rtlwifi_new-master/rtl8188ee/rf.o
  CC [M]  /home/dilara/rtlwifi_new-master/rtl8188ee/sw.o
  CC [M]  /home/dilara/rtlwifi_new-master/rtl8188ee/table.o
  CC [M]  /home/dilara/rtlwifi_new-master/rtl8188ee/trx.o
  LD [M]  /home/dilara/rtlwifi_new-master/rtl8188ee/rtl8188ee.o
  CC [M]  /home/dilara/rtlwifi_new-master/rtl8192c/main.o
  CC [M]  /home/dilara/rtlwifi_new-master/rtl8192c/dm_common.o
  CC [M]  /home/dilara/rtlwifi_new-master/rtl8192c/fw_common.o
  CC [M]  /home/dilara/rtlwifi_new-master/rtl8192c/phy_common.o
  LD [M]  /home/dilara/rtlwifi_new-master/rtl8192c/rtl8192c-common.o
  CC [M]  /home/dilara/rtlwifi_new-master/rtl8192ce/dm.o
  CC [M]  /home/dilara/rtlwifi_new-master/rtl8192ce/fw.o
  CC [M]  /home/dilara/rtlwifi_new-master/rtl8192ce/hw.o
  CC [M]  /home/dilara/rtlwifi_new-master/rtl8192ce/led.o
  CC [M]  /home/dilara/rtlwifi_new-master/rtl8192ce/phy.o
  CC [M]  /home/dilara/rtlwifi_new-master/rtl8192ce/rf.o
  CC [M]  /home/dilara/rtlwifi_new-master/rtl8192ce/sw.o
  CC [M]  /home/dilara/rtlwifi_new-master/rtl8192ce/table.o
  CC [M]  /home/dilara/rtlwifi_new-master/rtl8192ce/trx.o
  LD [M]  /home/dilara/rtlwifi_new-master/rtl8192ce/rtl8192ce.o
  CC [M]  /home/dilara/rtlwifi_new-master/rtl8192cu/dm.o
  CC [M]  /home/dilara/rtlwifi_new-master/rtl8192cu/hw.o
/home/dilara/rtlwifi_new-master/rtl8192cu/hw.c: In function ‘_rtl92cu_init_chipN_one_out_ep_priority’:
/home/dilara/rtlwifi_new-master/rtl8192cu/hw.c:622:2: warning: parameter names (without types) in function declaration
  622 |  u16 uninitialized_var(value);
      |  ^~~
/home/dilara/rtlwifi_new-master/rtl8192cu/hw.c:626:3: error: ‘value’ undeclared (first use in this function)
  626 |   value = QUEUE_HIGH;
      |   ^~~~~
/home/dilara/rtlwifi_new-master/rtl8192cu/hw.c:626:3: note: each undeclared identifier is reported only once for each function it appears in
/home/dilara/rtlwifi_new-master/rtl8192cu/hw.c: In function ‘_rtl92cu_init_chipN_two_out_ep_priority’:
/home/dilara/rtlwifi_new-master/rtl8192cu/hw.c:648:2: warning: parameter names (without types) in function declaration
  648 |  u16 uninitialized_var(valueHi);
      |  ^~~
/home/dilara/rtlwifi_new-master/rtl8192cu/hw.c:649:2: warning: parameter names (without types) in function declaration
  649 |  u16 uninitialized_var(valueLow);
      |  ^~~
/home/dilara/rtlwifi_new-master/rtl8192cu/hw.c:653:3: error: ‘valueHi’ undeclared (first use in this function)
  653 |   valueHi = QUEUE_HIGH;
      |   ^~~~~~~
/home/dilara/rtlwifi_new-master/rtl8192cu/hw.c:654:3: error: ‘valueLow’ undeclared (first use in this function)
  654 |   valueLow = QUEUE_LOW;
      |   ^~~~~~~~
make[3]: *** [scripts/Makefile.build:281: /home/dilara/rtlwifi_new-master/rtl8192cu/hw.o] Error 1
make[2]: *** [scripts/Makefile.build:524: /home/dilara/rtlwifi_new-master/rtl8192cu] Error 2
make[1]: *** [Makefile:1879: /home/dilara/rtlwifi_new-master] Error 2
make[1]: Leaving directory '/usr/src/linux-headers-5.13.0-28-generic'
make: *** [Makefile:76: all] Error 2

You did say you tried disabling all sorts of power management, but you didn't specifically state which commands that you use. Because of this, I am recommending this... A master command for disabling power management!

CTRL ALT T to enter terminal.

xset -dpms

Hope this helps!


1 Like

I've tried now, thank you very much. I didn't try this command. I'll wait and see the results, and come back and reply.

1 Like

It, also, does not like the 5.13 kernel...

Have you considered changing your kernel?

sudo apt install linux-headers-5.8.0-63-generic linux-modules-5.8.0-63-generic linux-modules-extra-5.8.0-63-generic linux-image-5.8.0-63-generic

Tap esc or tab at the grub menu to enter Advanced Options for Zorin and arrow key to Zorin on the 5.8.0-63 kernel and test.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.