Realtek wifi network unclaimed Zorin 16.3

Connect with ethernet or phone hotspot.

git clone

cd rtw89


sudo make install

sudo modprobe rtw89pci

1 Like

Yes, did that and got this

Instead try:

sudo apt install dh-sequence-dkms debhelper build-essential devscripts

git deborig HEAD

dpkg-buildpackage -us -uc

sudo apt install ../rtw89-dkms_1.0.2-3_all.deb

Another issue

I got those commands directly from the GitHub page I linked above.

Looking up dh-sequence-dkms, it looks like the package first appears in later versions of Ubuntu and in Sid.

I am in the middle of other work right now - please allow some time that I can look into this later or another forum member can provide some help.

1 Like

Well, I know you are on the 6.3 kernel.
Can you also show the terminal output for

sudo lshw -C network


Sorry for delay. I installed latest 16.3 pro version, but still no wifi .

Let's try


The lshw command gives a very generic response in this case.

1 Like

And this is what I got on Arch

That shows RTL89... Which we tried in post 1 of this thread.

There is a minor difference: lwfingers is directed toward 8851... Your Arch screenshot shows 8852be
We can try:

#Turn off your Security Boot in BIOS

git clone

cd rtl8852be

make -j8

sudo make install

sudo modprobe 8852be

1 Like

Thanks, this working perfect. I got my wifi back :slight_smile:

1 Like

What a difference a number makes...

1 Like

Yeah :slight_smile:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.