Regular crashes with Gimp

I use Gimp regularly for picture/photo cropping, resolution changes, etc etc and have never really had any problems with it under Zorin.
But it has been very touchy in the past few weeks or so. Sometimes it won't even fire up, whether that be from the menu or from the desk icon. Even when it does, it will occasionally bomb out when I try to open a file for processing. Now and then, the use of a special Artistic filter will also crash the program.
It is version 2.10.30
Does anyone here use Gimp regularly and have they had problems with it?

Admittedly, I have been transitioning from Gimp to other image editors due to a long standing bug in Gimp that getting the Gnome Developers to address, acknowledge and actually fix is like pulling teeth.

But I do use it regularly enough to comment.
Gimp generally tends to get pretty unstable after updates or patches are applied by the developer requiring a bit of a waiting period for the next update to stabilize it again.
And, in my opinion/observation, this appears to be a recent thing - it began in the last couple of years. It did not used to be this way.

What you might try is completely removing Gimp and reinstalling it to see it that improves things any.

OK, I could certainly try that. I think it was pre-installed with the Zorin17 Pro (can't recall properly). It's very annoying because I've used the program for years, after running with PaintShop Pro for an equal number of years on Windows. My alternative is being forced to use Gimp on Windows10, on the spare laptop.

Well. That proved interesting. I removed Gimp, and then installed it again....in doing so, I found that the version had "gone up" from 2.10.30 to 2.10.36
OK....all installed. Tried it out, all ok, until this afternoon, when I spent ten minutes on a cropping and resizing exercise with a photo. Was just about to hit "export" to save it, and the wretched app closed down on me, losing all my work.
Not Zorin's fault, I guess, but something's very wrong, this is unstable....shall go off to the Gimp site and look for bugs...

1 Like

Is it flatpak or .deb (Zorin OS)?

Now that's the thing I wasn't aware of; having removed the Gimp that came with my ZorinPro, I went to the software page, located Gimp again and just hit download....without realising that I was actually downloading a Flatpak (which just happens to be 2.10.36).
Aargh, too many options to trick the unwary. I have been back yet again, got rid of the Flatpak version and now loaded the .deb
So I've now gone full circle....will have to re-test to see if it's behaving or not...

Just thought I should round this up and give a conclusion. I eventually went to the Zorin team directly and they suggested I checked my .iso file to ensure that the SHA256 checksum was matching.
Now...this is odd, because I had checked it before the initial install, and it was showing ok. Similarly with the on-screen checks that come up while installing from the usb stick. Otherwise I wouldnt have gone ahead installing.
Anyway....I did recheck the iso and the sums didn't match....so that meant having to download a replacement iso, which for me is a bit of a slog because I have to go to someone else's house who has superfast broadband. Final result is that having done all the checks again and re-installed, I do not appear to have any Gimp problems now; nor indeed with a few other things such as Vivaldi and Krita, both of which were bailing out on me every day.
So....the mysteries of iso files. I'll consider this solved now.

2 Likes

It is always good to check a .iso SHA256 against published value prior to use, in your case prior to any use.

As you said "I'll consider this solved now", I have therefore marked your last post as Solution.

1 Like