Regular system updates not happening

When using Z15Ultimate, I always used to see a regular software update dialogue box, informing me of updates for system, browser, whatever. Since installing the Z16 equivalent, I never see it at all; that is, it doesn't appear automatically, like it used to.
If I select the Updater from the menu, it will open up but most times tells me that it has failed to download from the repository (image 1). My internet connection is live, although it is a slow UK rural speed.
What I DO notice is that some software does get updated in the background, for example I may see a small flag come up telling me that Blender or some such application has been updated. Is this now the way it works?
It puzzles me because I don't seem to recall seeing any updates for the main operating system; and this is unusual because they used to appear regularly under Z15. It is a concern because I am still having problems with opening applications such as Thunderbird (I posted this on a previous thread); having given up on that I moved to Evolution, which is now displaying the same problems (failing to open from the desktop icon and I have to trigger it from the terminal). There's something not right.

1 Like
sudo apt update && sudo apt full-upgrade
3 Likes

Thanks Turtle, I'm still not really up to speed with all these terminal commands. I'll go and try it now, and report back.

1 Like

Well that all ran ok; the only oddity was a GPG error relating to my Brave browser:
The following signature could not be verified because the public key was not available: No Pub Key (followed by a long number).
Guess this is an entirely different issue, so will have to look at that separately.
Evolution opened ok without crashing, let's hope it stays that way so I can say "solved".

How did you install Brave browser. Updates to Snap and Flatpak apps update differently from apt ones.

I did it from the repository; the current snapcraft version is 1.46.144 and that appears to be what is shown in the Brave browser's "About" section.

Version 1.46.144 Chromium: 108.0.5359.128 (Official Build) unknown (64-bit)
It's not giving me any problems right now, so am leaving it well alone. If it does, I'll start a new post.

1 Like

What I did was set up a key combination.

Zorin menu > Settings > Keyboard shortcuts

Scroll all the way to the bottom, click the '+' button, then enter:
Name: Update All
Command: gnome-terminal -- /bin/sh -c 'echo Updating; sleep 5; sudo apt update; sudo apt full-upgrade; sudo fwupdmgr refresh --force; sudo fwupdmgr update; sudo flatpak update; sudo snap refresh; sudo apt autoremove; sudo apt autoclean; sudo apt purge; sudo apt update --fix-missing; sleep 30'
Shortcut: Super+U

That updates everything... apt packages, flatpaks, snaps, firmware. It also automatically purges unused packages and fixes any dependency issues.