Reinitialize layout of usb stick

Hi, I am trying to use my USB stick to download Zorin lite for my wife's computer and I am in disks, but I get an error saying:

The partition can not be modified because it contains a partition table; please reinitialize the whole device.

I have no idea how I can do this. Can anyone guide me in the right direction, please?

1 Like

Delete any existing partitions and reformat using either fat32, exfat or ntfs (exfat or ntfs are preferred for large file sizes [above 4gb]).

It wont let me delete it.
Screenshot from 2022-12-09 14-58-11

And I am not very techy with this :slight_smile:

Is the disk mounted? If it has a square stop button on the partition it is mounted. It must be unmounted to make changes.

Once unmounted, you can select the partition in the window (click on it) then hit the minus sign to remove the partition.

It says it is not mounted.

Would you provide a screenshot?

That's what I keep trying but I get the error shown in the screenshot above

Of the disks window without the error.

Screenshot from 2022-12-09 14-58-11

Try hitting the gear and changing the disk type to gpt, it will require you to format.

That usb drive may not be large enough to download the iso to. I believe it's about 4GB, which is 900MB larger than your drive can hold. A little more than that is required to run the iso as well.

Its 16 gb and has old zorin installation on it and I want to get rid off it and put the lite version on it.

I hit the gear icon and changed it to gpt but nothing happend. Now it looks like it just changed to gpt?!?

It will say it at the top of the window, where it was master boot record, next to partitioning.

Then delete any partitions and select the unallocated space, right click and add partition, choose an fs and the entire drive.

You could attempt to format the free space, and leave the first partition alone.

I tried both and I keep getting the same error. I am not able to partition the free space either.

Try removing it, plugging it back in and then open disks again


HAhaha your kidding. It worked!

1 Like

Thanks for your help. Got to remember to turn things on and off again. Thanks

1 Like

I think there was an error in one of the processes when you were trying to access it before either it wasn't mounted or mounted And that's what caused it

1 Like